Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED-PARTIALY]compiz pb with metacity 2.28
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Ray ishido
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2006
Posts: 141
Location: Piracicaba (Brazil)

PostPosted: Fri Oct 09, 2009 2:55 am    Post subject: [SOLVED-PARTIALY]compiz pb with metacity 2.28 Reply with quote

hi

just updated to gnome 2.28 and a pb appears with compiz: when I run "compiz --replace --loose-binding ccp" the cpu usage stick around 30%-40%
it appears that Xorg uses about 7%, compiz 7%, gconfd-2 6%, metacity 4%, gnome session 2%, dbus-deamon 2%
I re-emerge mesa, nvidia drivers, compiz (all package), xorg-x11, x11-server, at least 3 times, and of course revdep-rebuild, but the pb is still here.
note nvidia-drivers doesn't upgrade and mesa upgrades from 7.4.4 to 7.4.2
note2: libxcb also ugrades. I followed the howto and (I supposed that) everythings ok

does anybody else have the same pb?

[EDIT]: the pb is solved if I manually kill metacity before running compiz, so it's a pb between of compatibility between metacity 2.28 and compiz. I'll fill a bug report today.

to partialy solved the pb I use this script to run compiz

Code:
killall metacity && compiz --loose-binding ccp &




emerge --info

Code:
ray@raoul ~ $ emerge --info
Portage 2.1.6.13 (default/linux/x86/2008.0, gcc-4.3.3, glibc-2.10.1-r0, 2.6.29-gentoo i686)
=================================================================
System uname: Linux-2.6.29-gentoo-i686-Genuine_Intel-R-_CPU_T2050_@_1.60GHz-with-gentoo-2.0.1
Timestamp of tree: Tue, 06 Oct 2009 02:30:01 +0000
app-shells/bash:     4.0_p33
dev-java/java-config: 2.1.9-r1
dev-lang/python:     2.5.4-r2, 2.6.3, 3.1.1-r1
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    2.1
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=native -Os -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=native -Os -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS=" #ftp://mirror.ovh.net/gentoo-distfiles #ftp://gentoo.imj.fr/pub/gentoo/ #ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo/ #      http://ftp.club-internet.fr/pub/mirrors/gentoo"
LANG="fr_FR.UTF-8"
LC_ALL="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="fr"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/portage/layman/gnome /usr/local/portage/layman/desktop-effects"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi aiglx alsa asf battery berkdb bmp bzip2 cairo cdr cli cracklib crypt cups dbus dri dvd dvdr encode esd exif ffmpeg firefox fortran gdbm gif glitz gnome gnome-keyring gpm gtk gtk2 hal iconv isdnlog java javascript jpeg lirc mad modules mp3 mpeg mudflap nautilus ncurses networkmanager nls nptl nptlonly nvidia opengl openmp pam pcre perl pic pmu png pppd readline reflection reiserfs session smp spl sqlite sqlite3 sse sse2 ssl svg sysfs tcpd tiff truetype unicode usb vorbis wifi win32codecs x264 x86 xcomposite xml xorg zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2 canon" ELIBC="glibc" INPUT_DEVICES="keyboard mouse wacom evdev joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


xorg.conf
Code:
ray@raoul ~ $ cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Tue May 12 12:47:02 PDT 2009

Section "InputDevice"
    Driver        "wacom"
    Identifier    "stylus"
    Option        "Device"       "/dev/input/wacom"
    Option        "Type"         "stylus"
    Option        "USB"          "on"                 # USB ONLY
#    Option        "Mode"         "Relative"           # other option: "Absolute"
    Option        "Vendor"       "WACOM"
#    Option        "tilt"         "on"  # add this if your tablet supports tilt
    Option        "Threshold"    "99"   # the official linuxwacom howto advises this line
EndSection
Section "InputDevice"
    Driver        "wacom"
    Identifier    "eraser"
    Option        "Device"       "/dev/input/wacom"
    Option        "Type"         "eraser"
    Option        "USB"          "on"                  # USB ONLY
#    Option        "Mode"         "Relative"            # other option: "Absolute"
    Option        "Vendor"       "WACOM"
#    Option        "tilt"         "on"  # add this if your tablet supports tilt
#    Option        "Threshold"    "5"   # the official linuxwacom howto advises this line
EndSection
Section "InputDevice"
  Driver        "wacom"
  Identifier    "pad"
#  Option        "Device"        "/dev/ttyS0"          # SERIAL ONLY
  Option        "Device"        "/dev/input/wacom"   # USB ONLY
  Option        "Type"          "pad"
  Option        "USB"           "on"                  # USB ONLY
EndSection

Section "ServerLayout"

##   InputDevice "cursor" "SendCoreEvents"  # add these 3 lines
   InputDevice "stylus" "SendCoreEvents"
   InputDevice "eraser" "SendCoreEvents"
   InputDevice "pad"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
    Option         "AIGLX" "false"
EndSection

Section "Files"

#   RgbPath      "/usr/share/X11/rgb"
    ModulePath      "/usr/lib/xorg/modules"
    FontPath        "/usr/share/fonts/misc/"
    FontPath        "/usr/share/fonts/TTF/"
    FontPath        "/usr/share/fonts/OTF"
    FontPath        "/usr/share/fonts/Type1/"
    FontPath        "/usr/share/fonts/CID/"
    FontPath        "/usr/share/fonts/100dpi/"
    FontPath        "/usr/share/fonts/75dpi/"
EndSection

Section "Module"

#   Load  "type1"
#   Load  "nv-control"
    Load           "glx"
    Load           "extmod"
    Load           "xtrap"
    Load           "record"
    Load           "dbe"
#    Load      "wacom"
#   Load  "freetype"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbModel" "pc102"
    Option         "XkbLayout" "fr-latin9"
EndSection

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
#   Option       "Device" "/dev/input/mouse_udev"
    Option         "Device" "/dev/input/mice"
    Option         "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Monitor Vendor"
    ModelName      "Monitor Model"
    Option         "DPMS" "true"
EndSection

Section "Device"
   Option      "AddARGBGLXVisuals"   "true"
   Option "BackingStore" "True"
#   Option     "EnablePageFlip" "True"
   Option "RenderAccel" "true"
#   Option "DisableGLXRootClipping" "true"
#   Option "AllowGLXWithComposite" "true"
   Option "DamageEvents" "true"
   Option "UseEvents" "False"
   Option "Triplebuffer" "True"
##   Option "AllowDDCCI" "true"

# section pour definir les perf de la carte
# autorise fixer manuelement le niveau de perf:
   Option "Coolbits" "1"

# max perf
Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerDefault=0x3; PowerMizerDefaultAC=0x1"

# med perf
#Option "RegistryDwords" "PowerMizerLevel=0x2"

#powersave
#Option "RegistryDwords" "PowerMizerLevel=0x3"



##TV out section
##   Option      "TVStandard" "PAL-B"
##   Option      "TVOutFormat" "COMPOSITE"
##   Option      "TVOverScan" "0.6"
##   Option      "ConnectedMonitor" "TV" # Add this if you're having problems
    Identifier     "Card0"
    Driver         "nvidia"
    VendorName     "nVidia Corporation"
    BoardName      "Unknown Board"
EndSection

Section "Screen"

#      Viewport   0 0
#      Depth     1
#   EndSubSection
#   SubSection "Display"
#      Viewport   0 0
#      Depth     4
#   EndSubSection
#   SubSection "Display"
#      Viewport   0 0
#      Depth     8
#   EndSubSection
#   SubSection "Display"
#      Viewport   0 0
#      Depth     15
#   EndSubSection
#   SubSection "Display"
#      Viewport   0 0
#      Depth     16
#   EndSubSection
    Identifier     "Screen0"
    Device         "Card0"
    Monitor        "Monitor0"
    Option         "AddARGBGLXVisuals" "true"
    Option         "DisableGLXRootClipping" "true"
#   SubSection "Display"
    SubSection     "Display"
        Viewport    0 0
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
    Option         "RENDER" "Enable"
EndSection


Xorg.0.log (part of it)
Code:
(==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "RenderAccel" "true"
(**) NVIDIA(0): Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerDefault=0x3; PowerMizerDefaultAC=0x1"
(**) NVIDIA(0): Option "Coolbits" "1"
(**) NVIDIA(0): Option "TripleBuffer" "True"
(**) NVIDIA(0): Option "UseEvents" "False"
(**) NVIDIA(0): Option "AddARGBGLXVisuals" "true"
(**) NVIDIA(0): Option "DisableGLXRootClipping" "true"
(**) NVIDIA(0): Option "DamageEvents" "true"
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0):     enabled.
(II) NVIDIA(0): NVIDIA GPU GeForce Go 7300 (G72) at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 262144 kBytes
(--) NVIDIA(0): VideoBIOS: 05.72.22.41.42
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce Go 7300 at PCI:1:0:0:
(--) NVIDIA(0):     LPL (DFP-0)
(--) NVIDIA(0): LPL (DFP-0): 330.0 MHz maximum pixel clock
(--) NVIDIA(0): LPL (DFP-0): Internal Dual Link LVDS
(II) NVIDIA(0): Assigned Display Device: DFP-0
(==) NVIDIA(0):
(==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
(==) NVIDIA(0):     will be used as the requested mode.
(==) NVIDIA(0):
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 1280 x 800
(--) NVIDIA(0): DPI set to (98, 96); computed from "UseEdidDpi" X config
(--) NVIDIA(0):     option
(**) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC?  No, I don't.
(II) resource ranges after preInit:
   [0] -1   0   0xffffffff - 0xffffffff (0x1) MX[B]
   [1] -1   0   0x000f0000 - 0x000fffff (0x10000) MX[B]
   [2] -1   0   0x000c0000 - 0x000effff (0x30000) MX[B]
   [3] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX[B]
   [4] -1   0   0x0000ffff - 0x0000ffff (0x1) IX[B]
   [5] -1   0   0x00000000 - 0x00000000 (0x1) IX[B]
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
(II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
(II) NVIDIA(0):     configuration option may not be set correctly.  When the
(II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
(II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
(II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
(II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
(II) NVIDIA(0):     Config Options in the README.
(II) NVIDIA(0): Setting mode "nvidia-auto-select"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(==) NVIDIA(0): Disabling shared memory pixmaps
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(**) NVIDIA(0): Option "BackingStore" "True"
(**) NVIDIA(0): Backing store enabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms" "true"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(II) Loading extension XINERAMA
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum