Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Python very broken
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
microtechno
Apprentice
Apprentice


Joined: 17 Apr 2006
Posts: 224
Location: Adelaide, Australia

PostPosted: Sat Oct 10, 2009 2:05 am    Post subject: Python very broken Reply with quote

Hi
I am running sabayon but this is a problem that has occured with the emerge/portage portion of sabayon. Hope that somone in here can help.
I unmerged python 3.2 and 2.6 because i was problems with python. Software wasnt running so i though I would go back to 2.5. Big mistake because entropy and portage as it would seem use 2.6.
I followed this
Code:
# cd
# tar xzf /usr/portage/distfiles/Python-2.2.1.tgz
# cd Python-2.2.1
# ./configure --with-fpectl --infodir=/usr/share/info/ --mandir=/usr/share/man
# make
# make install prefix=/usr
# rm /usr/bin/python 2>/dev/null
# ln -s /usr/bin/python2 /usr/bin/python

from https://forums.gentoo.org/viewtopic-p-27900.html#27900
Changing it for the 2.6 version. This gets me to being able to run emerge and try to reemerge python. But this then comes up during the emerge of python
Code:
 * Searching all installed packages for file collisions...
 *
 * Press Ctrl-C to Stop
 *
 * None of the installed packages claim the file(s).
 *
 * Package 'dev-lang/python-2.6.2-r2' NOT merged due to file collisions.
 * If necessary, refer to your elog messages for the whole content of the
 * above message.

>>> Failed to install dev-lang/python-2.6.2-r2, Log file:

>>>  '/var/lib/entropy/logs/dev-lang:python-2.6.2-r2:20091010-015514.log'

There are a lot of files listed, although they are not mensioned in the .log There are more collisions than the scroll back will go.
If someone could help that would be great, I kind of need python2.6 for entropy and portage.
Microtechno
_________________
The next statement is true.......The last statement was false..
My Computer
Asus M2N-SLI Deluxe MB
AMD X2 6000+
3GB DDR 667
Gigabyte ATI Radeon 2900XT
Dual Boot Vista/Gentoo (Gnome)
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43546
Location: 56N 3W

PostPosted: Sat Oct 10, 2009 12:46 pm    Post subject: Reply with quote

microtechno,

Go to tinderbox.dev.gentoo.org (or to Sabayons equivelent) and get the binary python you need
Put the tarball into your / root
Code:
do cd /
tar xjpf <tarball>

Ignore the warning about extra garbage at end ignored.

Rebuild python and portage then run python-updater.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43546
Location: 56N 3W

PostPosted: Sat Oct 10, 2009 12:47 pm    Post subject: Reply with quote

Moved from Portage & Programming to Unsupported Software.
As we don't support Sabayon here
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
microtechno
Apprentice
Apprentice


Joined: 17 Apr 2006
Posts: 224
Location: Adelaide, Australia

PostPosted: Sun Oct 11, 2009 1:59 am    Post subject: Reply with quote

thanks, thought I would post it here because its a portage error that I am getting.
_________________
The next statement is true.......The last statement was false..
My Computer
Asus M2N-SLI Deluxe MB
AMD X2 6000+
3GB DDR 667
Gigabyte ATI Radeon 2900XT
Dual Boot Vista/Gentoo (Gnome)
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43546
Location: 56N 3W

PostPosted: Sun Oct 11, 2009 11:20 am    Post subject: Reply with quote

microtechno,

Its not that we won't help.
Answers to some Sabayon issues do not apply to Gentoo so we keep things segregated for users searching he forums later.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum