Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge] probleme apres une emerge -uavDN world
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Sat Oct 10, 2009 12:48 pm    Post subject: [emerge] probleme apres une emerge -uavDN world Reply with quote

Hello a tous,

Je viens de faire un emerge -uavDN world, il m'a averti d'un emerge failed :

Code:
>>> Failed to emerge media-video/vlc-1.0.2, Log file:

>>>  '/var/tmp/portage/media-video/vlc-1.0.2/temp/build.log'

 * Messages for package media-video/vlc-1.0.2:

 * USE=bidi requires truetype, bidi will be disabled.
 *
 * ERROR: media-video/vlc-1.0.2 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3987:  Called base_src_compile
 *             environment, line  637:  Called base_src_work 'make'
 *             environment, line  751:  Called die
 * The specific snippet of code:
 *                       emake || die "died running emake, $FUNCNAME:make";
 *  The die message:
 *   died running emake, base_src_work:make
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-video/vlc-1.0.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-video/vlc-1.0.2/temp/environment'.
 *


voici le contenu du log /var/tmp/portage/media-video/vlc-1.0.2/temp/build.log :

Code:
 ^[[32;01m*^[[0m   320_all_disable_media_list_player_tests.patch ...
^[[A^[[180C  ^[[34;01m[ ^[[32;01mok^[[34;01m ]^[[0m
 ^[[32;01m*^[[0m   530_all_older_xcb_xv.patch ...
^[[A^[[180C  ^[[34;01m[ ^[[32;01mok^[[34;01m ]^[[0m
 ^[[32;01m*^[[0m   540_all_x264.patch ...
^[[A^[[180C  ^[[34;01m[ ^[[32;01mok^[[34;01m ]^[[0m
 ^[[32;01m*^[[0m   550_all_nofc.patch ...
^[[A^[[180C  ^[[34;01m[ ^[[32;01mok^[[34;01m ]^[[0m
 ^[[32;01m*^[[0m   560_all_kateppc.patch ...
^[[A^[[180C  ^[[34;01m[ ^[[32;01mok^[[34;01m ]^[[0m
 ^[[32;01m*^[[0m Done with patching
 ^[[32;01m*^[[0m Running eautoreconf in '/var/tmp/portage/media-video/vlc-1.0.2/work/vlc-1.0.2' ...
 ^[[32;01m*^[[0m Running aclocal -I m4 -I m4 -I /var/tmp/portage/media-video/vlc-1.0.2/work/vlc-m4 ...
^[[A^[[180C  ^[[34;01m[ ^[[32;01mok^[[34;01m ]^[[0m
 ^[[32;01m*^[[0m Running libtoolize --copy --force --install --automake ...
^[[A^[[180C  ^[[34;01m[ ^[[32;01mok^[[34;01m ]^[[0m
 ^[[32;01m*^[[0m Running aclocal -I m4 -I m4 -I /var/tmp/portage/media-video/vlc-1.0.2/work/vlc-m4 ...


je l'ai donc désinstaller en usant emerge -C vlc et ensuite faire un revdep-rebuild mais je me suis trompe et ai re emerger vlc, donc je l'ai arrêter, maintenant il reste bloquer sur :

Code:

>>> Emerging (2 of 2) media-video/vlc-1.0.2
 * waiting for lock on /var/tmp/portage/.media-video.portage_lockfile
 ...


donc la je suis paumer, j'ai aussi essayer un emerge --resume, j'ai finalement taper rev-dep-rebuild > même problème quand il s'appercoit que vlc est casse

j'ai un peut regarder les log d'emerge et voici ce que donne le emerge-fetch.log et emerge.log :

Code:
tail: /var/log/emerge-fetch.log: file truncated
 * vlc-m4-1.tar.bz2 size ;-) ...                                         [ ok ]
 * vlc-patches-77.tar.bz2 size ;-) ...                                   [ ok ]
 * vlc-1.0.2.tar.bz2 size ;-) ...                                        [ ok ]

.
Code:
1255185277:  >>> emerge (2 of 2) media-video/vlc-1.0.2 to /



a aprtir de la ca s'arrête sec, plus aucune action, dans el top, pas de service en relation actif.
_________________
un noob parmis tant d'autre noob
Back to top
View user's profile Send private message
GentooUser@Clubic
l33t
l33t


Joined: 01 Nov 2004
Posts: 829

PostPosted: Sat Oct 10, 2009 12:58 pm    Post subject: Reply with quote

Bah si tu est sûr de n'avoir aucun process d'emerge en cours tu peut virer la lockfile normalement emerge devrait re-marcher après.
Back to top
View user's profile Send private message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Sat Oct 10, 2009 1:02 pm    Post subject: Reply with quote

merci beaucoup de ta réponse emerge est repartit,
mais a la fin il me met toujours failed to merge vlc.
_________________
un noob parmis tant d'autre noob
Back to top
View user's profile Send private message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Sat Oct 10, 2009 1:33 pm    Post subject: Reply with quote

je met a jour le code du log :

Code:
libtool: link: x86_64-pc-linux-gnu-gcc -std=gnu99 -shared  .libs/libglx_plugin_la-glx.o .libs/libglx_plugin_la-xcommon.o  -Wl,--whole-archive ../../../compat/.libs/libcom$
/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lGL
collect2: ld returned 1 exit status
make[6]: *** [libglx_plugin.la] Error 1
make[6]: *** Waiting for unfinished jobs....
libtool: link: ( cd ".libs" && rm -f "libxvideo_plugin.la" && ln -s "../libxvideo_plugin.la" "libxvideo_plugin.la" )
make[6]: Leaving directory `/var/tmp/portage/media-video/vlc-1.0.2/work/vlc-1.0.2/modules/video_output/x11'
make[5]: *** [all] Error 2
make[5]: Leaving directory `/var/tmp/portage/media-video/vlc-1.0.2/work/vlc-1.0.2/modules/video_output/x11'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/var/tmp/portage/media-video/vlc-1.0.2/work/vlc-1.0.2/modules/video_output'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/var/tmp/portage/media-video/vlc-1.0.2/work/vlc-1.0.2/modules/video_output'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/media-video/vlc-1.0.2/work/vlc-1.0.2/modules'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-video/vlc-1.0.2/work/vlc-1.0.2'
make: *** [all] Error 2
 ^[[31;01m*^[[0m
 ^[[31;01m*^[[0m ERROR: media-video/vlc-1.0.2 failed.   
 ^[[31;01m*^[[0m Call stack:
^[[31;01m*^[[0m               ebuild.sh, line   49:  Called src_compile
 ^[[31;01m*^[[0m             environment, line 3983:  Called base_src_compile
 ^[[31;01m*^[[0m             environment, line  633:  Called base_src_work 'make'
 ^[[31;01m*^[[0m             environment, line  747:  Called die
 ^[[31;01m*^[[0m The specific snippet of code:
 ^[[31;01m*^[[0m                       emake || die "died running emake, $FUNCNAME:make";
 ^[[31;01m*^[[0m  The die message:
 ^[[31;01m*^[[0m   died running emake, base_src_work:make
 ^[[31;01m*^[[0m
 ^[[31;01m*^[[0m If you need support, post the topmost build error, and the call stack if relevant.
 ^[[31;01m*^[[0m A complete build log is located at '/var/tmp/portage/media-video/vlc-1.0.2/temp/build.log'.
 ^[[31;01m*^[[0m The ebuild environment file is located at '/var/tmp/portage/media-video/vlc-1.0.2/temp/environment'.
 ^[[31;01m*^[[0m

_________________
un noob parmis tant d'autre noob
Back to top
View user's profile Send private message
GentooUser@Clubic
l33t
l33t


Joined: 01 Nov 2004
Posts: 829

PostPosted: Sat Oct 10, 2009 3:30 pm    Post subject: Reply with quote

Quote:
ld: cannot find -lGL

Faut peut-être sélectionner l'implémentation d'openGL avec eselect opengl
Back to top
View user's profile Send private message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Sat Oct 10, 2009 3:33 pm    Post subject: Reply with quote

j'ai fait ca aussi, j'ai selectionne le X11, c'etait le seul, et un eselect opengl show me donne bien xorg-x11

j'ai egalement fai un ccache -C et reinstaller libdca-0.0.5-r2 et ajouter le USE dts, meme probleme
_________________
un noob parmis tant d'autre noob
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1699
Location: 127.0.0.1

PostPosted: Sat Oct 10, 2009 4:59 pm    Post subject: Reply with quote

Hello,

Fais voir ton emerge --info et emerge -pv vlc.
Back to top
View user's profile Send private message
GentooUser@Clubic
l33t
l33t


Joined: 01 Nov 2004
Posts: 829

PostPosted: Sat Oct 10, 2009 5:49 pm    Post subject: Reply with quote

Et ls /usr/lib*/libGL.* aussi
Back to top
View user's profile Send private message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Sat Oct 10, 2009 6:24 pm    Post subject: Reply with quote

Hello,

merci à tous de vos réponses, voici les résultats :


emerge -pv vlc
Code:
These are the packages that would be merged, in order:

Calculating dependencies   ... done!
[ebuild  N    ] media-video/vlc-1.0.2  USE="X a52 aac alsa bidi cdda cdio dts dvd ffmpeg flac gcrypt gnutls hal httpd live matroska mmx mpeg ncurses ogg opengl qt4 sse stream theora vlm xv -aalib (-altivec) -atmo -avahi -cddax -cddb -dbus -dc1394 -debug -dirac -directfb -dvb -fbcon -fluidsynth -fontconfig -ggi -gnome -id3tag -ieee1394 -jack -kate -libass -libcaca -libnotify -libproxy -libsysfs -libtiger -libv4l2 -lirc -lua -modplug -mp3 -mtp -musepack -nsplugin -optimisememory -oss (-pda) -png -pulseaudio -pvr -remoteosd -rtsp -run-as-root -samba -schroedinger -sdl -sdl-image -seamonkey -shine -shout -skins -speex -svg (-svga) -taglib -truetype -twolame -upnp -v4l -v4l2 -vcdinfo -vcdx -vorbis (-win32codecs) -wma-fixed -x264 -xcb -xinerama -xml -xosd -zvbi" 0 kB

Total: 1 package (1 new), Size of downloads: 0 kB

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.



ls /usr/lib*/libGL.*
Code:

/usr/lib32/libGL.so



emerge --info
Code:

Portage 2.1.6.13 (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r5 x86_64)
=================================================================
System uname: Linux-2.6.30-gentoo-r5-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E8400_@_3.00GHz-with-gentoo-1.12.11.1
Timestamp of tree: Sat, 10 Oct 2009 16:55:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:     4.0_p28
dev-lang/python:     2.4.4-r13, 2.5.4-r3, 2.6.2-r1
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl alsa amd64 berkdb bidi bzip2 cdda cdio cli cracklib crypt cups dri dts dvd encode ffmpeg flac fortran freetype gdbm gnutls gpm hal httpd iconv ipv6 isdnlog kde live mad matroska mmx modules mpeg mudflap multilib ncurses nls nptl nptlonly nvidia ogg oggvorbis opengl openmp pam pcre perl pppd python qt3 qt4 readline reflection session spl sse sse2 ssl stream sysfs tcpd theora unicode vcd vlm wxwindows xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY


j'ai lu aussi qu'il serait pa sinutile de changer de

CXXFLAGS="-march=nocona -O2 -pipe"

à

CXXFLAGS="-march=native -O2 -pipe"

pourrait regler ce genre de souci de compil qu'en pensez-vous ? ( je sais pas trop comment changer de maniere optimale ce CXXFLAGS sans peter mes compils :(

là je fais un emerge -e vlc au cas ou, mais je doute :)
_________________
un noob parmis tant d'autre noob
Back to top
View user's profile Send private message
Biloute
Guru
Guru


Joined: 03 Apr 2008
Posts: 364
Location: LENS

PostPosted: Sat Oct 10, 2009 7:02 pm    Post subject: Reply with quote

:idea: Est-ce que tu as vraiment besoin de bidi? :idea:
Tu compiles vlc avec USE=" bidi " mais apparement il est ignoré peut-être qu'en mettant USE=" -bidi " dans /etc/make.conf et recompiler avec
Code:
# emerge --newuse world

résoudrait l'affaire.
_________________
Gentoo rocks
Back to top
View user's profile Send private message
GentooUser@Clubic
l33t
l33t


Joined: 01 Nov 2004
Posts: 829

PostPosted: Sat Oct 10, 2009 7:03 pm    Post subject: Reply with quote

C'est un problème de link changer les C[XX]FLAGS ni changera rien

Code:
/usr/lib32/libGL.so

Pas normal si ta un /usr/lib32/ je suppose que tu est en amd64 multilib tu devrait donc aussi avoir /usr/lib64/libGL.so ainsi que /usr/lib/libGL.so /usr/lib/ étant un liens vers /usr/lib64/.

Chez moi :
Code:
% ls /usr/lib*/libGL.*
/usr/lib32/libGL.la   /usr/lib64/libGL.la   /usr/lib/libGL.la
/usr/lib32/libGL.so@  /usr/lib64/libGL.so@  /usr/lib/libGL.so@


Essai de re-emerger mesa (emerge -1 mesa) et encore eselect opengl set xorg-x11 après
Back to top
View user's profile Send private message
GentooUser@Clubic
l33t
l33t


Joined: 01 Nov 2004
Posts: 829

PostPosted: Sat Oct 10, 2009 7:06 pm    Post subject: Reply with quote

Biloute wrote:
:idea: Est-ce que tu as vraiment besoin de bidi? :idea:
Tu compiles vlc avec USE=" bidi " mais apparement il est ignoré peut-être qu'en mettant USE=" -bidi " dans /etc/make.conf et recompiler avec
Code:
# emerge --newuse world

résoudrait l'affaire.

Pense pas que ça ait grand chose à voir avec bidi (rendu bidirectionnel du texte) mais en effet cet useflag est inutile pour vlc si truetype n'est pas aussi activé.

Si l'objectif c'est juste d'avoir VLC qui compile virer le flag opengl suffirait ! Mais vaut mieux régler le problème à sa source.
Back to top
View user's profile Send private message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Sat Oct 10, 2009 7:45 pm    Post subject: Reply with quote

je vais attendre la fin de emerge -e vlc qui a 194 paquet à re emerger avant de changer le make.conf en pleine compll ^^, ensuite je fais le emerge mesa en modifiant mon make.conf en use -bidi et je refais un emerge --newuse world.

je précise quand meme que cette erreur était là avant le use bidi, c'est justement en parcourant les forum pour ce probleme de vlc qu'il a été demander de mettre le bidi.


en tout cas merci beaucoup de vos réponses rapides
_________________
un noob parmis tant d'autre noob
Back to top
View user's profile Send private message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Sat Oct 10, 2009 8:45 pm    Post subject: Reply with quote

euh, ben je comprend pas trop, le emerge -e vlc a fonctionne, j'ai bien vlc il fonctionne bien maintenant meme apres un revdep-rebuild qui n'a pas abouti, une explication ?


en tout cas merci de vos réponses :)
_________________
un noob parmis tant d'autre noob
Back to top
View user's profile Send private message
GentooUser@Clubic
l33t
l33t


Joined: 01 Nov 2004
Posts: 829

PostPosted: Sat Oct 10, 2009 9:08 pm    Post subject: Reply with quote

emerge -e vlc réinstalle vlc et toutes se dépendances directes ou indirecte même si elle sont déjà installées.
Ça a réinstallé mesa au passage, je pense vraiment que le problème venait de ce paquet.

Que donne ls /usr/lib*/libGL.* maintenant ?
Back to top
View user's profile Send private message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Sun Oct 11, 2009 9:04 am    Post subject: Reply with quote

Code:
lux ~ #  ls /usr/lib*/libGL.*
/usr/lib/libGL.la  /usr/lib32/libGL.so  /usr/lib64/libGL.so
/usr/lib/libGL.so  /usr/lib64/libGL.la


tout niquel :-), merci de ces précisions, j'aime pas trop faire sans comprendre pourquoi :)
_________________
un noob parmis tant d'autre noob
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum