Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Firefox [Mozilla-Overlay] ebuild fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
indietrash
Guru
Guru


Joined: 17 Sep 2008
Posts: 353
Location: Norway

PostPosted: Fri Oct 16, 2009 5:50 pm    Post subject: Firefox [Mozilla-Overlay] ebuild fails Reply with quote

build.log: http://dpaste.com/108214/


EDIT:
new build.log: http://dpaste.com/108756/


Last edited by indietrash on Sat Oct 17, 2009 11:02 pm; edited 1 time in total
Back to top
View user's profile Send private message
ursusca
Apprentice
Apprentice


Joined: 10 Sep 2008
Posts: 284
Location: Toronto ON, CANADA

PostPosted: Sat Oct 17, 2009 6:44 pm    Post subject: Reply with quote

Try this thread https://forums.gentoo.org/viewtopic-t-788565-highlight-.html Probably it will help you.
_________________
You deserve free software!
Back to top
View user's profile Send private message
indietrash
Guru
Guru


Joined: 17 Sep 2008
Posts: 353
Location: Norway

PostPosted: Sat Oct 17, 2009 8:14 pm    Post subject: Reply with quote

huh? how? my emerge fails at compiling. I have had FX3.5 installed several times, but on my re-install it doesn't emerge (see the build log).
Back to top
View user's profile Send private message
ursusca
Apprentice
Apprentice


Joined: 10 Sep 2008
Posts: 284
Location: Toronto ON, CANADA

PostPosted: Sat Oct 17, 2009 8:33 pm    Post subject: Reply with quote

Try to move out all
Code:
ls -la /usr/lib/pkgconfig | grep mozilla
files and to reemerge firefox or try to emerge xulrunner-1.9.1_beta4-r2.
_________________
You deserve free software!
Back to top
View user's profile Send private message
indietrash
Guru
Guru


Joined: 17 Sep 2008
Posts: 353
Location: Norway

PostPosted: Sat Oct 17, 2009 8:40 pm    Post subject: Reply with quote

not to be rude or anything but... are you sure about this? because if you aren't, I won't bother until someone who knows comes in and answers me. because if this fails, I have to clean xulrunner and re-emerge gran paradiso with USE="-xulrunner", and that takes some minutes too many for me to be bothered with it really... hehe. but thanks for trying to help anyway! :)
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3830
Location: Dallas area

PostPosted: Sat Oct 17, 2009 8:47 pm    Post subject: Reply with quote

The emerge fails because of this
Code:
./configure: line 12027: cd: /usr/lib64/xulrunner-devel-1.9.1: No such file or directory

_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3830
Location: Dallas area

PostPosted: Sat Oct 17, 2009 8:49 pm    Post subject: Reply with quote

If I try and emerge Ff 3.5.3 it wants to emerge xulrunner-1.9.1.3
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
indietrash
Guru
Guru


Joined: 17 Sep 2008
Posts: 353
Location: Norway

PostPosted: Sat Oct 17, 2009 9:12 pm    Post subject: Reply with quote

I had xulrunner emerged properly, so I don't see why it would fail???

I noticed I had forgot to remove the # before the layman-stuff in make.conf. could this have anything to do with my error?
Back to top
View user's profile Send private message
indietrash
Guru
Guru


Joined: 17 Sep 2008
Posts: 353
Location: Norway

PostPosted: Sat Oct 17, 2009 11:02 pm    Post subject: Reply with quote

hey,

I emerged xulrunner now because I realised that it wouldn't give me trouble with my current firefox ebuild, since I have it without the xulrunner use-flag (duh), and so it crashed like this: http://dpaste.com/108756/

but at least gran paradiso still works, heh.
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3830
Location: Dallas area

PostPosted: Sat Oct 17, 2009 11:06 pm    Post subject: Reply with quote

indietrash wrote:
I had xulrunner emerged properly, so I don't see why it would fail???


Which version of xulrunner?

It is looking for a specific one, according to the error message.
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43007
Location: 56N 3W

PostPosted: Sun Oct 18, 2009 3:31 pm    Post subject: Reply with quote

Moved from Portage & Programming to Unsupported Software.
Overlays are not offically supported, so this thread belongs here
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
ursusca
Apprentice
Apprentice


Joined: 10 Sep 2008
Posts: 284
Location: Toronto ON, CANADA

PostPosted: Sun Oct 18, 2009 5:59 pm    Post subject: Reply with quote

indietrash wrote:
not to be rude or anything but... are you sure about this? because if you aren't, I won't bother until someone who knows comes in and answers me. because if this fails, I have to clean xulrunner and re-emerge gran paradiso with USE="-xulrunner", and that takes some minutes too many for me to be bothered with it really... hehe. but thanks for trying to help anyway! :)


Hi,

I am not sure about this. I think probably these files
Code:
ls -la /usr/lib/pkgconfig | grep mozilla
do not define the proper paths.
_________________
You deserve free software!
Back to top
View user's profile Send private message
indietrash
Guru
Guru


Joined: 17 Sep 2008
Posts: 353
Location: Norway

PostPosted: Mon Oct 19, 2009 7:09 am    Post subject: Reply with quote

I have these xulrunners emerged:

1.9.2_alpha2[1]
1.8.1.19!s(02:21:43 18/10/09) - this is the bin file
[1] "mozilla" /usr/local/portage/layman/mozilla


I'm going to try emerging 1.9.1.x manually, but when doing emerge fx3.5, it automatically drags in xulrunner 1.9.2. but I'll try getting 1.9.1 manually and get back to you.
Back to top
View user's profile Send private message
indietrash
Guru
Guru


Joined: 17 Sep 2008
Posts: 353
Location: Norway

PostPosted: Mon Oct 19, 2009 7:41 am    Post subject: Reply with quote

worked. seems the error was that firefox-3.5.2 was requesting the wrong xulrunner.
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3830
Location: Dallas area

PostPosted: Mon Oct 19, 2009 11:37 am    Post subject: Reply with quote

Glad it's solved

As far as 3.5 versions, 3.5.2 shows as being on my system
since Sept 9 and 3.5.3 since Sept 13
so 3.5.3 should be the one being tried anyway.
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum