Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Amarok 1.4 spielt keine Vorbis-Dateien mehr ab
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2329
Location: Konradsreuth (Germany)

PostPosted: Mon Oct 19, 2009 8:23 pm    Post subject: Amarok 1.4 spielt keine Vorbis-Dateien mehr ab Reply with quote

Hallo :-)

Mir ist gerade aufgefallen, daß Amarok 1.4 keine Vorbis-Dateien mehr abspielen will. Welches Update das jetzt versaut hat, weiß ich nicht … erstmal habe ich aber versucht, Amarok neu zu bauen. Dazu sollte dann auch media-libs/tunepimp neu gebaut werden (wegen dem musicbraniz-Useflag, das ich neu gesetzt habe), was aufgrund einer fehlenden libogg.la fehlgeschlagen ist. Daraufhin habe ich dann mal media-libs/libogg neu gebaut, da habe ich dann gelesen, man soll doch dev-util/lafilefixer installieren und lafilefixer --justfixit ausführen. Danach ist dann der Neu-Merge von Amarok auch durchgelaufen.
Aber gebracht hat es nichts: Amarok spielt mir keine Vorbis-Dateien mehr ab.

Kann mir einer weiterhelfen?

MfG
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2225
Location: Germany

PostPosted: Mon Oct 19, 2009 11:34 pm    Post subject: Reply with quote

Verwendest du Xine als Backend?

Dann schau mal ob media-libs/xine-lib das Useflag "theora" aktiviert hat ;)

Wenn man sich nicht sicher ist wie der Codec heißt der fehlt, verwende ich immer mplayer in einer Konsole und öffne die Datei. Dann werden die Video und Audio-Codecs ja immer bezeichnet.
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4459

PostPosted: Tue Oct 20, 2009 7:42 am    Post subject: Reply with quote

ChrisJumper wrote:
Verwendest du Xine als Backend?

Dann schau mal ob media-libs/xine-lib das Useflag "theora" aktiviert hat ;)

Wenn man sich nicht sicher ist wie der Codec heißt der fehlt, verwende ich immer mplayer in einer Konsole und öffne die Datei. Dann werden die Video und Audio-Codecs ja immer bezeichnet.

öhm was hat vorbis support mit theora zu tun? vorbis ist ein audio codec und theora ist ein container format für verschieden audio/video codecs. Für vorbis support ist das useflag vorbis zuständig.

@l3u: Wird die audio-datei auch nicht abgespielt, wenn du versucht diese direkt über xine abzuspielen (xine-ui muss installiert sein). Könntest du die Ausgabe von xine --verbose hier posten?
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2329
Location: Konradsreuth (Germany)

PostPosted: Tue Oct 20, 2009 10:48 am    Post subject: Reply with quote

@ChrisJumper: dito ;-)

Danke für den Tip, xine direkt wollte auch keine Vorbis-Dateien abspielen. media-libs/xine-lib neu bauen hat aber geholfen, jetzt geht's wieder :-) Weiß der Geier, was da wieder war …
Back to top
View user's profile Send private message
Necoro
Veteran
Veteran


Joined: 18 Dec 2005
Posts: 1912
Location: München (Germany)

PostPosted: Tue Oct 20, 2009 2:14 pm    Post subject: Reply with quote

firefly wrote:
vorbis ist ein audio codec und theora ist ein container format für verschieden audio/video codecs.

Theora ist ein Video-Codec -- kein Container. Der für Theora benutzte Container ist in der Regel Ogg.
_________________
Inter Deum Et Diabolum Semper Musica Est.
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2042
Location: My own world! I and Gentoo!

PostPosted: Tue Oct 20, 2009 4:20 pm    Post subject: Reply with quote

Unter Umstängen hätte ein lafilefixer gereicht... JEdenfalls ist das eines dieser ominösen "libtool archives" (daher la).
Entweder gibt es da allgemein einige Probleme, oder ich denke mir das nur so.
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4459

PostPosted: Tue Oct 20, 2009 6:26 pm    Post subject: Reply with quote

Necoro wrote:
firefly wrote:
vorbis ist ein audio codec und theora ist ein container format für verschieden audio/video codecs.

Theora ist ein Video-Codec -- kein Container. Der für Theora benutzte Container ist in der Regel Ogg.

ups stimmt hatte das mit matroska verwechselt.
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2329
Location: Konradsreuth (Germany)

PostPosted: Tue Oct 20, 2009 6:49 pm    Post subject: Re: Amarok 1.4 spielt keine Vorbis-Dateien mehr ab Reply with quote

Max Steel wrote:
Unter Umstängen hätte ein lafilefixer gereicht... JEdenfalls ist das eines dieser ominösen "libtool archives" (daher la).
Entweder gibt es da allgemein einige Probleme, oder ich denke mir das nur so.

l3u wrote:
Hallo :-)

Mir ist gerade aufgefallen, daß Amarok 1.4 keine Vorbis-Dateien mehr abspielen will. Welches Update das jetzt versaut hat, weiß ich nicht … erstmal habe ich aber versucht, Amarok neu zu bauen. Dazu sollte dann auch media-libs/tunepimp neu gebaut werden (wegen dem musicbraniz-Useflag, das ich neu gesetzt habe), was aufgrund einer fehlenden libogg.la fehlgeschlagen ist. Daraufhin habe ich dann mal media-libs/libogg neu gebaut, da habe ich dann gelesen, man soll doch dev-util/lafilefixer installieren und lafilefixer --justfixit ausführen. Danach ist dann der Neu-Merge von Amarok auch durchgelaufen.
Aber gebracht hat es nichts: Amarok spielt mir keine Vorbis-Dateien mehr ab.

Kann mir einer weiterhelfen?

MfG
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2225
Location: Germany

PostPosted: Tue Oct 20, 2009 6:50 pm    Post subject: Reply with quote

Arg... natürlich ich hab mich vertan ich meinte auch vorbis und nicht theora! Ich verwechsel diese ganzen Video-, Audio-Codecs und verliere gerne den überblick bei den Containern. Daher ja auch der Tipp mit mplayer.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum