Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
libXi-1.2.99" is blocking x11-proto/inputproto-2.0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
upengan78
l33t
l33t


Joined: 27 Jun 2007
Posts: 710
Location: IL

PostPosted: Wed Oct 28, 2009 5:39 pm    Post subject: libXi-1.2.99" is blocking x11-proto/inputproto-2.0 Reply with quote

Hello,

What can I do in this case?

Code:

 ~ # ./emwrap.sh -wuDb

 Running emwrap.sh 4.0.8 with gcc-config Wed Nov 22 19:37:40 PST 2006
 If emwrap.sh is run and it detects a "failed' or "build" file
 then it will offer to build them. You can ignor this by not doing 
 anything and what you wanted todo will start after automaticlly.

work_dir is
[ebuild     U ] sys-libs/freeipmi-0.7.14 [0.7.13]
[ebuild  N    ] dev-libs/gmime-2.4.3
[ebuild     U ] net-irc/irssi-0.8.14 [0.8.13-r1]
[ebuild     U ] x11-proto/inputproto-2.0 [1.5.1]
[ebuild     U ] x11-proto/xf86driproto-2.1.0 [2.0.4]
[ebuild  NS   ] sys-kernel/gentoo-sources-2.6.31-r4 [2.6.28-r3, 2.6.28-r4, 2.6.29, 2.6.29-r1, 2.6.29-r2, 2.6.29-r3, 2.6.29-r4, 2.6.29-r5, 2.6.30, 2.6.30-r1, 2.6.30-r2, 2.6.30-r3, 2.6.30-r4, 2.6.30-r5, 2.6.30-r6, 2.6.31, 2.6.31-r1, 2.6.31-r2, 2.6.31-r3]
[ebuild     U ] sys-apps/lm_sensors-3.1.1 [3.0.3]
[ebuild     U ] dev-java/java-config-2.1.9-r1 [2.1.8-r1]
[ebuild     U ] app-admin/eselect-ruby-20090909 [20081227]
[ebuild     U ] dev-util/mercurial-1.3.1-r1 [1.2.1]
[ebuild     U ] dev-lang/ruby-1.8.7_p174-r1 [1.8.6_p369]
[ebuild     U ] dev-python/cheetah-2.4.0 [2.2.2]
[ebuild     U ] dev-db/mysql-5.0.84-r1 [5.0.70-r1]
[ebuild     U ] x11-proto/xf86vidmodeproto-2.3 [2.2.2]
[uninstall    ] x11-libs/libXxf86vm-1.0.2
[blocks b     ] <x11-libs/libXxf86vm-1.0.99.1 ("<x11-libs/libXxf86vm-1.0.99.1" is blocking x11-proto/xf86vidmodeproto-2.3)
[ebuild     U ] x11-proto/xextproto-7.1.1 [7.0.5]
[ebuild     U ] x11-libs/libX11-1.3.2 [1.2.2]
[ebuild     U ] x11-libs/libXext-1.1.1 [1.0.5]
[blocks b     ] <x11-libs/libXext-1.0.99 ("<x11-libs/libXext-1.0.99" is blocking x11-proto/xextproto-7.1.1)
[ebuild     U ] x11-libs/libXxf86vm-1.1.0 [1.0.2]
[ebuild     U ] media-video/ffmpeg-0.5_p20373 [0.5_p19928]
[ebuild     U ] app-text/acroread-9.2 [9.1.3]
[ebuild     U ] dev-libs/totem-pl-parser-2.26.3-r1 [2.26.3]
[ebuild     U ] net-libs/xulrunner-1.9.1.3-r1 [1.9.1.3]
[ebuild     U ] app-accessibility/orca-2.26.3 [2.24.4]
[ebuild     U ] www-client/mozilla-firefox-3.5.3-r1 [3.5.3]
[ebuild     U ] gnome-extra/gnome-power-manager-2.26.4-r1 [2.26.4]
[ebuild     U ] gnome-extra/deskbar-applet-2.26.2-r1 [2.26.2]
[blocks B     ] <x11-libs/libXi-1.2.99 ("<x11-libs/libXi-1.2.99" is blocking x11-proto/inputproto-2.0)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('ebuild', '/', 'x11-proto/inputproto-2.0', 'merge') pulled in by
    >=x11-proto/inputproto-1.5 required by ('installed', '/', 'x11-libs/libXi-1.2.1', 'nomerge')
    x11-proto/inputproto required by ('ebuild', '/', 'x11-libs/libX11-1.3.2', 'merge')

  ('installed', '/', 'x11-libs/libXi-1.2.1', 'nomerge') pulled in by
    x11-libs/libXi required by ('installed', '/', 'x11-libs/gtk+-2.16.6', 'nomerge')
    >=x11-libs/libXi-1.2.1 required by ('installed', '/', 'x11-base/xorg-server-1.6.3.901-r2', 'nomerge')
    x11-libs/libXi required by ('installed', '/', 'x11-apps/xsetmode-1.0.0', 'nomerge')
    (and 13 more)


!!! The following installed packages are masked:
- x11-plugins/desklet-newsgrab-1.5 (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Joe Sapp <nixphoeni@gentoo.org> (27 Oct 2009)
# Doesn't work any more and uses the old package format.
# Masked for removal on 26 Nov 2009.

- net-irc/kvirc-3.4.0 (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Samuli Suominen <ssuominen@gentoo.org> (23 Oct 2009)
# KDE3-only. Doesn't compile with KDE4 installed, bugs
# 245543, 258791, 248508, 275733 and security bug 282891.
# Masked for removal in 30 days.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.



emerge --info here - >
Code:
 http://dpaste.com/113271/
Back to top
View user's profile Send private message
upengan78
l33t
l33t


Joined: 27 Jun 2007
Posts: 710
Location: IL

PostPosted: Wed Oct 28, 2009 6:02 pm    Post subject: Reply with quote

looks like it is here alreayd, should have searched earlier. sorry

Code:
http://forums.gentoo.org/viewtopic-t-797360-highlight-libxi.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum