Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(SOLVED)Emerge blocks
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
01allein
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jun 2009
Posts: 127
Location: AUSTRALIA

PostPosted: Tue Oct 27, 2009 7:19 am    Post subject: (SOLVED)Emerge blocks Reply with quote

Trying to install avahi for kdelibs and mDNSResponder for cups, I get this

Quote:
[blocks B ] net-dns/avahi ("net-dns/avahi" is blocking net-misc/mDNSResponder-107.6-r5)
[blocks B ] net-misc/mDNSResponder ("net-misc/mDNSResponder" is blocking net-dns/avahi-0.6.24-r2)

Total: 58 packages (2 new, 56 reinstalls), Size of downloads: 3,762 kB
Conflict: 2 blocks (2 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

('ebuild', '/', 'net-dns/avahi-0.6.24-r2', 'merge') pulled in by
net-dns/avahi[mdnsresponder-compat] required by ('ebuild', '/', 'kde-base/kdelibs-4.3.1-r2', 'merge')

('ebuild', '/', 'net-misc/mDNSResponder-107.6-r5', 'merge') pulled in by
net-misc/mDNSResponder required by ('ebuild', '/', 'net-print/cups-1.3.10-r2', 'merge')


Any good suggestion?

Thanks


Last edited by 01allein on Fri Nov 06, 2009 4:31 am; edited 1 time in total
Back to top
View user's profile Send private message
sebaro
Veteran
Veteran


Joined: 03 Jul 2006
Posts: 1137
Location: Romania

PostPosted: Tue Oct 27, 2009 7:40 am    Post subject: Reply with quote

I don't think you can have both.
Try to emerge cups with avahi flag on.
Or disable avahi for both.
Back to top
View user's profile Send private message
dimm
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jan 2009
Posts: 89

PostPosted: Tue Oct 27, 2009 9:13 am    Post subject: Re: Emerge blocks Reply with quote

01allein wrote:
Trying to install avahi for kdelibs and mDNSResponder for cups, I get this

Quote:
[blocks B ] net-dns/avahi ("net-dns/avahi" is blocking net-misc/mDNSResponder-107.6-r5)
[blocks B ] net-misc/mDNSResponder ("net-misc/mDNSResponder" is blocking net-dns/avahi-0.6.24-r2)

Total: 58 packages (2 new, 56 reinstalls), Size of downloads: 3,762 kB
Conflict: 2 blocks (2 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

('ebuild', '/', 'net-dns/avahi-0.6.24-r2', 'merge') pulled in by
net-dns/avahi[mdnsresponder-compat] required by ('ebuild', '/', 'kde-base/kdelibs-4.3.1-r2', 'merge')

('ebuild', '/', 'net-misc/mDNSResponder-107.6-r5', 'merge') pulled in by
net-misc/mDNSResponder required by ('ebuild', '/', 'net-print/cups-1.3.10-r2', 'merge')


Any good suggestion?

Thanks


Please post command which return this error.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Tue Oct 27, 2009 2:42 pm    Post subject: Reply with quote

Simple answer: you only want net-dns/avahi[mdnsresponder-compat],
net-misc/mDNSResponder in such case is unneeded.
Back to top
View user's profile Send private message
01allein
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jun 2009
Posts: 127
Location: AUSTRALIA

PostPosted: Wed Oct 28, 2009 5:41 pm    Post subject: Reply with quote

VoidMage wrote:
Simple answer: you only want net-dns/avahi[mdnsresponder-compat],
net-misc/mDNSResponder in such case is unneeded.


That was the answer I was looking for.

Thanks
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum