Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
thunderbird-bin-3.0_beta4 AMD64 xfce4 -print -problems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Samspade
n00b
n00b


Joined: 16 Apr 2008
Posts: 4
Location: Viroflay (FRANCE)

PostPosted: Thu Oct 29, 2009 2:13 pm    Post subject: thunderbird-bin-3.0_beta4 AMD64 xfce4 -print -problems Reply with quote

I have installed thunderbird-bin-3.0_beta4 as version bump (provided by Janne Tanskanen thanks to him) in:
https://bugs.gentoo.org/show_bug.cgi?id=287881
This is a pure 32 bit thunderbird-bin , and restricted to English (en_us possibly);
My system is gentoo close to standard AMD64, but uses xfce4 (-gnome -kde) and based on UTF-8, localized for french (fr) and german (de)
Globally TB 3.0 beta4 works for reading mails, answering, reading news and the like.
But I encounter some issues, and I suspect some of them could be related to gentoo environment, or to my special restricted environment.
I start thunderbird in a terminal console by:
Code:

$ thunderbird-bin -P tb3beta4  --jsconsole --safe-mode &

using then the js error console to track possible issues.

I'm encountering the following problems:

Point 1- message at startup in error console
Quote:

Failed to load XPCOM component: /opt/thunderbird/components/libmozgnome.so

This is probably related to my non gnome configuration; The points are:
- is libmozgnome.so really needed?

-how to install it without installing a full gnome environment?
I have recompiled xulrunner after adding gnome (and debug by the way) USE flags for xulrunner by updating /etc/portage/package.use:
Quote:

net-libs/xulrunner debug gnome

But xulrunner has installed the lib64 version..
Quote:

usr/lib64/xulrunner-1.9.1/components/libmozgnome.so

Point2: Impossible to print a message from thunderbird
I trigger the following errors in terminal:
Quote:

(thunderbird-bin:13941): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/printbackends/libprintbackend-file.so: mauvaise classe ELF : ELFCLASS64
(thunderbird-bin:13941): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/printbackends/libprintbackend-file.so: mauvaise classe ELF : ELFCLASS64
(thunderbird-bin:13941): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/printbackends/libprintbackend-cups.so: mauvaise classe ELF : ELFCLASS64
(thunderbird-bin:13941): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/printbackends/libprintbackend-cups.so: mauvaise classe ELF : ELFCLASS64

And the dialog box for printing opens, but shows no printer at all.


I have tried to overcome this printing issue, forcing gtk to use 32bit libs for thunderbird-bin launching it as:
Code:

GTK_PATH=/usr/lib32/gtk-2.0 thunderbird-bin -P tb3beta4  --jsconsole --safe-mode &

that works fine for printing, and Thunderbird works apparently without big issues, but that seems trigger additional issues, for example while displaying html messages with some formatting problems.

-Point 3: Error message in js console after closing a message
Quote:

Error: Cc is not defined
Source File: chrome://messenger/content/search.xml
Line: 284


I wonder if others have similar issues, or have found better ways to overcome the problems ..
_________________
SamSpade
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum