Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Keyboard unter KDE komplett deutsch aber LogIn nicht!
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
PaddyW
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2006
Posts: 113
Location: germany/nrw/neuss

PostPosted: Fri Nov 06, 2009 1:11 pm    Post subject: Keyboard unter KDE komplett deutsch aber LogIn nicht! Reply with quote

Hallo zusammen,
nachdem ich nun doch einige Zeit hier im Forum gesucht habe und leider keine Lösung finden konnte, wende ich mich nun an euch:

Folgendes Problem:
Der KDE Login ist bei mir auf englisch. Ziemlich nervig. Unter den KDE settings habe ich als "Keyboard layout" "deutsch" gewählt - somit ist unter KDE alles in deutsch! Wie gesagt der LogIn aber nicht. Habe auch die Datei /etc/hal/fdi/policy/10-keymap.fdi erstellt - bringt nichts. Hat jemand hier Rat?

Meine xorg.conf:
Code:
Section "ServerLayout"
    Identifier     "eeePC1000"
    Screen      0  "Screen1"
    InputDevice    "keyboard"
    InputDevice    "mouse"
    InputDevice    "synaptics"
EndSection

Section "Files"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/X11/misc"
    FontPath     "/usr/share/fonts/X11/Type1"
    FontPath     "/usr/share/fonts/X11/75dpi"
    FontPath     "/usr/X11R6/lib/X11/fonts/Type1"
EndSection

Section "Module"
    Load  "glx"
    Load  "dri"
    Load  "extmod"
    Load  "synaptics"
EndSection

Section "ServerFlags"
    Option      "AllowMouseOpenFail"
    Option      "BlankTime" "5"
    Option      "DontVTSwitch"  "true"
    Option      "AIGLX"   "false"
EndSection

Section "InputDevice"
    Identifier  "keyboard"
    Driver      "kbd"
    Option      "CoreKeyboard"
    Option      "XkbRules" "xorg"
    Option      "XkbModel" "pc105"
    Option      "XkbLayout" "de"
    Option      "XkbVariant" "basic"
    Option      "XkbOptions" "grp:alt_shift_toggle"
EndSection

Section "InputDevice"
    Identifier  "mouse"
    Driver      "mouse"
    Option      "Device" "/dev/input/mouse1"
    Option      "Protocol" "IMPS/2"
    Option      "Emulate3Buttons" "yes"
    Option      "ZAxisMapping" "4 5"
    Option      "CorePointer"
EndSection

Section "InputDevice"
    Identifier  "synaptics"
    Driver      "synaptics"
    Option      "Device"           "/dev/psaux"
    Option      "Protocol"         "auto-dev"
    Option      "LeftEdge"         "1400"
    Option      "RightEdge"        "5900"
    Option      "TopEdge"          "1400"
    Option      "BottomEdge"       "4500"
    Option      "PalmDetect"       "0"
    Option      "SHMConfig"        "true"
    Option      "SendCoreEvents"   "yes"
    Option      "HorizScrollDelta" "0"
    Option      "VertScrollDelta"  "155"
    Option      "RBCornerButton"   "0"
    Option      "RTCornerButton"   "0"
    Option      "TapButton2"          "0"
    Option      "MinSpeed"         "0.095"
    Option      "MaxSpeed"         "0.38"
    Option      "VertTwoFingerScroll" "1"
    Option      "VertEdgeScroll"      "0"
    Option      "HorizEdgeScroll"     "0"
EndSection

Section "Monitor"
    Identifier   "Monitor1"
    VendorName   "ASUS"
    ModelName    "eeePC P701"
    Modeline     "800x480"  29.58  800 816 896 992  480 481 484 497  -HSync +Vsync # 60 Hz
    Modeline     "1024x600"  48.96  1024 1064 1168 1312  600 601 604 622  -HSync +Vsync
EndSection

Section "Monitor"
    Identifier   "TV"
    VendorName   "ASUS"
    ModelName    "eeePC P701"
    Option       "Ignore" "true"
EndSection

Section "Device"
    Identifier  "Device1"
    Driver      "intel"
    VendorName  "Intel Corporation"
    BoardName   "Mobile 915GM/GMS/910GML Express Graphics Controller"
    BusID       "PCI:0:2:0"
    Option      "Monitor-VGA"  "Monitor1"
    Option      "Monitor-LVDS" "Monitor1"
    Option      "Monitor-TV"   "TV"
    Option      "XAANoOffScreenPixmaps" "true"
    Option      "AccelMethod" "XAA"
EndSection

Section "Screen"
    Identifier "Screen1"
    Device     "Device1"
    DefaultDepth     16
    SubSection "Display"
        Depth     8
        Virtual  1024 768
    EndSubSection
    SubSection "Display"
        Depth     15
        Virtual  1024 768
    EndSubSection
    SubSection "Display"
        Depth     16
        Virtual  1024 768
    EndSubSection
    SubSection "Display"
        Depth     24
        Virtual  1024 768
    EndSubSection
EndSection

Section "DRI"
    Mode         0666
EndSection

Section "Extensions"
    Option      "Composite" "Disable"
EndSection



Hier meine 10-keymap.fdi:
Code:

<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keymap">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>

    <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.rules" type="string">base</merge>
      <merge key="input.xkb.model" type="string">evdev</merge>
      <merge key="input.xkb.layout" type="string">de</merge>
      <merge key="input.xkb.variant" type="string" />
    </match>
  </device>
</deviceinfo>
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2050
Location: My own world! I and Gentoo!

PostPosted: Fri Nov 06, 2009 1:15 pm    Post subject: Reply with quote

Deine letzte Zeile in der 10-keymap.fdi ist fehlerhaft.

Code:
        <merge key="input.xkb.variant" type="string"></merge>
        <merge key="input.xkb.options" type="string">terminate:ctrl_alt_bksp</merge>


(Die 2.te hab ich wegen: http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-1.6-upgrade-guide.xml
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
PaddyW
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2006
Posts: 113
Location: germany/nrw/neuss

PostPosted: Fri Nov 06, 2009 1:25 pm    Post subject: Reply with quote

Ah okay, danke!

Habe ausserdem:

Code:

<merge key="input.xkb.rules" type="string">base</merge>


in

Code:

<merge key="input.xkb.rules" type="string">udev</merge>


umbenannt. Und jetzt geht es!
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2231
Location: Germany

PostPosted: Sat Nov 07, 2009 4:46 pm    Post subject: Reply with quote

Hi PaddyW,

diese Sache fand ich die ersten male auch fies! Das alte Xorg hat "seine start" sofort verweigert wenn die alte xorg.conf nicht stimmte. Die neue Variante der Konfiguration über hal ist da ein bisschen "Fehler toleranter". Am besten daran denken/sich angewöhnen einen Blick in die Log-Dateien zu werfen wenn etwas nicht funktioniert. Manchmal steht (z.B.) im Xorg.0.log das es Probleme beim Parsen der Config gab (sogar mit Zeilen-Nummer)...

Aber oft wie in deinem Fall stand da wohl nur sowas wie default keyboard: XkbLayout: "us"... und da er den default verwendet muss es wohl an deiner Konfiguration liegen, sonst hätte er ja deine Einstellungen verwendet.

Nun ja ich empfehle einfach mal die Xorg-Dukumentation von Archlinux. Dort wird alles gut erklärt und sie sind soweit ich das beurteilen kann auf dem aktuellen Stand.

Grüße
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum