Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE 3.5.10 is masked but where is the stable KDE 4 for ppc?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Ato
n00b
n00b


Joined: 22 Dec 2007
Posts: 66
Location: Duisburg, Germany

PostPosted: Mon Nov 09, 2009 8:44 pm    Post subject: KDE 3.5.10 is masked but where is the stable KDE 4 for ppc? Reply with quote

Hi *,

since Saturday I am seeing messages like this

Code:
[ebuild   R   ] media-sound/amarok-1.4.10_p20090130-r3  USE="(-kde%*)"

!!! The following installed packages are masked:
- kde-base/kdm-3.5.10 (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Samuli Suominen <ssuominen@gentoo.org> (07 Nov 2009)
#
# Mask KDE 3.5.10 for removal, excluding the dependencies
# required for stable koffice. Removed in 30 days.
#

- kde-base/kwin-3.5.10 (masked by: package.mask)
- kde-base/kdepasswd-3.5.10 (masked by: package.mask)


when I want to update the installed builds on my ppc computer. All nice and fine that people want to move on and remove KDE 3.5.*. But where are the stable KDE 4 ebuilds for ppc* platforms? Checking the meta package

Code:
mac ~ # emerge --pretend --verbose --deep kde-base/kde-meta:kde-4

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "kde-base/kde-meta:kde-4".

mac ~ # grep ppc portage/portage/kde-base/kde-meta/kde-meta-4.3.1.ebuild
portage/portage/kde-base/kde-meta/kde-meta-4.3.1.ebuild:KEYWORDS="~alpha amd64 ~hppa ~ia64 ~ppc ~ppc64 x86"


shows that somebody seems to think that the world consists just of x86 and amd64 platforms. What is this about?

Thanks for any explanation,
Thomas
Back to top
View user's profile Send private message
SamuliSuominen
Retired Dev
Retired Dev


Joined: 30 Sep 2005
Posts: 2133
Location: Finland

PostPosted: Mon Nov 09, 2009 11:24 pm    Post subject: Reply with quote

https://bugs.gentoo.org/show_bug.cgi?id=292455

ppc/ppc64 will be included for KDE 4.3.3 stabling at the end of this month
Back to top
View user's profile Send private message
frankOnPPC
Apprentice
Apprentice


Joined: 26 May 2003
Posts: 169
Location: Fulda, Hessen, Germany, Europe, Earth

PostPosted: Sat Nov 14, 2009 10:58 pm    Post subject: Hopefully Reply with quote

Hopefully the nepomuk-4.3.3 Sun-Java Issue, used by soprano-2.3.1 will be fixed.
Well, thats a "show-stopper", also because :

!!! The following installed packages are masked:
- dev-java/ibm-jdk-bin-1.6.0.5 (masked by: IBM-J1.6 license(s))
A copy of the 'IBM-J1.6' license is located at '/usr/portage/licenses/IBM-J1.6'.

- dev-java/ibm-jdk-bin-1.5.0.10 (masked by: IBM-J1.5 license(s))
A copy of the 'IBM-J1.5' license is located at '/usr/portage/licenses/IBM-J1.5'.

End of November solved, I don't know, I woud expect not be solved.

But the question is : why dolphin-to-Nepomuk-to-soprano-to-icedtea-bin are using java ? Well, does KDE 4.3.3 needs java to build ? No, I guess not, or ? Why soprano needs icedtea-bin (bin !) ?

Cheers
Frank
BTW : KDE-4.2.2 doesn't fail to build..
_________________
always look at yellow site of Linux on the PPC.
Its PPCNUX.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Mon Nov 16, 2009 5:13 am    Post subject: Reply with quote

That's not a bug. You need at accept the license to use the IBM java.

Try adding this to your make.conf:
Quote:
ACCEPT_LICENSE="IBM-J1.6"

_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
frankOnPPC
Apprentice
Apprentice


Joined: 26 May 2003
Posts: 169
Location: Fulda, Hessen, Germany, Europe, Earth

PostPosted: Mon Nov 16, 2009 11:19 am    Post subject: Reply with quote

JoseJX wrote:
That's not a bug. You need at accept the license to use the IBM java.

Try adding this to your make.conf:
Quote:
ACCEPT_LICENSE="IBM-J1.6"


OK, I will try that.

Well, that would fix that Java-License things, what about Nepomuk->soprano->icedtea-bin und KDE 4.3.3 ?
Why icedtea-bin must be a bin ?
Its avaiable as source : http://icedtea.classpath.org/download/source/
isn't it ? And possibly usabel with IBM-JDK or the OpenJDK (not Java 1.7).

Cheers,
Frank
_________________
always look at yellow site of Linux on the PPC.
Its PPCNUX.
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Mon Nov 16, 2009 11:39 am    Post subject: Reply with quote

Quote:
what about Nepomuk->soprano->icedtea-bin und KDE 4.3.3 ? Why icedtea-bin must be a bin ?


soprano doesn´t depend on icedtea-bin, in case you have the java use flag enabled it depens on virtual/jdk.

Quote:
Its avaiable as source : http://icedtea.classpath.org/download/source/


ebuilds for this are in the java-overlay.
In case this combination works for you let the gentoo kde & java devs know about it.

cheers
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
frankOnPPC
Apprentice
Apprentice


Joined: 26 May 2003
Posts: 169
Location: Fulda, Hessen, Germany, Europe, Earth

PostPosted: Mon Nov 16, 2009 9:24 pm    Post subject: Reply with quote

Hi,
ACCEPT_LICENSE="IBM-J1.6"
#
runs perfect.

But, how I get rid of this :


emerge nepomuk
Calculating dependencies ... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=dev-libs/soprano-2.3.0[clucene,dbus,raptor,java]".
!!! One of the following packages is required to complete your request:
- dev-libs/soprano-2.3.1 (Change USE: +java)
(dependency required by "kde-base/nepomuk-4.3.3" [ebuild])
(dependency required by "nepomuk" [argument])


Cheers,
Frank
_________________
always look at yellow site of Linux on the PPC.
Its PPCNUX.
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Tue Nov 17, 2009 11:56 am    Post subject: Reply with quote

nepomuk apparently needs soprano to be build with java support.
If you already have a jdk installed it should provide the virtual and it shouldn´t requiere you to install any other jdk.

cheers
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
frankOnPPC
Apprentice
Apprentice


Joined: 26 May 2003
Posts: 169
Location: Fulda, Hessen, Germany, Europe, Earth

PostPosted: Tue Nov 17, 2009 8:52 pm    Post subject: jeah ! Reply with quote

After a fresh unmerge of java, the acceptance of the ibm-license, a fresh emerge of the latest ibm-jdk it builds soprano succcessfully.
I also set up /etc/java-config-2/build/jdk.conf with *=ibm-jdk and set up to use it with java-config .
Well, kde 4.3.3 is still compiling, linking, compiling, 233 files, now at 221. Well, its a slow popwerpc with only 1.2 Ghz, it needs time....

Thanks for the help and all the fish,
cheers,
Frank
_________________
always look at yellow site of Linux on the PPC.
Its PPCNUX.
Back to top
View user's profile Send private message
frankOnPPC
Apprentice
Apprentice


Joined: 26 May 2003
Posts: 169
Location: Fulda, Hessen, Germany, Europe, Earth

PostPosted: Thu Nov 19, 2009 9:22 am    Post subject: well, success Reply with quote

KD 4.3.3 runs...but, to be honest, slow. Its a 1.2 GHz G4 with 1G Mem and a ATI-Radeon AGP-Card.
KDE 3.5.9/10 runs faster.
KDE 4.3.3 is nice.

Cheers,
Frank
_________________
always look at yellow site of Linux on the PPC.
Its PPCNUX.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Mon Nov 30, 2009 7:58 am    Post subject: Reply with quote

KDE-4.3.3 is now stable on PPC and PPC64!

Please let us know if there are any problems that crop up!
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum