Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]emerge update block
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
skydoom
Tux's lil' helper
Tux's lil' helper


Joined: 19 Aug 2006
Posts: 141
Location: Eschershausen, Niedersachsen

PostPosted: Sat Nov 14, 2009 4:04 pm    Post subject: [solved]emerge update block Reply with quote

Guten Abend,

ich wollte mal wieder ein Update machen, starte also emerge --sync, danach ein portpeek -arf und dann ein
Quote:
server dennis # emerge --ask --verbose --update --deep --newuse world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild NS ] dev-db/sqlite-2.8.16-r4 [3.6.18] USE="nls -doc -tcl" 959 kB
[ebuild R ] dev-libs/apr-util-1.3.9 USE="berkdb gdbm mysql sqlite* -doc -freetds -ldap -odbc -postgres -sqlite3" 0 kB
[ebuild R ] dev-db/libdbi-drivers-0.8.3 USE="mysql sqlite* -bindist -doc -firebird -oci8 -postgres -sqlite3" 0 kB
[ebuild N ] dev-python/pysqlite-1.0.1 41 kB
[ebuild N ] dev-python/pysqlite-2.5.5-r1 USE="-examples" 72 kB
[ebuild R ] media-libs/libsndfile-1.0.20 USE="alsa sqlite* -jack -minimal" 0 kB
[ebuild R ] dev-libs/redland-1.0.9-r1 USE="berkdb mysql sqlite* ssl xml -postgres -threads" 0 kB
[ebuild U ] sys-fs/udev-146-r1 [141] USE="devfs-compat%* -extras% (-selinux)" 528 kB
[ebuild R ] media-libs/libsdl-1.2.13-r1 USE="X alsa audio joystick opengl video -aalib -custom-cflags -dga -directfb -esd -fbcon -ggi -libcaca -nas -oss -pulseaudio -svga -tslib% -xinerama -xv (-arts%*)" 0 kB
[ebuild R ] dev-libs/cyrus-sasl-2.1.23-r1 USE="berkdb crypt gdbm mysql pam sqlite* ssl -authdaemond -java -kerberos -ldap -ntlm_unsupported_patch -postgres -sample -srp -urandom" 0 kB
[ebuild R ] dev-lang/php-5.2.11 USE="apache2 berkdb bzip2 cli crypt gdbm iconv imap ipv6 mysql ncurses nls pcre readline reflection session snmp spl sqlite* ssl unicode xml zlib -adabas -bcmath -birdstep -calendar -cdb -cgi -cjk -concurrentmodphp -ctype -curl -curlwrappers -db2 -dbase -dbmaker -debug -discard-path -doc -empress -empress-bcs -esoob -exif -fastbuild -fdftk -filter -firebird -flatfile -force-cgi-redirect -frontbase -ftp -gd -gd-external -gmp -hash -inifile -interbase -iodbc (-java-external) -json -kerberos -kolab -ldap -ldap-sasl -libedit -mcve -mhash -msql -mssql -mysqli -oci8 -oci8-instant-client -odbc -pcntl -pdo -pic -posix -postgres -qdbm -recode -sapdb -sharedext -sharedmem -simplexml -soap -sockets -solid -spell -suhosin -sybase -sybase-ct -sysvipc -threads -tidy -tokenizer -truetype -wddx -xmlreader -xmlrpc -xmlwriter -xpm -xsl -yaz -zip" 0 kB
[ebuild R ] x11-libs/qt-3.3.8b-r1 USE="cups ipv6 mysql opengl sqlite* -debug -doc -examples -firebird -immqt -immqt-bc -nas -nis -odbc -postgres -xinerama" 0 kB
[ebuild R ] net-libs/xulrunner-1.9.1.4 USE="alsa dbus python sqlite* -custom-optimization -debug -gnome -java -startup-notification" 0 kB
[ebuild R ] www-client/mozilla-firefox-3.5.4 USE="alsa dbus sqlite* -bindist -custom-optimization -gnome -iceweasel -java -mozdevelop -restrict-javascript -startup-notification" LINGUAS="de -af -ar -as -be -bg -bn -bn_BD -bn_IN -ca -cs -cy -da -el -en -en_GB -en_US -eo -es -es_AR -es_CL -es_ES -es_MX -et -eu -fa -fi -fr -fy -fy_NL -ga -ga_IE -gl -gu -gu_IN -he -hi -hi_IN -hr -hu -id -is -it -ja -ka -kk -kn -ko -ku -lt -lv -mk -ml -mn -mr -nb -nb_NO -nl -nn -nn_NO -oc -or -pa -pa_IN -pl -pt -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -sq -sr -sv -sv_SE -ta -ta_LK -te -th -tr -uk -vi -zh_CN -zh_TW" 0 kB
[ebuild R ] net-analyzer/nagios-plugins-1.4.13-r1 USE="ipv6 mysql samba snmp ssl -ldap -nagios-dns* -nagios-game* -nagios-ntp* -nagios-ping* -nagios-ssh -postgres -radius -ups" 0 kB
[ebuild R ] app-office/akonadi-server-1.2.1 USE="mysql sqlite*" 0 kB
[ebuild R ] dev-python/kaa-base-0.3.0 USE="lirc sqlite*" 0 kB
[ebuild R ] media-tv/freevo-1.7.6.1 USE="X dvd lirc nls sqlite* -directfb -doc -fbcon -gphoto2 -ivtv -matrox -minimal -mixer -tv" 0 kB
[ebuild U ] sys-apps/hal-0.5.13-r2 [0.5.12_rc1-r8] USE="X crypt -acpi -apm -consolekit -debug -dell -disk-partition -doc -laptop -policykit (-selinux)" 902 kB
[ebuild U ] app-misc/hal-info-20090716 [20090414] 136 kB
[ebuild R ] app-portage/portato-0.13 USE="kde libnotify nls sqlite* -userpriv" LINGUAS="de -ca -es_ES -pl -pt_BR -tr" 0 kB
[ebuild U ] media-tv/mythtv-0.21_p20877 [0.21_p19961-r2] USE="aac alsa dvb dvd lirc opengl perl python (-altivec) -autostart -debug -directv -fftw -ieee1394 -jack -lcd -mmx -xvmc" VIDEO_CARDS="nvidia -via" 0 kB
[blocks B ] sys-fs/device-mapper ("sys-fs/device-mapper" is blocking sys-fs/udev-146-r1)

Total: 22 packages (4 upgrades, 2 new, 1 in new slot, 15 reinstalls), Size of downloads: 2,635 kB
Conflict: 1 block (1 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

('ebuild', '/', 'sys-fs/udev-146-r1', 'merge') pulled in by
sys-fs/udev required by ('installed', '/', 'sys-kernel/gentoo-sources-2.6.30-r8', 'nomerge')
>=sys-fs/udev-117 required by ('ebuild', '/', 'sys-apps/hal-0.5.13-r2', 'merge')
>=sys-fs/udev-124 required by ('installed', '/', 'sys-fs/cryptsetup-1.0.6-r2', 'nomerge')
(and 1 more)

('installed', '/', 'sys-fs/device-mapper-1.02.24-r1', 'nomerge') pulled in by
>=sys-fs/device-mapper-1.00.07-r1 required by ('installed', '/', 'sys-fs/cryptsetup-1.0.6-r2', 'nomerge')


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


!!! The following installed packages are masked:
- dev-perl/DCOP-0.036 (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Samuli Suominen <ssuominen@gentoo.org> (06 Nov 2009)
# Cleaning out packages with KDE3 dependencies.
# Masked for removal in 30 days.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Das ist schlecht. Irgendwie hackts da gewaltig.
Wie löse ich das ganze auf?

grüße
dennis
_________________
Mein Rechner:
Gentoo Linux 2.6.29-gentoo-r5
Intel Core2Duo 6420 @ 2.13GHz
MB: Abit AB9
HDD: 2x Samsung 200GB


Last edited by skydoom on Sat Nov 14, 2009 5:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Sat Nov 14, 2009 5:07 pm    Post subject: Reply with quote

Probiers mal mit "emerge -C device-mapper".

Tobi

P.s: Das nächste Mal bitte einen aussagekräftigeren Titel
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
skydoom
Tux's lil' helper
Tux's lil' helper


Joined: 19 Aug 2006
Posts: 141
Location: Eschershausen, Niedersachsen

PostPosted: Sat Nov 14, 2009 5:49 pm    Post subject: Reply with quote

Vielen dank, funktioniert.
Mir stellt sich jetzt allerdings eine Frage, wie ist dieses Paket aufs System gekommen, warum ist es draufgekommen?
Ich weiß, Fragen die Ihr mir wahrscheinlich nicht beantworten könnt. Aber so wie ich das sehe hat device-mapper irgendwas mit lvm zutun, was ich jedoch nicht nutze.

Wegen dem Titel, sorry, beim nächsten mal.

grüße
dennis
_________________
Mein Rechner:
Gentoo Linux 2.6.29-gentoo-r5
Intel Core2Duo 6420 @ 2.13GHz
MB: Abit AB9
HDD: 2x Samsung 200GB
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Sat Nov 14, 2009 6:26 pm    Post subject: Reply with quote

Code:
('installed', '/', 'sys-fs/device-mapper-1.02.24-r1', 'nomerge') pulled in by
>=sys-fs/device-mapper-1.00.07-r1 required by ('installed', '/', 'sys-fs/cryptsetup-1.0.6-r2', 'nomerge')


Kommt also von cryptsetup
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
skydoom
Tux's lil' helper
Tux's lil' helper


Joined: 19 Aug 2006
Posts: 141
Location: Eschershausen, Niedersachsen

PostPosted: Sat Nov 14, 2009 6:31 pm    Post subject: Reply with quote

Aber cryptsetup arbeitet doch noch weiter, auch ohne device-mapper, oder?
Wäre schlecht wenn nicht.

grüße
dennis
_________________
Mein Rechner:
Gentoo Linux 2.6.29-gentoo-r5
Intel Core2Duo 6420 @ 2.13GHz
MB: Abit AB9
HDD: 2x Samsung 200GB
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Sat Nov 14, 2009 6:40 pm    Post subject: Reply with quote

skydoom wrote:
Aber cryptsetup arbeitet doch noch weiter, auch ohne device-mapper, oder?
Wäre schlecht wenn nicht.

grüße
dennis


Hmm. Keine Ahnung, schau mal ob er es bei "emerge cryptsetup -av1" wieder verlangt
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
ScytheMan
l33t
l33t


Joined: 30 Nov 2005
Posts: 605

PostPosted: Sat Nov 14, 2009 6:46 pm    Post subject: Reply with quote

imho wurde die funktionalität von device-mapper in lvm2 untergebracht, daher der block.
Back to top
View user's profile Send private message
skydoom
Tux's lil' helper
Tux's lil' helper


Joined: 19 Aug 2006
Posts: 141
Location: Eschershausen, Niedersachsen

PostPosted: Sat Nov 14, 2009 6:50 pm    Post subject: Reply with quote

ScytheMan wrote:
imho wurde die funktionalität von device-mapper in lvm2 untergebracht, daher der block.


Das stimmt, also nicht so schlimm.

Dankeschön :)
_________________
Mein Rechner:
Gentoo Linux 2.6.29-gentoo-r5
Intel Core2Duo 6420 @ 2.13GHz
MB: Abit AB9
HDD: 2x Samsung 200GB
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum