Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kde4 will Use +gnome?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Sun Nov 15, 2009 7:49 pm    Post subject: kde4 will Use +gnome? Reply with quote

Seit einiger Zeit habe ich immer folgende Meldung beim emerge -puD world:

Code:
localhost uhai # emerge -puD world

These are the packages that would be merged, in order:

Calculating dependencies       ... done!

emerge: there are no ebuilds built with USE flags to satisfy "gnome-base/gvfs[gnome]".
!!! One of the following packages is required to complete your request:
- gnome-base/gvfs-1.2.3 (Change USE: +gnome)
(dependency required by "gnome-base/libgnome-2.26.0" [ebuild])
(dependency required by "gnome-extra/yelp-2.26.0" [installed])
(dependency required by "app-doc/gnucash-docs-2.2.0" [installed])
(dependency required by "app-office/gnucash-2.2.9-r1" [installed])
(dependency required by "world" [argument])


emerge --info:

Code:
localhost uhai # emerge --info
Portage 2.1.6.13 (default/linux/x86/10.0/desktop, gcc-4.3.4, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r6 i686)                                                                                       
=================================================================                               
System uname: Linux-2.6.30-gentoo-r6-i686-AMD_Athlon-tm-with-gentoo-1.12.13                     
Timestamp of tree: Sun, 15 Nov 2009 18:15:03 +0000                                               
ccache version 2.4 [enabled]                                                                     
app-shells/bash:     4.0_p28                                                                     
dev-java/java-config: 1.3.7-r1, 2.1.9-r1                                                         
dev-lang/python:     2.4.6, 2.5.4-r3, 2.6.2-r1                                                   
dev-util/ccache:     2.4-r7                                                                     
dev-util/cmake:      2.6.4                                                                       
sys-apps/baselayout: 1.12.13                                                                     
sys-apps/sandbox:    1.6-r2                                                                     
sys-devel/autoconf:  2.13, 2.63-r1                                                               
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2                           
sys-devel/binutils:  2.18-r3                                                                     
sys-devel/gcc-config: 1.4.1                                                                     
sys-devel/libtool:   2.2.6a                                                                     
virtual/os-headers:  2.6.27-r2                                                                   
ACCEPT_KEYWORDS="x86"                                                                           
CBUILD="i686-pc-linux-gnu"                                                                       
CFLAGS="-O2 -march=athlon -pipe"                                                                 
CHOST="i686-pc-linux-gnu"                                                                       
CONFIG_PROTECT="/etc /etc/X11/xorg.conf /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"                                                       
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"                             
CXXFLAGS="-O2 -march=athlon -pipe"                                                               
DISTDIR="/usr/portage/distfiles"                                                                 
FEATURES="candy ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"                                                                       
GENTOO_MIRRORS="ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp.gentoo.mesh-solutions.com/gentoo/ http://pandemonium.tiscali.de/pub/gentoo/ ftp://pandemonium.tiscali.de/pub/gentoo/ http://gentoo.mneisen.org/ ftp://ftp.mneisen.org/gentoo http://mirror.switch.ch/ftp/mirror/gentoo/ ftp://mirror.switch.ch/mirror/gentoo/ ftp://ftp.solnet.ch/mirror/Gentoo http://gentoo.mirror.solnet.ch "                                                                                           
LANG="de_DE.UTF-8"                                                                               
LC_ALL="de_DE.UTF-8"                                                                             
LDFLAGS="-Wl,-O1"                                                                               
LINGUAS="de"                                                                                     
MAKEOPTS="-j2"                                                                                   
PKGDIR="/usr/portage/packages"                                                                   
PORTAGE_CONFIGROOT="/"                                                                           
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"   
PORTAGE_TMPDIR="/home/uhai/Fotos"                                                               
PORTDIR="/usr/portage"                                                                           
PORTDIR_OVERLAY="/usr/local/portage/layman/openstreetmap /usr/local/portage/layman/pro-audio /usr/local/portage/layman/sunrise /usr/local/portage/layman/local-overlay"                           
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"                                           
USE="X a52 aac acl acpi alsa ao apache2 audiofile berkdb bitmap-fonts bluetooth bzip2 cairo cda cdparanoia cdr cli consolekit cracklib crypt cups dbus dga dmx doc dri dssi dts dvd dvdr dvdread emboss encode evo fam firefox flac fortran gd gdbm gif glitz gpm gps gstreamer hal iconv ipv6 java jpeg jpeg2k kde kde4 lame ldap libnotify mad midi mikmod modules mp3 mp4 mpeg mudflap musicbrainz mysql ncurses nls nptl nptlonly nvidia objc ogg opengl openmp pam pcre pda pdf perl png ppds pppd prce print python qt3 qt3support qt4 quicktime readline reflection samba sdl session snmp sockets spell spl ssl startup-notification svg symlink sysfs tcpd thunar tiff truetype truetype-fonts type1-fonts unicode usb v4l v4l2 vorbis wavpack wddx win32codecs x264 x86 xine xml xml2 xorg xpm xscreensaver xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="nvidia v4l vesa fbdev sis"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Gnome will ich nicht auf diesem Rechner, wo kommt das jetzt her?

In den dependency-required-Zeilen war ursprünglich auch unison, das ich wieder entfernt habe. Daraufhin haben sich alle dependencies geändert. Was verlangt hier nach gnome? Unter kde3.5 hat es auch ohne geklappt....

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6281

PostPosted: Sun Nov 15, 2009 7:59 pm    Post subject: Reply with quote

Steht doch da: Du hast gnucash installiert. Das will gnucash-docs und das wiederum das Gnome-Hilfesystem yelp, wodurch dann der ganze Rest nachgezogen wird.
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4459

PostPosted: Sun Nov 15, 2009 8:00 pm    Post subject: Reply with quote

öhm ich sehe keine referenz zu kde4 in deinen ausgaben. Nur gnucash, welches gnome benötigt.
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Sun Nov 15, 2009 8:08 pm    Post subject: Reply with quote

gnucash war schon mit kde3.5 auf dem Rechner mit Use=-gnome. Daran hat sich auch nichts geändert nach Installation von kde4.3.

Zuerst stand dort auch nicht gnucash, sondern unison. Nachdem ich unison von der Platte geputzt habe, tauchen jetzt andere Programme anstatt auf. Jedes Programm, das ich entferne wird durch andere ersetzt...

Wenn unter kde3.5 dieser Effekt nicht auftrat, warum dann mit kde4.3?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4459

PostPosted: Sun Nov 15, 2009 8:29 pm    Post subject: Reply with quote

uhai wrote:
gnucash war schon mit kde3.5 auf dem Rechner mit Use=-gnome. Daran hat sich auch nichts geändert nach Installation von kde4.3.

Zuerst stand dort auch nicht gnucash, sondern unison. Nachdem ich unison von der Platte geputzt habe, tauchen jetzt andere Programme anstatt auf. Jedes Programm, das ich entferne wird durch andere ersetzt...

Wenn unter kde3.5 dieser Effekt nicht auftrat, warum dann mit kde4.3?

uhai

kde4 benötigt kein gnome. Ich vermute dass diese Problem durch ein anderes Paket ausgelöst wird, und da du vermutlich gleichzeitig auf kde-4 gewechselt bist und deshalb die falsche Vermutung anstellst, dass das Problem durch kde4 ausgelöst wird.
Laut dem ebuild von gnucash-2.2.9-r1 wird jetzt das gnome useflag für eine Abhängigkeit benötigt. Und zwar verlangt das ebuild von gnucash für goffice dass das gnome useflag aktiv ist.
gnucash-2.2.9-r1.ebuild wrote:
>=x11-libs/goffice-0.6[gnome]

Und es kann sein, dass noch andere pakete, welche von gnucash direkt oder indirekt benötig werden, ihrerseits eine abhängigkeit haben, welche gnome als useflag benötigt.
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Mon Nov 16, 2009 7:38 pm    Post subject: Reply with quote

unison habe ich jetzt weder installiert, ohne dass er
Code:
USE=+gnome
verlangt hat.

gnome/gvfs kann ich anscheinend auch installieren mit -gnome:

Code:
localhost uhai # emerge -pvt gvfs

These are the packages that would be merged, in reverse order:

Calculating dependencies            ... done!
[ebuild  N    ] gnome-base/gvfs-1.2.3  USE="bluetooth doc hal samba -archive -avahi -bash-completion -cdda -debug -fuse -gnome -gnome-keyring -gphoto2" 0 kB


Jedenfalls meckert er hier nicht herum...

Ein anderer Versuch war "emerge --newuse" mit diesem Ergebnis:

Code:
localhost uhai # emerge --newuse -p world

These are the packages that would be merged, in order:

Calculating dependencies                                        ... done!
[ebuild     U ] media-libs/taglib-1.6 [1.5] USE="-examples% -static-libs%"
[ebuild     U ] net-analyzer/iptraf-3.0.0-r5 [3.0.0-r4]                   
[ebuild     U ] dev-python/setuptools-0.6.4 [0.6-r1]                       
[ebuild     U ] media-libs/libpano13-2.9.14 [2.9.12]                       
[ebuild  N    ] dev-java/cldc-api-1.1                                     
[ebuild  N    ] dev-java/gnu-regexp-1.1.4-r2  USE="doc -source"           
[ebuild  N    ] app-admin/eselect-boost-0.3                               
[ebuild     U ] dev-util/boost-build-1.35.0-r2 [1.35.0-r1]                 
[ebuild     U ] dev-python/cython-0.11.3 [0.11.2]                         
[ebuild     U ] dev-util/mercurial-1.3.1-r1 [1.2.1]                       
[ebuild     U ] dev-libs/boost-1.35.0-r5 [1.35.0-r2] USE="eselect%* python%*"
[ebuild  NS   ] dev-java/lucene-1.9.1 [1.4.3-r3, 2.3.2] USE="doc -source -test"
[ebuild  N    ] dev-java/commons-el-1.0-r2  USE="-source"                       
[ebuild  NS   ] dev-java/tomcat-servlet-api-5.5.27-r1 [3, 4.1.36] USE="doc -source"
[ebuild  NS   ] dev-java/lucene-analyzers-1.9.1-r1 [2.3.2] USE="-source"           
[ebuild  N    ] dev-java/qdox-1.6.3  USE="doc -source"                             
[ebuild  N    ] dev-java/java-getopt-1.0.13  USE="doc -source"                     
[ebuild  N    ] dev-java/ant-owanttask-1.1-r12                                     
[ebuild  N    ] dev-java/asm-2.0-r1  USE="doc -source"                             
[ebuild  N    ] dev-java/jarjar-0.9  USE="doc -source -test"                       
[ebuild  N    ] dev-java/hamcrest-core-1.1  USE="-source"                           
[ebuild  NS   ] dev-java/junit-4.6 [3.8.2-r1] USE="doc -examples -source -test"     
[ebuild     U ] net-dialup/ppp-2.4.4-r24 [2.4.4-r23] USE="-gtk*"                   
[ebuild   R   ] media-sound/alsa-tools-1.0.20-r1  USE="-gtk*"                       
[ebuild   R   ] sci-mathematics/scilab-4.1.2-r1  USE="-gtk*"                       
[ebuild     U ] x11-themes/slim-themes-1.2.3a-r4 [1.2.3a-r3]                       
[ebuild   R   ] dev-util/git-1.6.4.4  USE="-gtk*"                                   
[ebuild     U ] x11-libs/qt-core-4.5.3-r2 [4.5.2]                                   
[ebuild     U ] x11-libs/qt-script-4.5.3-r1 [4.5.2]                                 
[ebuild     U ] x11-libs/qt-dbus-4.5.3-r1 [4.5.2]                                   
[ebuild  N    ] x11-libs/qt-xmlpatterns-4.5.3-r1  USE="-debug -pch"                 
[ebuild     U ] x11-libs/qt-gui-4.5.3-r2 [4.5.2-r2] USE="-gtk*"                     
[ebuild  N    ] media-libs/taglib-extras-1.0.1  USE="-debug"                       
[ebuild  N    ] media-sound/amarok-utils-2.2.0  USE="-debug"                       
[ebuild   R   ] x11-misc/xlockmore-5.28  USE="-esd* -gtk*"                         
[ebuild     U ] dev-db/mysql-5.0.84-r1 [5.0.70-r1] USE="community%* -profiling%"   
[ebuild     U ] x11-libs/qt-sql-4.5.3 [4.5.2]                                       
[ebuild     U ] x11-libs/qt-qt3support-4.5.3 [4.5.2]                               
[ebuild     U ] app-admin/apache-tools-2.2.14 [2.2.11]                             
[ebuild     U ] www-servers/apache-2.2.14-r1 [2.2.11-r2]                           
[ebuild     U ] dev-lang/php-5.2.11-r1 [5.2.11]                                     
[ebuild   R   ] x11-libs/gtk+-2.16.6  USE="(-X%*)"                                 
[ebuild     U ] net-fs/samba-3.0.37 [3.0.36]                                       
[ebuild     U ] net-libs/xulrunner-1.9.1.4 [1.9.0.14] USE="alsa%* python%* -debug% -sqlite%"
[ebuild     UD] www-client/mozilla-firefox-2.0.0.19 [3.0.14] USE="ipv6%* -debug% -filepicker% -moznopango% -xforms% -xinerama%"                                                                   
[ebuild     U ] app-misc/mc-4.7.0_pre3 [4.7.0_pre1] USE="edit%*"                                 
[ebuild  N    ] dev-java/swt-3.4-r4  USE="cairo opengl xulrunner -gnome"                         
[ebuild     U ] www-client/mozilla-firefox-3.5.4 [3.0.14] USE="alsa%* -sqlite%" LINGUAS="-as% -bn_BD% -es_CL% -es_MX% -fa% -hr% -kk% -ml% -or% -rm% -ta% -ta_LK% -vi%"                           
[ebuild     U ] app-text/acroread-9.2 [9.1.3]                                                   
[ebuild  NS   ] dev-java/eclipse-ecj-3.4-r4 [3.2.2-r1] USE="-java6"                             
[ebuild  N    ] dev-java/ant-eclipse-ecj-3.4                                                     
[ebuild  NS   ] dev-util/eclipse-sdk-3.4-r2 [3.2.1-r3] USE="doc -java6"                         
[ebuild   R   ] sci-geosciences/gpsbabel-1.3.6  USE="(-debug%)"                                 
[ebuild   R   ] media-video/mplayer-1.0_rc2_p20090731  USE="-esd*"                               
[ebuild     U ] media-gfx/hugin-0.8.0 [0.7.0] USE="-lapack%" LINGUAS="de%* -bg% -ca% -cs% -en_GB% -es% -fr% -hu% -it% -ja% -ko% -nl% -pl% -pt_BR% -ru% -sk% -sl% -sv% -uk% -zh_CN% -zh_TW%"       
[ebuild     U ] games-engines/scummvm-1.0.0_rc1 [0.13.1]                                         
[ebuild     U ] games-strategy/widelands-0.0.14 [0.0.13]                                         
[ebuild   R   ] dev-db/knoda-0.8.3  USE="(-arts%*)"                                             
[ebuild   R   ] net-im/pidgin-2.6.3  USE="-gtk*"                                                 
[ebuild     U ] sys-apps/hal-0.5.13-r2 [0.5.12_rc1-r8]                                           
[ebuild     U ] app-misc/hal-info-20090716 [20090414]                                           
[ebuild   R   ] x11-drivers/nvidia-drivers-173.14.20  USE="-gtk*"                               
[ebuild   R   ] x11-drivers/linuxwacom-0.8.4_p1  USE="-gtk*"                                     
[ebuild   R   ] app-misc/beagle-0.3.9-r1  USE="-gtk*"                                           
[ebuild   R   ] media-libs/xine-lib-1.1.16.3-r1  USE="-esd* -gtk* (-arts%*)"                     
[ebuild   R   ] net-print/gutenprint-5.1.4  USE="-gtk*"                                         
[ebuild  N    ] x11-libs/qtscriptgenerator-0.1.0  USE="kde -debug"                               
[ebuild   R   ] app-office/openoffice-3.1.1  USE="kde* -gtk*"                                   
[ebuild  NS   ] media-sound/amarok-2.2.0 [1.4.10_p20090130-r3] USE="opengl semantic-desktop (-aqua) -cdda -daap -debug -ipod -lastfm -mp3tunes -mtp" LINGUAS="de -bg -ca -cs -da -en_GB -es -et -eu -fi -fr -it -ja -km -nb -nds -nl -pa -pl -pt -pt_BR -ru -sl -sr -sr@latin -sv -th -tr -uk -wa -zh_TW"                                                                                           
[ebuild  NS   ] app-cdr/k3b-1.68.0_alpha3 [1.0.5-r6] USE="dvd encode ffmpeg flac lame mad musicbrainz sndfile vcd vorbis wav (-aqua) -debug -emovix -sox -taglib"                                 
[blocks B     ] >x11-libs/qt-dbus-4.5.2-r9999 (">x11-libs/qt-dbus-4.5.2-r9999" is blocking x11-libs/qt-test-4.5.2, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-script-4.5.2, x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)                                                               
[blocks B     ] <x11-libs/qt-svg-4.5.3 ("<x11-libs/qt-svg-4.5.3" is blocking x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-xmlpatterns-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-sql-4.5.3)                   
[blocks B     ] <x11-libs/qt-sql-4.5.3 ("<x11-libs/qt-sql-4.5.3" is blocking x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-xmlpatterns-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-script-4.5.3-r1)                                         
[blocks B     ] <x11-libs/qt-webkit-4.5.3 ("<x11-libs/qt-webkit-4.5.3" is blocking x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-xmlpatterns-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-sql-4.5.3)             
[blocks B     ] >x11-libs/qt-core-4.5.2-r9999 (">x11-libs/qt-core-4.5.2-r9999" is blocking x11-libs/qt-test-4.5.2, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-sql-4.5.2)                                                               
[blocks B     ] <x11-libs/qt-test-4.5.3 ("<x11-libs/qt-test-4.5.3" is blocking x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-xmlpatterns-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-sql-4.5.3)                 
[blocks B     ] <x11-libs/qt-qt3support-4.5.3 ("<x11-libs/qt-qt3support-4.5.3" is blocking x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-xmlpatterns-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-sql-4.5.3)                                   
[blocks B     ] <x11-libs/qt-core-4.5.3 ("<x11-libs/qt-core-4.5.3" is blocking x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-xmlpatterns-4.5.3-r1, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-sql-4.5.3)                                           
[blocks B     ] <x11-libs/qt-script-4.5.3 ("<x11-libs/qt-script-4.5.3" is blocking x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-xmlpatterns-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-sql-4.5.3)                                         
[blocks B     ] >x11-libs/qt-gui-4.5.2-r9999 (">x11-libs/qt-gui-4.5.2-r9999" is blocking x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-test-4.5.2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)                                                                   
[blocks B     ] >x11-libs/qt-qt3support-4.5.2-r9999 (">x11-libs/qt-qt3support-4.5.2-r9999" is blocking x11-libs/qt-test-4.5.2, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-svg-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)                                                         
[blocks B     ] >x11-libs/qt-script-4.5.2-r9999 (">x11-libs/qt-script-4.5.2-r9999" is blocking x11-libs/qt-test-4.5.2, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-dbus-4.5.2, x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)                                                             
[blocks B     ] >x11-libs/qt-xmlpatterns-4.5.2-r9999 (">x11-libs/qt-xmlpatterns-4.5.2-r9999" is blocking x11-libs/qt-test-4.5.2, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)                         
[blocks B     ] >x11-libs/qt-sql-4.5.2-r9999 (">x11-libs/qt-sql-4.5.2-r9999" is blocking x11-libs/qt-test-4.5.2, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2)                                                                 
[blocks B     ] <x11-libs/qt-dbus-4.5.3 ("<x11-libs/qt-dbus-4.5.3" is blocking x11-libs/qt-xmlpatterns-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-sql-4.5.3)                                           
[blocks B     ] <x11-libs/qt-opengl-4.5.3 ("<x11-libs/qt-opengl-4.5.3" is blocking x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-xmlpatterns-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-sql-4.5.3)             
[blocks B     ] <x11-libs/qt-gui-4.5.3 ("<x11-libs/qt-gui-4.5.3" is blocking x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-xmlpatterns-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-sql-4.5.3)                                             

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.                 

  ('ebuild', '/', 'x11-libs/qt-script-4.5.3-r1', 'merge') pulled in by
    >=x11-libs/qt-script-4.5.1:4 required by ('installed', '/', 'kde-base/mimelib-4.3.1', 'nomerge')                                                                                             
    >=x11-libs/qt-script-4.5.1:4 required by ('installed', '/', 'kde-base/libkcddb-4.3.1', 'nomerge')                                                                                             
    >=x11-libs/qt-script-4.5.1:4 required by ('installed', '/', 'kde-base/systemsettings-4.3.1', 'nomerge')                                                                                       
    (and 112 more)                                                                               

  ('installed', '/', 'x11-libs/qt-webkit-4.5.2-r1', 'nomerge') pulled in by
    >=x11-libs/qt-webkit-4.5.1:4[kde] required by ('installed', '/', 'kde-base/kdelibs-4.3.1-r2', 'nomerge')                                                                                     
    >=x11-libs/qt-webkit-4.5.1:4[kde] required by ('ebuild', '/', 'app-cdr/k3b-1.68.0_alpha3', 'merge')                                                                                           
    >=x11-libs/qt-webkit-4.5.1:4 required by ('installed', '/', 'dev-python/PyQt4-4.5.4-r4', 'nomerge')                                                                                           
    (and 1 more)                                                                                 

  ('installed', '/', 'x11-libs/qt-dbus-4.5.2', 'nomerge') pulled in by
    x11-libs/qt-dbus:4 required by ('ebuild', '/', 'x11-libs/qtscriptgenerator-0.1.0', 'merge')
    >=x11-libs/qt-dbus-4.4.0:4 required by ('installed', '/', 'media-sound/phonon-4.4_pre20090520', 'nomerge')                                                                                   
    >=x11-libs/qt-dbus-4.5.1:4 required by ('installed', '/', 'dev-python/PyQt4-4.5.4-r4', 'nomerge')                                                                                             
    (and 4 more)                                                                                 

  ('ebuild', '/', 'x11-libs/qt-dbus-4.5.3-r1', 'merge') pulled in by
    x11-libs/qt-dbus:4 required by ('ebuild', '/', 'x11-libs/qtscriptgenerator-0.1.0', 'merge')
    >=x11-libs/qt-dbus-4.4.0:4 required by ('installed', '/', 'media-sound/phonon-4.4_pre20090520', 'nomerge')                                                                                   
    >=x11-libs/qt-dbus-4.5.1:4 required by ('installed', '/', 'dev-python/PyQt4-4.5.4-r4', 'nomerge')                                                                                             
    (and 4 more)                                                                                 

  ('installed', '/', 'x11-libs/qt-test-4.5.2', 'nomerge') pulled in by
    >=x11-libs/qt-test-4.5.1:4 required by ('installed', '/', 'kde-base/knotify-4.3.1', 'nomerge')                                                                                               
    >=x11-libs/qt-test-4.5.1:4 required by ('installed', '/', 'kde-base/kdelibs-4.3.1-r2', 'nomerge')                                                                                             
    >=x11-libs/qt-test-4.4.0:4 required by ('installed', '/', 'media-sound/phonon-4.4_pre20090520', 'nomerge')                                                                                   
    (and 112 more)                                                                               

  ('installed', '/', 'x11-libs/qt-qt3support-4.5.2', 'nomerge') pulled in by
    >=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('installed', '/', 'kde-base/khotkeys-4.3.1', 'nomerge')                                                                     
    >=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('installed', '/', 'kde-base/libkexiv2-4.3.1', 'nomerge')                                                                     
    >=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('installed', '/', 'kde-base/klinkstatus-4.3.1', 'nomerge')                                                                   
    (and 110 more)                                                                               

  ('installed', '/', 'x11-libs/qt-script-4.5.2', 'nomerge') pulled in by
    >=x11-libs/qt-script-4.5.1:4 required by ('installed', '/', 'kde-base/mimelib-4.3.1', 'nomerge')                                                                                             
    >=x11-libs/qt-script-4.5.1:4 required by ('installed', '/', 'kde-base/libkcddb-4.3.1', 'nomerge')                                                                                             
    >=x11-libs/qt-script-4.5.1:4 required by ('installed', '/', 'kde-base/systemsettings-4.3.1', 'nomerge')                                                                                       
    (and 112 more)                                                                               

  ('installed', '/', 'x11-libs/qt-core-4.5.2', 'nomerge') pulled in by
    >=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('installed', '/', 'kde-base/kdesu-4.3.1', 'nomerge')                                                                                 
    >=x11-libs/qt-core-4.4:4 required by ('ebuild', '/', 'media-sound/amarok-utils-2.2.0', 'merge')                                                                                               
    >=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('installed', '/', 'kde-base/kdemultimedia-kioslaves-4.3.1', 'nomerge')                                                               
    (and 127 more)                                                                               

  ('ebuild', '/', 'x11-libs/qt-qt3support-4.5.3', 'merge') pulled in by
    >=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('installed', '/', 'kde-base/khotkeys-4.3.1', 'nomerge')                                                                     
    >=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('installed', '/', 'kde-base/libkexiv2-4.3.1', 'nomerge')                                                                     
    >=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('installed', '/', 'kde-base/klinkstatus-4.3.1', 'nomerge')                                                                   
    (and 110 more)                                                                               

  ('ebuild', '/', 'x11-libs/qt-gui-4.5.3-r2', 'merge') pulled in by
    >=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('installed', '/', 'kde-base/kdepim-kresources-4.3.1', 'nomerge')                                                                   
    >=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('installed', '/', 'kde-base/plasma-runtime-4.3.1', 'nomerge')                                                                     
    >=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('installed', '/', 'kde-base/libkdegames-4.3.1', 'nomerge')                                                                         
    (and 124 more)                                                                               

  ('installed', '/', 'x11-libs/qt-gui-4.5.2-r2', 'nomerge') pulled in by
    >=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('installed', '/', 'kde-base/kdepim-kresources-4.3.1', 'nomerge')                                                                   
    >=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('installed', '/', 'kde-base/plasma-runtime-4.3.1', 'nomerge')                                                                     
    >=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('installed', '/', 'kde-base/libkdegames-4.3.1', 'nomerge')                                                                         
    (and 127 more)                                                                               

  ('ebuild', '/', 'x11-libs/qt-xmlpatterns-4.5.3-r1', 'merge') pulled in by
    x11-libs/qt-xmlpatterns:4 required by ('ebuild', '/', 'x11-libs/qtscriptgenerator-0.1.0', 'merge')                                                                                           

  ('installed', '/', 'x11-libs/qt-sql-4.5.2', 'nomerge') pulled in by
    >=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('installed', '/', 'kde-base/kdialog-4.3.1', 'nomerge')                                                                                     
    >=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('installed', '/', 'kde-base/kig-4.3.1', 'nomerge')                                                                                         
    >=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('installed', '/', 'kde-base/kfind-4.3.1', 'nomerge')                                                                                       
    (and 114 more)                                                                               

  ('installed', '/', 'x11-libs/qt-opengl-4.5.2-r1', 'nomerge') pulled in by
    >=x11-libs/qt-opengl-4.5.1:4 required by ('installed', '/', 'media-plugins/kipi-plugins-0.6.0', 'nomerge')                                                                                   
    >=x11-libs/qt-opengl-4.4.0:4 required by ('installed', '/', 'media-sound/phonon-4.4_pre20090520', 'nomerge')                                                                                 
    >=x11-libs/qt-opengl-4.5.1:4 required by ('installed', '/', 'kde-base/kdelibs-4.3.1-r2', 'nomerge')                                                                                           
    (and 10 more)                                                                               

  ('installed', '/', 'x11-libs/qt-svg-4.5.2', 'nomerge') pulled in by
    >=x11-libs/qt-svg-4.5.1:4 required by ('installed', '/', 'kde-base/kdebase-startkde-4.3.1', 'nomerge')                                                                                       
    >=x11-libs/qt-svg-4.5.1:4 required by ('installed', '/', 'kde-base/systemsettings-4.3.1', 'nomerge')                                                                                         
    >=x11-libs/qt-svg-4.5.1:4 required by ('ebuild', '/', 'app-office/openoffice-3.1.1', 'merge')
    (and 111 more)                                                                               

  ('ebuild', '/', 'x11-libs/qt-core-4.5.3-r2', 'merge') pulled in by
    >=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('installed', '/', 'kde-base/kxsldbg-4.3.1', 'nomerge')                                                                               
    >=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('installed', '/', 'kde-base/kdesu-4.3.1', 'nomerge')                                                                                 
    >=x11-libs/qt-core-4.4:4 required by ('ebuild', '/', 'media-sound/amarok-utils-2.2.0', 'merge')                                                                                               
    (and 125 more)                                                                               

  ('ebuild', '/', 'x11-libs/qt-sql-4.5.3', 'merge') pulled in by
    >=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('installed', '/', 'kde-base/kdialog-4.3.1', 'nomerge')                                                                                     
    >=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('installed', '/', 'kde-base/kig-4.3.1', 'nomerge')                                                                                         
    >=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('installed', '/', 'kde-base/kfind-4.3.1', 'nomerge')                                                                                       
    (and 114 more)                                                                               


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):   

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


!!! The following installed packages are masked:
- kde-base/libkcal-3.5.10 (masked by: package.mask)
/usr/portage/profiles/package.mask:               
# Samuli Suominen <ssuominen@gentoo.org> (07 Nov 2009)
#                                                     
# Mask KDE 3.5.10 for removal, excluding the dependencies
# required for stable koffice. Removed in 30 days.       
#                                                       

- kde-base/kiconedit-3.5.10 (masked by: package.mask)
- kde-base/kbabel-3.5.10 (masked by: package.mask)   
- kde-base/libkmime-3.5.10 (masked by: package.mask)
- kde-base/ksvg-3.5.10 (masked by: package.mask)     
- kde-base/kbackgammon-3.5.10 (masked by: package.mask)
- kde-base/arts-3.5.10 (masked by: package.mask)       
- kde-base/kfind-3.5.10 (masked by: package.mask)     
- kde-base/ktnef-3.5.10 (masked by: package.mask)     
- kde-base/kdemultimedia-kfile-plugins-3.5.10 (masked by: package.mask)
- kde-base/kwalletmanager-3.5.10 (masked by: package.mask)             
- kde-base/kenolaba-3.5.10 (masked by: package.mask)                   
- kde-base/dcoppython-3.5.10 (masked by: package.mask)                 
- kde-base/quanta-3.5.10 (masked by: package.mask)                     
- kde-base/libkdegames-3.5.10 (masked by: package.mask)               
- kde-base/kxkb-3.5.10 (masked by: package.mask)                       
- app-antivirus/klamav-0.46 (masked by: package.mask)                 
/usr/portage/profiles/package.mask:
# Samuli Suominen <ssuominen@gentoo.org> (06 Nov 2009)
# Cleaning out packages with KDE3 dependencies.
# Masked for removal in 30 days.

- kde-base/konq-plugins-3.5.10 (masked by: package.mask)
- kde-base/libkcddb-3.5.10 (masked by: package.mask)
- kde-base/kdemultimedia-arts-3.5.10 (masked by: package.mask)
- kde-base/kate-3.5.10 (masked by: package.mask)
- kde-base/kdeaddons-docs-konq-plugins-3.5.10 (masked by: package.mask)
- kde-base/kregexpeditor-3.5.10 (masked by: package.mask)
- kde-base/konqueror-3.5.10 (masked by: package.mask)
- kde-base/kate-plugins-3.5.10 (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Da habe ich erstmal genug zutun...

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum