Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Amarok spielt nicht und beendet nicht
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Schinkencroissant
Guru
Guru


Joined: 09 Oct 2009
Posts: 309

PostPosted: Sun Nov 15, 2009 10:36 pm    Post subject: Amarok spielt nicht und beendet nicht Reply with quote

Hallo alle zusammen,

nach dem man mir hier im Forum erzählt hat, dass Amarok 2.2 endlich wieder Abspiel-Statistiken benutzt, die es früher mal bei 1.4 gab, habe ich den auch installiert und tatsächlich, die Funktionen sind drin. Ursprünglich gab es auch kein Problem (seit ich weiß, dass man lastfm ein USE-Flag ist...).

Jetzt habe ich mir allerdings (ich weiß nicht, ob der Zusammenhang wirklich darin liegt, aber es wäre wohl durchaus denkbar) ein Plugin für Opera installieren wollen, damit ich DivX-Videos online kucken kann (abseits meiner Frage kann mir bestimmt auch jemand verraten, wie das heißt, was ich installieren kann, dass mir dann bei einer Seite mit eingebettetem DivX-Video vorgeschlagen wird, das eingebettete Video mit einem installierten Player zu installieren). Da kam dann leider der ganze mplayer mit, der mir eigentlich nicht gefällt, da ich KDE benutze und eigentlich mit dem Dragon-Player ganz zu Frieden bin und ich denke, das Problem besteht seither, bin mir aber nicht so ganz sicher.

Das Problem sieht so aus, dass Amarok sich öffnen lässt, wenn ich dann ein Lied abspielen will, wechselt oben das Symbol am entsprechenden Knopf von Play auch auf Pause und unten neben der Uhr wird mir im Systemabschnitt auch ein Amarok-Symbol mit einem Abspielpfeil angezeigt. Auch wenn ich mit der Maus darüberfahre, zeigt es mir an, welches Lied gerade läuft, nur leider bleibt das Lied bei 0 Sekunden stehen und wird weiterhin als spielend angezeigt. Dementsprechend höre ich natürlich auch nichts.

Wenn ich Amarok dann beenden will (Rechtsklick -> Beenden im Systemabschnitt), dann verschwindet nur das offene Fenster, aber im Systemabschnitt bleibt er stehen. Nochmal beenden funktioniert nicht, es sei denn, ich schicke ihm von außen ein TERM-Signal.

Vielleicht kann mir da ja jemand weiterhelfen.

Viele Grüße,

Schinkencroissant
_________________
"Es muss ein Lehrplan her und eine Wertediskussion
und keine Werte unter 120 Phon!"

- J.B.O.
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Mon Nov 16, 2009 8:15 am    Post subject: Reply with quote

Ich würde ausschließen, dass der mplayer Deinen Amarok kaputt macht. mplayer bringt seine eigenen libs mit. Amarok basiert entweder auf gestreamer oder auf xine-lib bzw. auf phonon-kde.

Zum Betrachten von eingebetteten Videos benötigst du den gecko-mediaplayer.

Btw: mplayer ist eigentlich der beste Videoplayer, den es überhaupt für Linux gibt. Was der nicht abspielt, spielt keiner ab.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Mon Nov 16, 2009 11:07 am    Post subject: Reply with quote

Und weil der mplayer so dolle ist und du kde4 verwendest, solltest du dir mal "smplayer" anschauen.
Ist eine richtig gute Qt4-Gui für den mplayer.
Evtl. ist aber auch vlc mit dem Qt4-Frontend was für dich, ich hatte auch noch kein Video, das vlc nicht gepackt hätte.
Und wenn du ganz experminetierfreudig bist probierst du dann gleich noch aus dem kdeplayground das vlc-phonon-Backend aus, oder gleich das mplayer-Backend ;)
(Gibts dafür schon ebuilds?)
Back to top
View user's profile Send private message
AmonAmarth
l33t
l33t


Joined: 03 Mar 2005
Posts: 727

PostPosted: Mon Nov 16, 2009 11:54 am    Post subject: Reply with quote

ich würde vorschlagen du startest amarok mal aus der konsole und schaust was diese ausgibt beim einfrieren von amarok. ich vermute acuh das irgendwas am phonon backend nicht stimmt. alternativ kannst du auch mal die konfigurationsdateien von amarok und phonon löschen/verschieben/(durchsehen):
Code:
~/.kde4/share/apps/amarok
Code:
~/.kde4/share/config/amarok*
Code:
~/.kde4/share/config/phonondevicesrc
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Mon Nov 16, 2009 12:03 pm    Post subject: Reply with quote

Du kannst auch ein provisorisches revdep-rebuild starten.
Es kann nämlich sein, dass dein Backend einfach einen Decoder nicht laden kann.
Hat das mplayer installieren irgend welche anderen Updates nachgezogen?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum