Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Probleme bei der stage2 Erstellung (catalyst)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
ZNk
n00b
n00b


Joined: 18 Nov 2009
Posts: 2

PostPosted: Wed Nov 18, 2009 10:43 am    Post subject: Probleme bei der stage2 Erstellung (catalyst) Reply with quote

Hallo zusammen,
bei der Stage2 - Erstellung einer Live CD mit Hilfe von Catalyst kommt es zu einer seltsamen Fehlermeldung.

Fehlerausgabe
Code:

Using default Catalyst configuration file, /etc/catalyst/catalyst.conf
Setting sharedir to config file value "/usr/lib/catalyst"
Setting snapshot_cache to config file value "/var/tmp/catalyst/snapshot_cache"
Setting hash_function to config file value "crc32"
Setting storedir to config file value "/var/tmp/catalyst"
Setting portdir to config file value "/usr/portage"
Setting distdir to config file value "/usr/portage/distfiles"
Setting options to config file value "autoresume ccache kerncache metadata_overlay pkgcache seedcache snapcache"
Autoresuming support enabled.
Compiler cache support enabled.
Kernel cache support enabled.
Package cache support enabled.
Seed cache support enabled.
Snapshot cache support enabled.
Use of metadata_overlay module for portage enabled.
Envscript support enabled.
Using target: livecd-stage2
Building natively for x86
Caching snapshot to /var/tmp/catalyst/snapshot_cache/2009.1/
The autoresume path is /var/tmp/catalyst/tmp/default/.autoresume-livecd-stage2-x86-2009.1/
Location of the package cache is /var/tmp/catalyst/packages/default/livecd-stage2-x86-2009.1/
Location of the kerncache is /var/tmp/catalyst/kerncache/default/livecd-stage2-x86-2009.1/
Checking for processes running in chroot and killing them.
--- Running action sequence: unpack
No Valid Resume point detected, cleaning up  ...
Removing AutoResume Points: ...
Emptying directory /var/tmp/catalyst/tmp/default/.autoresume-livecd-stage2-x86-2009.1/
Emptying directory /var/tmp/catalyst/tmp/default/livecd-stage2-x86-2009.1/

!!! catalyst: Could not find appropriate source. Please check the 'source_subpath' setting in the spec file.

!!! catalyst: Error encountered during run of target livecd-stage2

Catalyst aborting....
lockfile does not exist '/var/tmp/catalyst/tmp/default/livecd-stage2-x86-2009.1/.catalyst_lock'


Das Problem tritt bei sämtlichen stage2.spec Dateien auf, die ich testweise erstellt habe. Auch wenn ich hierfür andere Gentoo Stage Archive verwende.

Catalyst Version
Code:

catalyst --version
Catalyst, version 2.0.6
Copyright 2003-2008 Gentoo Foundation
Distributed under the GNU General Public License version 2

Catalyst version 2.0.6


Systeminformationen Host System
Code:

emerge --info
Portage 2.1.6.13 (default/linux/x86/10.0, gcc-4.3.4, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r8 i686)
=================================================================
System uname: Linux-2.6.30-gentoo-r8-i686-Intel-R-_Core-TM-2_CPU_T5600_@_1.83GHz-with-gentoo-1.12.13
Timestamp of tree: Mon, 16 Nov 2009 19:20:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:     4.0_p28
dev-lang/python:     2.6.2-r1
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.63-r1
sys-devel/automake:  1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ "
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j6"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="acl berkdb bzip2 ccache cli cracklib crypt cups dri fortran gdbm gpm iconv ipv6 modules mudflap ncurses nls nptl nptlonly openmp pam pcre perl pppd python readline reflection session spl ssl sysfs tcpd unicode vim vim-syntax x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

Code:

uname -ar
Linux CoreHost 2.6.30-gentoo-r8 #3 SMP Mon Nov 16 21:36:32 CET 2009 i686 Intel(R) Core(TM)2 CPU T5600 @ 1.83GHz GenuineIntel GNU/Linux


Ich habe früher schon mit Catalyst Live CDs, respektive Flash Drives erstellt und dieser Fehler ist bis dato noch nicht aufgetreten, selbst eine ausführliche Google Suche hat leider keine Lösungsansätze finden können.

Meine aktuellen Catalyst Konfigurationsdateien findet ihr hier:
-> Stage1.spec: http://nopaste.info/5c02b0880f.html
-> Stage2.spec: http://nopaste.info/4a19a4e141.html
-> Catalyst.conf: http://nopaste.info/46d2b902c8.html
-> Catalystrc: http://nopaste.info/de4e5ba8cf.html

Schönen Gruß & vielen Dank
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Wed Nov 18, 2009 11:17 am    Post subject: Reply with quote

Ich hab zwar noch nix mit Catalyst gemacht, aber mir fällt auf, dass du veraltete Profiles verwendest.
Du verwendest (im spec) 2008.0, aktuell ist 10.0 (wie du es scheinbar am Rechner eingestellt hast -> emerge --info). Stell das mal um.
Allerdings weiß ich nicht, ob das der Fehler ist ;)

Grüße
Franz
Back to top
View user's profile Send private message
ZNk
n00b
n00b


Joined: 18 Nov 2009
Posts: 2

PostPosted: Wed Nov 18, 2009 12:13 pm    Post subject: Reply with quote

Danke für die schnelle Antwort. Aber daran scheint es leider nicht zu liegen. Zuerst hatte ich das ebenfalls mit einem aktuellen 10.0'er Profil ausprobiert (entsprechend dem Host-System), das schlug allerdings auch fehl.
Danach hatte ich die originalen Gentoo Spec Dateien für die minimal (install) Live CD benutzt und ein paar Einstellungen angepasst. Der Fehler muss woanders liegen.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum