Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[xorg] probleme avec dri
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
sylvain.bonnemaison
Apprentice
Apprentice


Joined: 13 Jan 2008
Posts: 152

PostPosted: Thu Nov 19, 2009 8:34 pm    Post subject: [xorg] probleme avec dri Reply with quote

Bonjour,

Suite à la mise à jour du système, Xorg trace les erreurs suivantes :
Code:
(EE) Failed to load module "dri" (module does not exist, 0)
(EE) Failed to load module "dri2" (module does not exist, 0)

Quelle peut être la cause de ce problème ?

J'ai aussi des erreur du gestionaire du clavier (xkbcomp)
Code:
No symbols named "latin9" in the include file "us"

Dans le fichier xorg.conf, il est bien précisé que le clavier est "fr".

Au final, lorsque je suis dans l'interface d'authentification de gdm ou l'interface gnome, la vitesse de répétition des touche clavier ne respecte pas les réglages du fichier de configuration, trop rapide. J'ai vu plusieurs post sur ce problème sans pour résoudre ce problème sur mon poste.

Sylvain
Back to top
View user's profile Send private message
xelif
Apprentice
Apprentice


Joined: 16 Jan 2006
Posts: 152

PostPosted: Fri Nov 20, 2009 12:00 am    Post subject: Reply with quote

pour le clavier c'est surement un souci avec evdev

je ne m'y connais maleuresment pas j'ai désactivé ce useflag lors de la compil de X11

euh lors de ta mise à jour des modules ont du "oublié" d'etre mis à jour et peut etre leur version ne correspond surement pas avec la version de X

si tu tentes un :

Code:

emerge -av x11-proto/dri2proto x11-proto/xf86driproto


ca donne quoi?

[EDIT] Ces modules sont mis à jour si tu possèdes "dri" dans les use flags du serveur X
Back to top
View user's profile Send private message
Biloute
Guru
Guru


Joined: 03 Apr 2008
Posts: 366
Location: LENS

PostPosted: Fri Nov 20, 2009 8:54 am    Post subject: Reply with quote

A chaque fois que xorg-server est compilé, il faut recompiler les drivers ensuite, c'est à dire xf86-input-keyboard, xf86-input-mouse, ...
_________________
Gentoo rocks
Back to top
View user's profile Send private message
sylvain.bonnemaison
Apprentice
Apprentice


Joined: 13 Jan 2008
Posts: 152

PostPosted: Fri Nov 20, 2009 12:49 pm    Post subject: Reply with quote

J'ai déjà tout recompilé avec
Code:
emerge -e world
Cela ne change rien.
Même la configuration généré avec nvidia-xconfig génère les mêmes erreurs.
Back to top
View user's profile Send private message
brubru
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2008
Posts: 109
Location: France

PostPosted: Fri Nov 20, 2009 2:22 pm    Post subject: Reply with quote

Salut.

Si tu utilises les drivers propriétaires NVIDIA, je dirais que c'est normal:
Nvidia fait ça propre tambouille pour l'accélération graphique et n'utilise pas le DRI.
L'erreur vient que sur les nouveaux server Xorg, les extensions dri et dri2 sont activées par défaut, cela permet (entre autre) de se passer du fichier xorg.conf. Donc c'est deux erreurs ne sont pas génantes.

Bruno
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Fri Nov 20, 2009 4:10 pm    Post subject: Reply with quote

brubru +1 ! ;-)

Bien que non gênants, on peut faire disparaître ces messages en désactivant la tentative de chargement de ces modules avec les lignes suivantes dans la section "Module" de xorg.conf :
Code:
   Disable "dri"
   Disable "dri2"
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Sat Nov 21, 2009 11:39 am    Post subject: Reply with quote

Et que renvoie eselect opengl list ?
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum