Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge @preserved-rebuild weider und wieder... [SOLVED]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
mattes
Apprentice
Apprentice


Joined: 23 Jul 2008
Posts: 255
Location: München, Bavaria, Germany

PostPosted: Sat Nov 21, 2009 3:29 pm    Post subject: emerge @preserved-rebuild weider und wieder... [SOLVED] Reply with quote

Hallo,

neuerdings, seit einem größeren Update bekomme ich immer diese Meldung, dass einige Pakete wegen neuere Libs neu gebaut werden müssen:
Code:

 * Regenerating GNU info directory index...
 * Processed 232 info files.

!!! existing preserved libs:
>>> package: sys-libs/e2fsprogs-libs-1.41.9
 *  - /lib/libblkid.so
 *      used by /bin/mount (sys-apps/util-linux-2.16.1)
 *      used by /bin/umount (sys-apps/util-linux-2.16.1)
 *      used by /sbin/blkid (sys-apps/util-linux-2.16.1)
 *      used by 14 other files
 *  - /lib/libuuid.so
 *      used by /bin/mount (sys-apps/util-linux-2.16.1)
 *      used by /bin/umount (sys-apps/util-linux-2.16.1)
 *      used by /sbin/blkid (sys-apps/util-linux-2.16.1)
 *      used by 634 other files
>>> package: media-libs/jpeg-7
 *  - /usr/lib/libjpeg.so.62
 *  - /usr/lib/libjpeg.so.62.0.0
 *      used by /opt/googleearth/libIGAttrs.so (x11-misc/googleearth-4.3.7284.3916)
 *      used by /opt/googleearth/libIGCollision.so (x11-misc/googleearth-4.3.7284.3916)
 *      used by /opt/googleearth/libIGCore.so (x11-misc/googleearth-4.3.7284.3916)
 *      used by 10 other files
Use emerge @preserved-rebuild to rebuild packages using these libraries


Wenn ich preserved-rebuild ausführe, bekomme ich exakt die gleiche Ausgabe wieder...
revdep-rebuild finded alles i.O.

Kann ich das ignorieren bzw. resetten? Woher hat emerge diese Informationen?

Portage ist 2.2_rc33

Grüße
Mattes


Last edited by mattes on Tue Dec 01, 2009 5:17 pm; edited 1 time in total
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3628
Location: Germany

PostPosted: Sat Nov 21, 2009 5:02 pm    Post subject: Reply with quote

Hi

beim ersten Teil hilft es "sys-libs/e2fsprogs-libs" einmal zu deinstallieren und dan neu zu mergen.

Zu den
Quote:
* - /usr/lib/libjpeg.so.62
* - /usr/lib/libjpeg.so.62.0.0
solltest du ein
Code:
# revdep-rebuild --library libjpeg.so.62
durchbringen, dies ist wahrscheinlich etwas umfangreicher...
es wurde auch beim Update von "media-libs/jpeg-7" drauf hingewiesen
Quote:
WARN: postinst
Old versions of installed libraries were detected on your system.
In order to avoid breaking packages that depend on these old libs,
the libraries are not being removed. You need to run revdep-rebuild
in order to remove these old dependencies. If you do not have this
helper program, simply emerge the 'gentoolkit' package.

# revdep-rebuild --library libjpeg.so.62

Once you've finished running revdep-rebuild, it should be safe to
delete the old libraries. Here is a copy & paste for the lazy:
# rm '/usr/lib64/libjpeg.so.62'


PS: Du solltest dein Portage mal aktualisieren, aktuell sind wir schon bei "2.2_rc50" :wink:

MfG
Back to top
View user's profile Send private message
Carlo
Developer
Developer


Joined: 12 Aug 2002
Posts: 3356

PostPosted: Sat Nov 21, 2009 5:49 pm    Post subject: Reply with quote

Erstes Problem siehe bug 230257.


Josef.95 wrote:
# revdep-rebuild --library libjpeg.so.62

Das wird wohl kaum bei einem Blob a la Google Earth helfen. Dafür gibt's media-libs/jpeg-compat-6b-r1. Ein Update auf eine aktuelle GoogleEarth-Version ist hier wohl sinnvoller.

Josef.95 wrote:
Du solltest dein Portage mal aktualisieren, aktuell sind wir schon bei "2.2_rc50" :wink:

Unbedingt.
_________________
Please make sure that you have searched for an answer to a question after reading all the relevant docs.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3628
Location: Germany

PostPosted: Sat Nov 21, 2009 7:23 pm    Post subject: Reply with quote

Ah ja Sorry,
das mit der alten "googleearth" Version hatte ich übersehen...
Back to top
View user's profile Send private message
mattes
Apprentice
Apprentice


Joined: 23 Jul 2008
Posts: 255
Location: München, Bavaria, Germany

PostPosted: Sun Nov 22, 2009 6:58 pm    Post subject: Reply with quote

Hallo,

hab portage und GE auf die neuesten Versionen upgedatet und emerge @preserved-rebuild erneut 2 mal ausgeführt. Gleiches Verhalten, er merged jedes mal 74 Pakete...


Grüße
Mattes
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2328
Location: Konradsreuth (Germany)

PostPosted: Mon Nov 23, 2009 9:22 am    Post subject: Reply with quote

Ich hatte das auch erst. Ich denke, ich hab geschaut, zu wem /lib/libblkid.so und /lib/libuuid.so gehören (equery b ...), das Paket net gebaut und dann war’s gut … da haben sich denk ich irgendwelche Symlinks geändert oder so.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3628
Location: Germany

PostPosted: Mon Nov 23, 2009 11:26 am    Post subject: Reply with quote

Hmm..,die weiteren oben schon genannten Ratschläge bist du mal durchgegangen?
Hier konnte es so auf mehreren Systemen gelöst werden...

/edit
Ich hab grad noch mal nachgesehen, als ich vor ca. einem halben Jahr dies Problem mit den "e2fsprogs-libs" hatte hat mir dieser Link weitergeholfen.
Quote:
Check which files it is protecting:

portageq list_preserved_libs /

Then identify which package they belong to (equery f filename).
Manually delete the protected files, then emerge --oneshot the
packages they came from. That cleaned it up for me when a similar
thing happened a few weeks ago.

Paul
Back to top
View user's profile Send private message
mattes
Apprentice
Apprentice


Joined: 23 Jul 2008
Posts: 255
Location: München, Bavaria, Germany

PostPosted: Tue Dec 01, 2009 5:17 pm    Post subject: Reply with quote

Hallo,

ganz vergessen die Lösung zu posten :oops:

Dieser Link http://www.gossamer-threads.com/lists/gentoo/user/173997#173997 hat weitergeholfen.

Danke!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum