Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Reihenfolge der Module beim Genkernel
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
2bbionic
Tux's lil' helper
Tux's lil' helper


Joined: 24 Mar 2005
Posts: 134

PostPosted: Tue Nov 24, 2009 7:34 am    Post subject: Reihenfolge der Module beim Genkernel Reply with quote

Hallo alle,

ich habe hier das Problem, daß ich einen Server mit Genkernel starten muß (bzw. will) und daß das RAID-System (Adaptec RAID Contoller 5405) immer sda bekommt, egal, was sonst noch an anderen Platten angeschlossen ist.
Das Booten klappt mittlwerweile mit der UUID-Variante (ohne LABEL) sehr gut; ich habe aber immer noch das Problem, daß sich mein System nach dem Booten auf sdb statt sda "befindet".

Zuerst dachte ich, man könnte es innerhalb udev lösen; wurde aber daraus so ziemlich gar nicht schlau.
Daher war mein Gedanke, die bewährte Methode über die Lade-Reihenfolge der Module die Zuordnung der Namen zu beeinflussen - nur leider weiß ich nicht, wie ich dem genkernel bzw. der initrd das beibringen soll (ist einer meiner wenigen genkernel... :( )
Könnte mir jemand einen Tipp geben und mir auf die Sprünge helfen?

Vielen Dank schon mal,

2bbionic
Back to top
View user's profile Send private message
2bbionic
Tux's lil' helper
Tux's lil' helper


Joined: 24 Mar 2005
Posts: 134

PostPosted: Wed Nov 25, 2009 8:34 am    Post subject: Reply with quote

Keiner eine Idee ?
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4459

PostPosted: Wed Nov 25, 2009 8:58 am    Post subject: Reply with quote

wiso soll das ein Problem sein, wenn deine System-Platte als sdb erkannt wird statt als sda?

Die Reihenfolge der platten hängt davon ab auf welchem Port die Platte hängt und wann der Treiber des Festplatten-Controllers geladen wird und die angeschlossenen Festplatten erkennt.
Das einzige was ich mir vorstellen könnte um das "Problem" zu lösen, wenn der Treiber für den RAID-Adapter erst nach dem Treiber für den Controller, an dem die Systemplatte hängt, geladen wird.

Werden für beide Festplatten-Controller der selbe Treiber verwendet oder sind hier separate Treiber am werke.
Wenn es separate Treiber sind, dann würde ich versuchen, den Treiber für den Controller, an dem die Systemplatte hängt, fest in den kernel einzubinden statt als modul.
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
2bbionic
Tux's lil' helper
Tux's lil' helper


Joined: 24 Mar 2005
Posts: 134

PostPosted: Wed Nov 25, 2009 9:06 am    Post subject: Reply with quote

Das "Problem" ist eigentlich eher kosmetischer Natur. Einige Skripte haben fixe Partitionsangaben (sda3,sda5,...) und die fahren halt gegen die Wand.
Die Festplatten nutzen unterschiedliche Treiber; mein Problem ist halt, daß ich die Reihenfolge im genkernel ändern muß. Soweit ich das verstanden habe, würde es auch nichts nützen, den Treiber fest im Kernel einzubinden, weil ja die Hardwareerkennung nach der initrd schon abgeschlossen ist.
Kern des Problems wäre also die Frage, wie ich innerhalb der initrd die Lade-Reihenfolge ändern kann...

Grüße,

2bbionic
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4459

PostPosted: Wed Nov 25, 2009 9:31 am    Post subject: Reply with quote

2bbionic wrote:
Das "Problem" ist eigentlich eher kosmetischer Natur. Einige Skripte haben fixe Partitionsangaben (sda3,sda5,...) und die fahren halt gegen die Wand.

Was spricht dagegen einen Eintrag unter /dev/disk/ zu verwenden?

2bbionic wrote:
Die Festplatten nutzen unterschiedliche Treiber; mein Problem ist halt, daß ich die Reihenfolge im genkernel ändern muß. Soweit ich das verstanden habe, würde es auch nichts nützen, den Treiber fest im Kernel einzubinden, weil ja die Hardwareerkennung nach der initrd schon abgeschlossen ist.
Kern des Problems wäre also die Frage, wie ich innerhalb der initrd die Lade-Reihenfolge ändern kann...

Hmm wenn ich mich nicht ganz täusche müssten die Treiber, welche fest im kernel eingebaut sind, den Vorzug erhalten gegenüber den Treibern, welche erst in der initrd geladen werden.
Also einfach ausprobieren, statt Vermutungen anstellen ;)
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
2bbionic
Tux's lil' helper
Tux's lil' helper


Joined: 24 Mar 2005
Posts: 134

PostPosted: Wed Nov 25, 2009 11:51 am    Post subject: Reply with quote

Dagen spricht, daß ich ca. 200 Skripte umschreiben müßte - womit ich mich im Monent noch nicht anfreuden kann. Zudem sind da auch einige Binaries darunter - Altlasten von Programmierern :evil:
Ich habe AACRAID eben mal fest in den Kernel gebaut und mit genkernel --luks --disklabel initramfs eine neue initrd erstellt. Leider booted die Maschine damit nicht. Das gleiche passiert, wenn ich das AHCI-SATA Modul fest in den Kernel baue.
Gibt es sonst keine Möglichkeit, die Ladereihenfolge in der initrd zu ändern?

Grüße,

2bbionic
Back to top
View user's profile Send private message
Marlo
Veteran
Veteran


Joined: 26 Jul 2003
Posts: 1414

PostPosted: Wed Nov 25, 2009 3:44 pm    Post subject: Reply with quote

2bbionic wrote:
Dagen spricht, daß ich ca. 200 Skripte umschreiben müßte - womit ich mich im Monent noch nicht anfreuden kann.


Das ist bitter. 8O

Ob es funktioniert weis ich nicht, aber ich würde vor dem Umschreiben
auf jeden Fall die Grubfunktion map ausprobieren.
Natürlich müssen in der /boot/grub/grub.conf und in der /etc/fstab auch die entsprechenden Änderungen durchgeführt werden.
Aber mit dem Dualboot bzw. mapping der Partitionen
mit windows geht es ja auch.

Gruß
_________________
Thank you for your attention, interest and support.
------------------------------------------------------------------
http://radio.garden/
Back to top
View user's profile Send private message
2bbionic
Tux's lil' helper
Tux's lil' helper


Joined: 24 Mar 2005
Posts: 134

PostPosted: Wed Nov 25, 2009 7:45 pm    Post subject: Reply with quote

Die Frage bei Grub wäre, ob das was bringt. Wie gesagt, die Maschine bootet in beiden Fällen korrekt; einmal ist das System auf sda1 und das andere Mal halt auf sdb1. GRUB ist auf UuID eingestellt, die fstab ebenfalls, von den beiden erwarte ich also keine Probleme. Was ärgert, ist, daß die einzelne Platte sich quasi "in der Vordergrund" schiebt und nach dem booten sda ist - das System nach hinten verschoben wird auf sdb.
Es ist zum eierlegen - ich habe jetzt ca. 10 verschiedene Methoden ausprobiert (inkl. BIOS); dieses Problem in den Griff zu bekommen und ich scheitere immer wieder an der initramfs. Bekäme ich es dort in den Griff (in dem ich das Modul für den RAID-Adapter als erstes lade), wären alle Probleme auf einen Schlag weg.

2bbionic
Back to top
View user's profile Send private message
Marlo
Veteran
Veteran


Joined: 26 Jul 2003
Posts: 1414

PostPosted: Wed Nov 25, 2009 8:24 pm    Post subject: Reply with quote

2bbionic wrote:

..., die Maschine bootet in beiden Fällen korrekt; einmal ist das System auf sda1 und das andere Mal halt auf sdb1. GRUB ist auf UuID eingestellt, die fstab ebenfalls,


Wenn die Reihenfolge hin und her springt die Frage; Benutzt du den Parameter disklabel?
Code:

If you want to be able to use a UUID for real_root in grub.conf then include "--disklabel". Otherwise you can omit the "--disklabel" (which I normally do).

_________________
Thank you for your attention, interest and support.
------------------------------------------------------------------
http://radio.garden/
Back to top
View user's profile Send private message
2bbionic
Tux's lil' helper
Tux's lil' helper


Joined: 24 Mar 2005
Posts: 134

PostPosted: Wed Nov 25, 2009 9:31 pm    Post subject: Reply with quote

Ja, ich benutze --disklabel, damit das booten per UUID funktioniert.

Grüße,

2bbionic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum