Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] squeezeboxserver has conflicting components?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Seron
Apprentice
Apprentice


Joined: 31 Dec 2002
Posts: 293
Location: Malmö, Sweden

PostPosted: Thu Nov 26, 2009 11:37 pm    Post subject: [solved] squeezeboxserver has conflicting components? Reply with quote

When I try to emerge squeezeboxserver-7.4.1 I get the following blocking:
Code:
[ebuild  N    ]  dev-perl/Class-XSAccessor-1.05
[ebuild  N    ]  dev-perl/File-Slurp-9999.13
[ebuild  N    ]  dev-perl/TimeDate-1.16
[ebuild  N    ]  dev-perl/Exporter-Lite-0.02
[ebuild  N    ]  perl-core/i18n-langtags-0.35
[ebuild  N    ]  dev-perl/Class-Virtual-0.06
[ebuild  N    ]  dev-perl/Scope-Guard-0.03  USE="-test"[ebuild  N    ]  virtual/perl-Module-Pluggable-3.9
[ebuild  N    ]  dev-perl/Class-XSAccessor-Array-1.04
[ebuild  N    ]  dev-perl/Path-Class-0.17  USE="-test"
[ebuild  N    ]  dev-perl/File-ReadBackwards-1.04
[ebuild  N    ]  dev-perl/Tie-IxHash-1.21-r1
[nomerge      ] dev-perl/DateTime-Format-Mail-0.3001
[nomerge      ]  dev-perl/DateTime-0.50  USE="-test"
[ebuild  N    ]   perl-core/Time-Local-1.18
[nomerge      ] dev-perl/Crypt-SSLeay-0.57
[nomerge      ]  dev-perl/libwww-perl-5.831  USE="ssl"
[ebuild  N    ]   dev-perl/HTML-Parser-3.64  USE="-test"
[ebuild  N    ]    dev-perl/HTML-Tagset-3.20
[nomerge      ] media-sound/squeezeboxserver-7.4.1  USE="aac avahi flac lame ogg -alac -bonjour -musepack -wavpack"
[ebuild  N    ]  perl-core/Module-Pluggable-3.9
[ebuild  N    ]  virtual/perl-Time-HiRes-1.97.15
[ebuild  N    ]  dev-perl/Net-IP-1.25-r1
[ebuild  N    ]  dev-perl/Class-C3-0.21  USE="-test"
[ebuild  N    ]   dev-perl/Class-C3-XS-0.13  USE="-test"
[ebuild  N    ]  perl-core/File-Temp-0.20
[ebuild  N    ]  dev-perl/Class-Data-Inheritable-0.08
[ebuild  N    ]  dev-perl/Class-Inspector-1.23  USE="-test"
[ebuild  N    ]  dev-perl/Carp-Assert-0.20
[ebuild  N    ]  dev-perl/common-sense-2.01
[ebuild  N    ]  dev-perl/AutoXS-Header-1.02
[ebuild  N    ]  perl-core/Time-HiRes-1.97.15
[nomerge      ] dev-perl/DateTime-0.50  USE="-test"
[ebuild  N    ]  dev-perl/Params-Validate-0.88
[blocks B     ] dev-perl/Class-XSAccessor-Array ("dev-perl/Class-XSAccessor-Array" is blocking dev-perl/Class-XSAccessor-1.05)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('ebuild', '/', 'dev-perl/Class-XSAccessor-Array-1.04', 'merge') pulled in by
    >=dev-perl/Class-XSAccessor-Array-1.04 required by ('ebuild', '/', 'media-sound/squeezeboxserver-7.4.1', 'merge')

  ('ebuild', '/', 'dev-perl/Class-XSAccessor-1.05', 'merge') pulled in by
    >=dev-perl/Class-XSAccessor-1.03 required by ('ebuild', '/', 'media-sound/squeezeboxserver-7.4.1', 'merge')


Neither of the Class-XSAccessor packages were previously installed. Is squeezeboxserver pulling in conflicting packages?

edit: Changing Class-XSAccessor-1.05 to Class-XSAccessor-1.03 in /etc/portage/package.keywords solved this conflict.
_________________
man cannot be brave without being afraid
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2541
Location: Near Toronto

PostPosted: Tue Dec 29, 2009 6:25 pm    Post subject: Reply with quote

but now Class-XSAccessor exists only as version 1.05 and
when I start squeezebox server I get this warning:

Code:
NOTE: Class::XSAccessor::Array not found, install it for better performance


How much performance am I missing and is there a fix?


TIA
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
msalerno
Veteran
Veteran


Joined: 17 Dec 2002
Posts: 1338
Location: Sweating in South Florida

PostPosted: Tue Dec 29, 2009 8:06 pm    Post subject: Reply with quote

You could always just fire up cpan and install the latest module.
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2541
Location: Near Toronto

PostPosted: Tue Dec 29, 2009 9:32 pm    Post subject: Reply with quote

Quote:
You could always just fire up cpan and install the latest module.


I have no clue about that ... but I think it's already installed:

Code:
 locate XSAcc
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux/auto/Class/XSAccessor
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux/auto/Class/XSAccessor/XSAccessor.so
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux/Class/XSAccessor                   
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux/Class/XSAccessor/Array.pm         
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux/Class/XSAccessor/Heavy.pm         
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux/Class/XSAccessor.pm   


It's just not working with squeezeboxserver for some reason
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum