Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kein Login in xfce4
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Sun Nov 29, 2009 6:37 pm    Post subject: kein Login in xfce4 Reply with quote

Hallo,

wieder stehe ich auf dem Schlauch:

Auf dem alten Laptop läuft XFCE4. Aber nur noch root kann sich einloggen, alle anderen User werden nach dem Login wieder auf den Login-Screen verfrachtet...

Passwortfehler ist es nicht. Und trifft alle "normalen" User. Rechte und Gruppen sind unverändert. Das muss irgendwie mit den letzten "emerge -puD world" zusammenhängen...

Was kann das sein?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
schachti
Advocate
Advocate


Joined: 28 Jul 2003
Posts: 3765
Location: Gifhorn, Germany

PostPosted: Mon Nov 30, 2009 6:18 am    Post subject: Reply with quote

Geht es denn, wenn Du es statt über den Login-Manager direkt mit startx probierst?

Geben die Logdateien (Systemlog, ~/.xsession-errors usw.) was her?
_________________
Never argue with an idiot. He brings you down to his level, then beats you with experience.

How-To: Daten verschlüsselt auf DVD speichern.
Back to top
View user's profile Send private message
Wolle
Apprentice
Apprentice


Joined: 07 May 2003
Posts: 256
Location: Hamburg (Germany)

PostPosted: Mon Nov 30, 2009 6:38 am    Post subject: Re: kein Login in xfce4 Reply with quote

uhai wrote:
Was kann das sein?

Platte voll?
_________________
USE="gentoo" emerge linux
Back to top
View user's profile Send private message
Jean-Paul
Apprentice
Apprentice


Joined: 13 Apr 2009
Posts: 269

PostPosted: Mon Nov 30, 2009 3:24 pm    Post subject: Reply with quote

~/.Xauthority löschen

Jean-Paul
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Sat Dec 05, 2009 12:06 pm    Post subject: Reply with quote

Das sagt slim.log (sieht ja furchtbar aus - wo soll ich denn da anfangen?)
Code:
X.Org X Server 1.5.3
Release Date: 5 November 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.27-gentoo-r8 i686
Current Operating System: Linux Schlepptop 2.6.30-gentoo-r5 #2 SMP Sun Sep 6 22:35:20 CEST 2009 i686
Build Date: 06 September 2009  02:05:29PM
 
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Oct  4 18:09:54 2009
(==) Using config file: "/etc/X11/xorg.conf"
(EE) Failed to load module "freetype" (module does not exist, 0)
FATAL: Module wacom not found.
FATAL: Module evdev not found.
(EE) xf86OpenSerial: Cannot open device /dev/input/tablet-vol2
   No such file or directory.
Error opening /dev/input/tablet-vol2 : No such file or directory
(EE) ioctl EVIOCGBIT failed: Inappropriate ioctl for device
(EE) PreInit returned NULL for "USB Optical Mouse"
(EE) config/hal: NewInputDeviceRequest failed
(EE) ioctl EVIOCGBIT failed: Inappropriate ioctl for device
(EE) PreInit returned NULL for "AlpsPS/2 ALPS GlidePoint"
(EE) config/hal: NewInputDeviceRequest failed
(EE) ioctl EVIOCGBIT failed: Inappropriate ioctl for device
(EE) PreInit returned NULL for "PS/2 Mouse"
(EE) config/hal: NewInputDeviceRequest failed
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error:            No Symbols named "nodeadkey" in the include file "de"
>                   Exiting
>                   Abandoning symbols file "default"
Errors from xkbcomp are not fatal to the X server
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Duplicate shape name ""
>                   Using last definition
> Warning:          Duplicate shape name ""
>                   Using last definition
> Warning:          Duplicate shape name ""
>                   Using last definition
> Warning:          Duplicate shape name ""
>                   Using last definition
> Warning:          Duplicate shape name ""
>                   Using last definition
> Warning:          Duplicate shape name ""
>                   Using last definition
> Warning:          Duplicate shape name ""
>                   Using last definition
> Warning:          Duplicate shape name ""
>                   Using last definition
> Warning:          Duplicate shape name ""
>                   Using last definition
> Warning:          Duplicate shape name ""
>                   Using last definition
> Warning:          Duplicate shape name ""
>                   Using last definition
> Warning:          Duplicate shape name ""
>                   Using last definition
> Warning:          Duplicate shape name ""
>                   Using last definition
> Warning:          Duplicate shape name ""
>                   Using last definition
> Warning:          Multiple doodads named ""
>                   Using first definition
> Warning:          Multiple doodads named ""
>                   Using first definition
> Warning:          Multiple doodads named ""
>                   Using first definition
> Warning:          Multiple doodads named ""
>                   Using first definition
> Warning:          Multiple doodads named ""
>                   Using first definition
> Warning:          Multiple doodads named ""
>                   Using first definition
Errors from xkbcomp are not fatal to the X server
/usr/bin/xauth:  creating new authority file /home/.Xauthority
/usr/bin/startxfce4: X server already running on display :0.0
xrdb:  "Xft.hinting" on line 9 overrides entry on line 6
xrdb:  "Xft.hintstyle" on line 11 overrides entry on line 7
Agent pid 4820

(xfce4-session:4828): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/security/EnableTcp" does not exist on channel "xfce4-session"

(xfce4-session:4828): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/compat/LaunchGNOME" does not exist on channel "xfce4-session"

(xfce4-session:4828): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/compat/LaunchKDE" does not exist on channel "xfce4-session"

(xfce4-session:4828): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/chooser/AlwaysDisplay" does not exist on channel "xfce4-session"

** (xfwm4:4834): CRITICAL **: getBoolValue: assertion `G_VALUE_TYPE(rc[i].value) == G_TYPE_BOOLEAN' failed
xfdesktop[4841]: starting up

(xfce4-settings-helper:4842): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/MouseKeys" does not exist on channel "accessibility"

(xfce4-panel:4840): xfce4-panel-WARNING **: xfce4-panel is not running

(xfce4-settings-helper:4842): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/Default/XkbDisable" does not exist on channel "keyboard-layout"

(xfdesktop:4841): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/xinerama-stretch" does not exist on channel "xfce4-desktop"

(xfdesktop:4841): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-icons/icon-size" does not exist on channel "xfce4-desktop"

(xfdesktop:4841): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-icons/font-size" does not exist on channel "xfce4-desktop"

(xfdesktop:4841): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/monitor0/saturation" does not exist on channel "xfce4-desktop"
sh: fortune: Kommando nicht gefunden.
Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property `GtkOptionMenu::indicator-size' of type `GtkRequisition' from rc file value "0" of type `glong'
Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property `GtkOptionMenu::indicator-spacing' of type `GtkBorder' from rc file value "0" of type `glong'

** (xfdesktop:4841): CRITICAL **: Unusable XfceDesktopIconStyle: 2.  Unable to display desktop icons.

(xfdesktop:4841): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-menu/show-icons" does not exist on channel "xfce4-desktop"

(xfdesktop:4841): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/windowlist-menu/show-icons" does not exist on channel "xfce4-desktop"

(xfdesktop:4841): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/windowlist-menu/show-workspace-names" does not exist on channel "xfce4-desktop"

(xfdesktop:4841): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/windowlist-menu/show-submenus" does not exist on channel "xfce4-desktop"

(xfdesktop:4841): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/windowlist-menu/show-sticky-once" does not exist on channel "xfce4-desktop"

** (xfwm4:4834): WARNING **: Unhandled keyboard shortcut

(xfce4-session:4828): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/general/AutoSave" does not exist on channel "xfce4-session"

(xfce4-session:4828): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/general/PromptOnLogout" does not exist on channel "xfce4-session"

(xfce4-session:4828): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/shutdown/ShowSuspend" does not exist on channel "xfce4-session"

(xfce4-session:4828): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/shutdown/ShowHibernate" does not exist on channel "xfce4-session"

(xfce4-session:4828): Gtk-WARNING **: Failed to set text from markup due to error parsing markup: Fehler in Zeile 1, Zeichen 14: Seltsames Zeichen »·«, es wurde entweder ein Attribut oder aber »>« oder »/« erwartet, um das Start-Tag des Elements »span« abzuschließen; vielleicht haben Sie ein ungültiges Zeichen in einem Attributnamen benutzt

(xfce4-session:4828): Gtk-WARNING **: Failed to set text from markup due to error parsing markup: Fehler in Zeile 1, Zeichen 14: Seltsames Zeichen »·«, es wurde entweder ein Attribut oder aber »>« oder »/« erwartet, um das Start-Tag des Elements »span« abzuschließen; vielleicht haben Sie ein ungültiges Zeichen in einem Attributnamen benutzt

(xfce4-session:4828): Gtk-WARNING **: Failed to set text from markup due to error parsing markup: Fehler in Zeile 1, Zeichen 14: Seltsames Zeichen »·«, es wurde entweder ein Attribut oder aber »>« oder »/« erwartet, um das Start-Tag des Elements »span« abzuschließen; vielleicht haben Sie ein ungültiges Zeichen in einem Attributnamen benutzt
** Message: xfsm-shutdown-helper.c:268: Using HAL to shutdown/reboot the computer.


.Xauthority habe ich gelöscht, hat aber nichts gebracht
Zwischenzeitlich hat der grafische login auch für root nicht mehr funkioniert, das habe ich aber mit pwconv hinbekommen.
pam habe ich neu installiert, hat aber auch nichts gebracht.
Den user habe ich neu angelegt mit dem Bestandshome, ebenfalls erfolglos.

Xorg.log bemängelt evdev, hal und eine ganze Reihe anderer Module... Wieso kann dann aber root sich einloggen? Auch die usb-Maus wird erkannt, so falsch aknn dann die Konfiguration wohl nicht sein.

Vielleicht habe ich nach dem letzten Kernel-update die Mdule nicht gebacken?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Hollowman
Guru
Guru


Joined: 19 Apr 2007
Posts: 584

PostPosted: Sat Dec 05, 2009 1:08 pm    Post subject: Reply with quote

Hi

Code:
(EE) Failed to load module "freetype" (module does not exist, 0)
FATAL: Module wacom not found.
FATAL: Module evdev not found.
(EE) xf86OpenSerial: Cannot open device /dev/input/tablet-vol2
   No such file or directory.
Error opening /dev/input/tablet-vol2 : No such file or directory
(EE) ioctl EVIOCGBIT failed: Inappropriate ioctl for device
(EE) PreInit returned NULL for "USB Optical Mouse"
(EE) config/hal: NewInputDeviceRequest failed
(EE) ioctl EVIOCGBIT failed: Inappropriate ioctl for device
(EE) PreInit returned NULL for "AlpsPS/2 ALPS GlidePoint"
(EE) config/hal: NewInputDeviceRequest failed
(EE) ioctl EVIOCGBIT failed: Inappropriate ioctl for device
(EE) PreInit returned NULL for "PS/2 Mouse"
(EE) config/hal: NewInputDeviceRequest failed


Fang doch erst ma damit an das dein X Server richtig läuft.

Sebastian
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Sat Dec 05, 2009 5:39 pm    Post subject: Reply with quote

Ich glaube nicht, dass das hilft. grundsätzlich läuft die Kiste mit xfce4 und grafischen login. Zumindest für root.

Normale user können sich nicht einloggen und landen wieder im Lgin-Screen.

Trotz der Fehlermeldungen läuft X. Zugegeben, die Konfiguration ist schlampig bis mies. Der Laptop dient momentan auch nur meinem Sohn für "Beneath a steel sky"

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum