Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Zen Kernel Discussion/Support Thread - Part 2
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 5, 6, 7 ... 12, 13, 14  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Waninkoko
Guru
Guru


Joined: 13 May 2005
Posts: 549

PostPosted: Sun Dec 20, 2009 6:26 pm    Post subject: Reply with quote

ponciarello wrote:
zen-sched is obsolete? :o


Yes, it is.
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1159

PostPosted: Sun Dec 20, 2009 7:01 pm    Post subject: Reply with quote

CC arch/x86/kernel/ioport.o
arch/x86/kernel/ioport.c: In function ‘sys_ioperm’:
arch/x86/kernel/ioport.c:126: error: invalid storage class for function ‘do_iopl’
arch/x86/kernel/ioport.c:125: warning: ISO C90 forbids mixed declarations and code
arch/x86/kernel/ioport.c:168: error: expected declaration or statement at end of input
make[2]: *** [arch/x86/kernel/ioport.o] Error 1
make[1]: *** [arch/x86/kernel] Error 2


latest git stable pull.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Mon Dec 21, 2009 2:47 am    Post subject: Reply with quote

tranquilcool wrote:
CC arch/x86/kernel/ioport.o
arch/x86/kernel/ioport.c: In function ‘sys_ioperm’:
arch/x86/kernel/ioport.c:126: error: invalid storage class for function ‘do_iopl’
arch/x86/kernel/ioport.c:125: warning: ISO C90 forbids mixed declarations and code
arch/x86/kernel/ioport.c:168: error: expected declaration or statement at end of input
make[2]: *** [arch/x86/kernel/ioport.o] Error 1
make[1]: *** [arch/x86/kernel] Error 2


latest git stable pull.


fixed, thanks

---

zen-sched is obsolete because bfs 312 patch does the same thing - so i just used that and added the boost, rr, etc. options
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1159

PostPosted: Mon Dec 21, 2009 3:27 am    Post subject: Reply with quote

cheater1034 wrote:
tranquilcool wrote:
CC arch/x86/kernel/ioport.o
arch/x86/kernel/ioport.c: In function ‘sys_ioperm’:
arch/x86/kernel/ioport.c:126: error: invalid storage class for function ‘do_iopl’
arch/x86/kernel/ioport.c:125: warning: ISO C90 forbids mixed declarations and code
arch/x86/kernel/ioport.c:168: error: expected declaration or statement at end of input
make[2]: *** [arch/x86/kernel/ioport.o] Error 1
make[1]: *** [arch/x86/kernel] Error 2


latest git stable pull.


fixed, thanks

sorry but it still hasn't been fixed for me after the latest git pull
---

zen-sched is obsolete because bfs 312 patch does the same thing - so i just used that and added the boost, rr, etc. options

_________________
this is a strange strange world.
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Mon Dec 21, 2009 3:56 am    Post subject: Reply with quote

tranquilcool wrote:
cheater1034 wrote:
tranquilcool wrote:
CC arch/x86/kernel/ioport.o
arch/x86/kernel/ioport.c: In function ‘sys_ioperm’:
arch/x86/kernel/ioport.c:126: error: invalid storage class for function ‘do_iopl’
arch/x86/kernel/ioport.c:125: warning: ISO C90 forbids mixed declarations and code
arch/x86/kernel/ioport.c:168: error: expected declaration or statement at end of input
make[2]: *** [arch/x86/kernel/ioport.o] Error 1
make[1]: *** [arch/x86/kernel] Error 2


latest git stable pull.


fixed, thanks

sorry but it still hasn't been fixed for me after the latest git pull
---

zen-sched is obsolete because bfs 312 patch does the same thing - so i just used that and added the boost, rr, etc. options


apparently by fixed i meant "in progress :P", i must have missed something, it'll be fixed soon

*fixed now*
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1159

PostPosted: Mon Dec 21, 2009 4:15 am    Post subject: Reply with quote

yes fixed thanks cheater1034
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
omnimuc
n00b
n00b


Joined: 09 Nov 2004
Posts: 14
Location: Germany

PostPosted: Mon Dec 21, 2009 5:11 pm    Post subject: X-lock Reply with quote

Hi,
did anyone else get X-locks with 2.6.32*
I got no logs or response while under load with avidemux working on m2t streams
or something else that uses CPU-power.
The System just doesn't rersponse, nothing to do but Alt-Sysrq-B.
No logfiles whatsoever ...
_________________
Fachbegriffe der Informatik:
263: MCSE
Meine Computerkenntisse Sind Erbärmlich
Back to top
View user's profile Send private message
Bluesquare
n00b
n00b


Joined: 26 Oct 2009
Posts: 24

PostPosted: Tue Dec 22, 2009 6:40 am    Post subject: Reply with quote

A git pull broke radeon KMS for me. The one working still hade the swap prefetch, and one of the latest posts in the log is

commit ca59174674b0c156c31d79f2286c99e9b01d3c31
Author: Nigel Cunningham <nigel@tuxonice.net>
Date: Fri Dec 18 09:07:30 2009 +1100

Anyhow, now I've been using the same config, same everything, with the current sources and the system hardlocks during boot.

What info do you need?
Back to top
View user's profile Send private message
Rion
Guru
Guru


Joined: 12 Oct 2006
Posts: 376
Location: Ekaterinburg, Russia

PostPosted: Tue Dec 22, 2009 11:04 am    Post subject: Re: X-lock Reply with quote

omnimuc wrote:
Hi,
did anyone else get X-locks with 2.6.32*
I got no logs or response while under load with avidemux working on m2t streams
or something else that uses CPU-power.
The System just doesn't rersponse, nothing to do but Alt-Sysrq-B.
No logfiles whatsoever ...
same for me on one of my systems. but with emerge

some info:
bfs, bfq, ext4, ~amd64, nvidia-drivers, cpu E8200
_________________
~amd64
rion-overlay
Back to top
View user's profile Send private message
bollucks
l33t
l33t


Joined: 27 Oct 2004
Posts: 606

PostPosted: Tue Dec 22, 2009 1:46 pm    Post subject: Reply with quote

x264 encoding anyone?

http://doom10.org/index.php?topic=78.0
Back to top
View user's profile Send private message
costel78
Guru
Guru


Joined: 20 Apr 2007
Posts: 310

PostPosted: Tue Dec 22, 2009 2:40 pm    Post subject: Reply with quote

Any news about reiser4 ? It is safe to use it with zen-2.6.32 ?
_________________
Sorry for my English. I'm still learning this language.
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Tue Dec 22, 2009 3:49 pm    Post subject: Reply with quote

Bluesquare wrote:
A git pull broke radeon KMS for me. The one working still hade the swap prefetch, and one of the latest posts in the log is

commit ca59174674b0c156c31d79f2286c99e9b01d3c31
Author: Nigel Cunningham <nigel@tuxonice.net>
Date: Fri Dec 18 09:07:30 2009 +1100

Anyhow, now I've been using the same config, same everything, with the current sources and the system hardlocks during boot.

What info do you need?


"ca59174674b0c156c31d79f2286c99e9b01d3c31"
That commit is not in zen-stable "master", that is in "master-drm"

master-drm uses drm-linus, which is 2.6.33 drm - which is broken in more ways than one. Master-drm branch is for convenience, drm problems with it aren't supported anywhere except vanilla upstream (as a 2.6.33 drm problem)

-----

Reiser4 is not good to use on 2.6.32 under all circumstances, i'm not sure what the broken conditions are, but someone should really get in contact with edward (not me, because i'm not using reiser4 and am not totally sure of the problem)

Atleast post it on the mailing list, edward may be subscribed there
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
shaumux
l33t
l33t


Joined: 13 May 2005
Posts: 996
Location: Bangalore, India

PostPosted: Wed Dec 23, 2009 12:22 am    Post subject: Re: X-lock Reply with quote

Rion wrote:
omnimuc wrote:
Hi,
did anyone else get X-locks with 2.6.32*
I got no logs or response while under load with avidemux working on m2t streams
or something else that uses CPU-power.
The System just doesn't rersponse, nothing to do but Alt-Sysrq-B.
No logfiles whatsoever ...
same for me on one of my systems. but with emerge

some info:
bfs, bfq, ext4, ~amd64, nvidia-drivers, cpu E8200
happened to me also 3 or 4 times
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Dec 23, 2009 12:43 am    Post subject: Re: X-lock Reply with quote

shaumux wrote:
Rion wrote:
omnimuc wrote:
Hi,
did anyone else get X-locks with 2.6.32*
I got no logs or response while under load with avidemux working on m2t streams
or something else that uses CPU-power.
The System just doesn't rersponse, nothing to do but Alt-Sysrq-B.
No logfiles whatsoever ...
same for me on one of my systems. but with emerge

some info:
bfs, bfq, ext4, ~amd64, nvidia-drivers, cpu E8200
happened to me also 3 or 4 times


++

but with fglrx / ati-drivers instead of nvidia-drivers and E6600
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Wed Dec 23, 2009 12:45 am    Post subject: Re: X-lock Reply with quote

kernelOfTruth wrote:
shaumux wrote:
Rion wrote:
omnimuc wrote:
Hi,
did anyone else get X-locks with 2.6.32*
I got no logs or response while under load with avidemux working on m2t streams
or something else that uses CPU-power.
The System just doesn't rersponse, nothing to do but Alt-Sysrq-B.
No logfiles whatsoever ...
same for me on one of my systems. but with emerge

some info:
bfs, bfq, ext4, ~amd64, nvidia-drivers, cpu E8200
happened to me also 3 or 4 times


++

but with fglrx / ati-drivers instead of nvidia-drivers and E6600


This is a deboccle (not sure how to spell), anyway - what kernel versions have been tried and what about .configs?
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5724

PostPosted: Wed Dec 23, 2009 12:56 am    Post subject: Reply with quote

r700 KMS also stopped working for me with what I'm currently using (cd6c7bda).

The screen goes dead as soon as it does the fbcon mode switch thing regardless of how I try to load it, prior to this it was working fine but then I've got no idea what version I was using before (it was a -zen1).

(oops, didn't see above post:)
Config I was using which worked previously was all framebuffer stuff built in (including firmware built in to kernel), after that I tried using all modules and external firmware but doing a "modprobe fbcon" kills it (I did it over SSH, it printed "Killed" to the console and the session hanged).
Back to top
View user's profile Send private message
omnimuc
n00b
n00b


Joined: 09 Nov 2004
Posts: 14
Location: Germany

PostPosted: Wed Dec 23, 2009 7:02 am    Post subject: Re: X-lock Reply with quote

Quote:
Quote:
same for me on one of my systems. but with emerge

some info:
bfs, bfq, ext4, ~amd64, nvidia-drivers, cpu E8200
happened to me also 3 or 4 times


Quote:


This is a deboccle (not sure how to spell), anyway - what kernel versions have been tried and what about .configs?


I used to try the provided ebuilds for 2.6.32-zen1 and 2.6.32-zen2.
Hardlocks always. Tried different nvidia-drivers also, 190.42* and 190.53
My root is on reiser4, if that matters, which I don't think.
Here comes the .config and emerge --info

http://pastebin.com/m7880fcf7
http://pastebin.com/m6b3664f2

So I will try latest git later this day ...
_________________
Fachbegriffe der Informatik:
263: MCSE
Meine Computerkenntisse Sind Erbärmlich
Back to top
View user's profile Send private message
Rion
Guru
Guru


Joined: 12 Oct 2006
Posts: 376
Location: Ekaterinburg, Russia

PostPosted: Wed Dec 23, 2009 8:35 am    Post subject: Re: X-lock Reply with quote

cheater1034 wrote:
This is a deboccle (not sure how to spell), anyway - what kernel versions have been tried and what about .configs?
oh i don't remember exactly version i tested. probably that was zen2.
and here is config http://paste.pocoo.org/show/159061/ after last recompilation
_________________
~amd64
rion-overlay
Back to top
View user's profile Send private message
shaumux
l33t
l33t


Joined: 13 May 2005
Posts: 996
Location: Bangalore, India

PostPosted: Wed Dec 23, 2009 10:19 am    Post subject: Re: X-lock Reply with quote

cheater1034 wrote:
This is a deboccle (not sure how to spell), anyway - what kernel versions have been tried and what about .configs?
Here's my config
http://pastebin.com/m1c877ae2
Was on reiser4 with .32-zen1, on ext4 with .32-zen2 with portage on reiser4.
Running nvidia binary drivers 190.42-r3
emerge --info
http://pastebin.com/m5cbc42da
Back to top
View user's profile Send private message
one_and_only
Apprentice
Apprentice


Joined: 13 May 2007
Posts: 250
Location: PL/Krakow

PostPosted: Wed Dec 23, 2009 11:46 am    Post subject: Reply with quote

Same issue on r4, 32-zen1 (more hangs) and 32-zen2 (one hang so far). xorg-server 1.7.3.901-r1, nvidia-drivers-195.22
config: http://pastebin.com/d2419a652
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3843
Location: Dallas area

PostPosted: Wed Dec 23, 2009 11:48 am    Post subject: Reply with quote

I'm running the 2.6.32-zen2 kernel, used to be the 190.42 nvidia drivers,
but now its 190.53 and have seen no problems,
and yes, I do push both cpus heavy at times.

I am using reiser3 though.
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
GD
Tux's lil' helper
Tux's lil' helper


Joined: 11 May 2005
Posts: 134
Location: Greece

PostPosted: Wed Dec 23, 2009 2:24 pm    Post subject: Reply with quote

Hello,

anyone else experiencing problems emerging virtualbox-modules with the latest git version of zen? I get:

Quote:
*** Building 'vboxdrv' module ***
make[1]: Entering directory `/var/tmp/portage/app-emulation/virtualbox-modules-3.1.0/work/vboxdrv'
make KBUILD_VERBOSE= -C /usr/src/linux SUBDIRS=/var/tmp/portage/app-emulation/virtualbox-modules-3.1.0/work/vboxdrv SRCROOT=/var/tmp/portage/app-emulation/virtualbox-modules-3.1.0/work/vboxdrv modules
make[2]: Entering directory `/usr/src/linux-2.6-zen'
CC [M] /var/tmp/portage/app-emulation/virtualbox-modules-3.1.0/work/vboxdrv/linux/SUPDrv-linux.o
CC [M] /var/tmp/portage/app-emulation/virtualbox-modules-3.1.0/work/vboxdrv/SUPDrvAgnostic.o
CC [M] /var/tmp/portage/app-emulation/virtualbox-modules-3.1.0/work/vboxdrv/SUPDrv.o
In file included from /var/tmp/portage/app-emulation/virtualbox-modules-3.1.0/work/vboxdrv/include/VBox/types.h:34In file included from /var/tmp/portage/app-emulation/virtualbox-modules-3.1.0/work/vboxdrv/include/VBox/types.h:34,
from /var/tmp/portage/app-emulation/virtualbox-modules-3.1.0/work/vboxdrv/linux/../SUPDrvInternal.h:39,
from /var/tmp/portage/app-emulation/virtualbox-modules-3.1.0/work/vboxdrv/SUPDrvInternal.h:39,
from /var/tmp/portage/app-emulation/virtualbox-modules-3.1.0/work/vboxdrv/linux/SUPDrv-linux.c:37,
from /var/tmp/portage/app-emulation/virtualbox-modules-3.1.0/work/vboxdrv/SUPDrv.c:35:
/var/tmp/portage/app-emulation/virtualbox-modules-3.1.0/work/vboxdrv/include/iprt/types.h:100:30::
/var/tmp/portage/app-emulation/virtualbox-modules-3.1.0/work/vboxdrv/include/iprt/types.h:100:30:error: error: linux/autoconf.h: No such file or directory
linux/autoconf.h: No such file or directory
In file included from /var/tmp/portage/app-emulation/virtualbox-modules-3.1.0/work/vboxdrv/include/VBox/types.h:34,
from /var/tmp/portage/app-emulation/virtualbox-modules-3.1.0/work/vboxdrv/SUPDrvInternal.h:39,
from /var/tmp/portage/app-emulation/virtualbox-modules-3.1.0/work/vboxdrv/SUPDrvAgnostic.c:36:
/var/tmp/portage/app-emulation/virtualbox-modules-3.1.0/work/vboxdrv/include/iprt/types.h:100:30: error: linux/autoconf.h: No such file or directory
make[3]: *** [/var/tmp/portage/app-emulation/virtualbox-modules-3.1.0/work/vboxdrv/SUPDrvAgnostic.o] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: *** [/var/tmp/portage/app-emulation/virtualbox-modules-3.1.0/work/vboxdrv/SUPDrv.o] Error 1
make[3]: *** [/var/tmp/portage/app-emulation/virtualbox-modules-3.1.0/work/vboxdrv/linux/SUPDrv-linux.o] Error 1
make[2]: *** [_module_/var/tmp/portage/app-emulation/virtualbox-modules-3.1.0/work/vboxdrv] Error 2
make[2]: Leaving directory `/usr/src/linux-2.6-zen'
make[1]: *** [vboxdrv] Error 2
make[1]: Leaving directory `/var/tmp/portage/app-emulation/virtualbox-modules-3.1.0/work/vboxdrv'
make: *** [all] Error 2
* ERROR: app-emulation/virtualbox-modules-3.1.0 failed:
* Unable to emake HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- LDFLAGS= KERN_DIR=/usr/src/linux KERNOUT=/lib/modules/2.6.33-rc1-zen1/build all
*
* Call stack:
* ebuild.sh, line 61: Called src_compile
* environment, line 3564: Called linux-mod_src_compile
* environment, line 2748: Called die
* The specific snippet of code:
* eval "emake HOSTCC=\"$(tc-getBUILD_CC)\" CROSS_COMPILE=${CHOST}- LDFLAGS=\"$(get_abi_LDFLAGS)\" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CROSS_COMPILE=${CHOST}- LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
*
* If you need support, post the output of 'emerge --info =app-emulation/virtualbox-modules-3.1.0',
* the complete build log and the output of 'emerge -pqv =app-emulation/virtualbox-modules-3.1.0'.
* The complete build log is located at '/var/tmp/portage/app-emulation/virtualbox-modules-3.1.0/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/app-emulation/virtualbox-modules-3.1.0/temp/environment'.
* S: '/var/tmp/portage/app-emulation/virtualbox-modules-3.1.0/work'
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Wed Dec 23, 2009 3:13 pm    Post subject: Reply with quote

The problems are with reiser4 (can't fix, some upstream problem)

If not using reiser4, but using zen2 there is also a problem with swap prefetch, which has been disabled in zen3 (i'll release that soon)
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
ponciarello
Apprentice
Apprentice


Joined: 22 Jul 2008
Posts: 223
Location: beach of slack

PostPosted: Wed Dec 23, 2009 5:24 pm    Post subject: Reply with quote

fyi, someone posted on slax forums an howto for using zen-kernels in slax. :)
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Wed Dec 23, 2009 9:32 pm    Post subject: Reply with quote

ponciarello wrote:
fyi, someone posted on slax forums an howto for using zen-kernels in slax. :)


GOod news ;)
I posted there as well, some clarifications anyway
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 5, 6, 7 ... 12, 13, 14  Next
Page 6 of 14

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum