Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Zen Kernel Discussion/Support Thread - Part 2
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 7, 8, 9 ... 12, 13, 14  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Fri Jan 01, 2010 10:58 am    Post subject: Reply with quote

HAPPY NEW YEAR DUDES!
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
forkboy
Apprentice
Apprentice


Joined: 24 Nov 2004
Posts: 200
Location: Blackpool, UK

PostPosted: Fri Jan 01, 2010 10:20 pm    Post subject: Reply with quote

On a new install, installing zen-sources-2.6.32_p4 gave errors
Code:
ERROR: unpack
Could not extract patch!
untill I installed lzma-utils, so I guess zen-sources should depend on lzma-utils?
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Sat Jan 02, 2010 5:17 am    Post subject: Reply with quote

forkboy wrote:
On a new install, installing zen-sources-2.6.32_p4 gave errors
Code:
ERROR: unpack
Could not extract patch!
untill I installed lzma-utils, so I guess zen-sources should depend on lzma-utils?


Yeah it should probably add a depend on lzma-utils or xz-utils, because the patch is compressed with lzma after all ;)
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
forkboy
Apprentice
Apprentice


Joined: 24 Nov 2004
Posts: 200
Location: Blackpool, UK

PostPosted: Sun Jan 03, 2010 11:37 pm    Post subject: Reply with quote

Filed a bug and is fixed now FYI
Back to top
View user's profile Send private message
SpectreDragon
Tux's lil' helper
Tux's lil' helper


Joined: 22 Aug 2008
Posts: 92
Location: Germany

PostPosted: Mon Jan 04, 2010 7:20 pm    Post subject: Reply with quote

As soon as I try to download this file onto my btrfs partition (compression enabled) I get the following kernel message and all my programs stop responding. Seem to happen at the same download position every time I tried... :?
Code:
[ 5181.070287] ------------[ cut here ]------------
[ 5181.070310] kernel BUG at fs/btrfs/ordered-data.c:672!
[ 5181.070325] invalid opcode: 0000 [#1] PREEMPT SMP
[ 5181.070342] last sysfs file: /sys/devices/pci0000:00/0000:00:1e.0/0000:03:00.0/ssb0:0/net/eth0/carrier
[ 5181.070359] CPU 0
[ 5181.070369] Modules linked in: vboxnetadp vboxnetflt vboxdrv nvidia(P)
[ 5181.070396] Pid: 6735, comm: chrome Tainted: P           2.6.32-zen5-sp1 #1 Inspiron 1520
[ 5181.070414] RIP: 0010:[<ffffffff81208e40>]  [<ffffffff81208e40>] btrfs_ordered_update_i_size+0x1e4/0x1eb
[ 5181.070444] RSP: 0018:ffff88006735fdd8  EFLAGS: 00010216
[ 5181.070457] RAX: 0000000001473000 RBX: 0000000000000000 RCX: ffff880097033400
[ 5181.070473] RDX: ffff88010cdd9f68 RSI: 0000000001472b1e RDI: ffff88005acc20b0
[ 5181.070489] RBP: 0000000001472b1e R08: 0000000000000000 R09: 0000000000d1e67e
[ 5181.070504] R10: 0000000000000000 R11: 0000000000000000 R12: 0000000001472b1e
[ 5181.070520] R13: ffff88005acc21a0 R14: 0000000000d1e67e R15: ffff88005acc2000
[ 5181.070537] FS:  00007f5d0cfd2710(0000) GS:ffff880028200000(0000) knlGS:0000000000000000
[ 5181.070554] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[ 5181.070568] CR2: 00000000020f5c20 CR3: 0000000068b6e000 CR4: 00000000000006f0
[ 5181.070583] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[ 5181.070599] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
[ 5181.070615] Process chrome (pid: 6735, threadinfo ffff88006735e000, task ffff88011de01680)
[ 5181.070631] Stack:
[ 5181.070640]  ffff88005acd2000 ffff88005acc20b0 ffff88011eb57800 ffff88005acc2030
[ 5181.070656] <0> ffff88011eb57800 ffff88005acc21a0 ffff88006735fef8 ffff88011eb57800
[ 5181.070677] <0> ffff88005acd2000 0000000000000000 0000000000000000 ffffffff811fb3fd
[ 5181.070702] Call Trace:
[ 5181.070719]  [<ffffffff811fb3fd>] ? btrfs_setattr+0x14c/0x21d
[ 5181.070738]  [<ffffffff81507009>] ? __down_write_nested+0x34/0xa5
[ 5181.070757]  [<ffffffff810c7f19>] ? notify_change+0x18d/0x2dd
[ 5181.070775]  [<ffffffff810b4fce>] ? do_truncate+0x68/0x86
[ 5181.070791]  [<ffffffff810b54a9>] ? sys_ftruncate+0xa9/0xab
[ 5181.070809]  [<ffffffff8100ba2b>] ? system_call_fastpath+0x16/0x1b
[ 5181.070823] Code: 48 85 db 74 15 48 8d 7b 50 31 c9 ba 01 00 00 00 be 03 00 00 00 e8 2c 6c e2 ff 48 83 c4 28 89 e8 5b 5d 41 5c 41 5d 41 5e 41 5f c3 <0f> 0b e9 f6 fe ff ff 41 54 49 89 fc 55 48 8d af 10 ff ff ff 53
[ 5181.070941] RIP  [<ffffffff81208e40>] btrfs_ordered_update_i_size+0x1e4/0x1eb
[ 5181.070961]  RSP <ffff88006735fdd8>
[ 5181.070974] ---[ end trace 21c3c92771224afd ]---


(as you can see I use 2.6.32-zen5 and chromium)
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Mon Jan 04, 2010 7:35 pm    Post subject: Reply with quote

not i btrfs problem. it doesn't happen here.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
SpectreDragon
Tux's lil' helper
Tux's lil' helper


Joined: 22 Aug 2008
Posts: 92
Location: Germany

PostPosted: Mon Jan 04, 2010 7:40 pm    Post subject: Reply with quote

tranquilcool wrote:
not i btrfs problem. it doesn't happen here.

ok, strange. smart attributes look ok, so i don't think that it is a hardware issue. but i am a bit clueless what i could try in order to find out more about the cause of this.
i may fiddle around with the compile options as i use custom cflags ("-os -march=native -fomit-frame-pointer -mno-align-stringops -minline-stringops-dynamically -mno-push-args"), will try without them.

btw. i'm using 64-bit, if this makes any difference
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Mon Jan 04, 2010 8:29 pm    Post subject: Reply with quote

SpectreDragon wrote:
tranquilcool wrote:
not i btrfs problem. it doesn't happen here.

ok, strange. smart attributes look ok, so i don't think that it is a hardware issue. but i am a bit clueless what i could try in order to find out more about the cause of this.
i may fiddle around with the compile options as i use custom cflags ("-os -march=native -fomit-frame-pointer -mno-align-stringops -minline-stringops-dynamically -mno-push-args"), will try without them.

btw. i'm using 64-bit, if this makes any difference


do that

I'm using 64 bits too and it has just been successfully downloaded here (also with compression)


what are your mount-options and specifics to this volume ? (e.g. subvolumes, snapshots, etc.)

mine are: rw,noatime,nodiratime,compress

and no additional subvolumes or snapshots (only the default created subvolume)

more info:
http://btrfs.wiki.kernel.org/index.php/FAQ#Can_the_data.3Dordered_mode_be_turned_off_in_Btrfs.3F
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
SpectreDragon
Tux's lil' helper
Tux's lil' helper


Joined: 22 Aug 2008
Posts: 92
Location: Germany

PostPosted: Tue Jan 05, 2010 2:22 am    Post subject: Reply with quote

recompiling the kernel without custom cflags did not change anything.

mount options: rw,noatime,compress
i don't use any special / additional subvolumes or snapshots.

as i saw now the download position is not always the same when this happens and unfortunately in the meantime it appeared in a different situation (still while using chromium but without any download, i guess downloading something in chromium just triggers this situation with a very good chance).

reverted every change i did to my system the last days (well except for changing the filesystem to btrfs, started to use it 2 days ago, but the problem did not appear until i mentioned it here).
i am currently out of ideas (except to see if my other filesystem of the same type is also affected and if not to recreate the affected one) but thanks for the help so far.

//edit
may be a known problem: http://patchwork.kernel.org/patch/69924/
call trace doesn't look completely the same but quite similar

//edit^2
applied the patch from the link above and was not able to reproduce the problem in several tries. seems to be solved. i would suggest to include this patch in zen-kernel when it really fixes the problem as it looks relative simple and i guess it is not likely to break things.
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Wed Jan 06, 2010 4:26 am    Post subject: Reply with quote

That patch is now applied in zen-stable, 2.6.31 and 2.6.32 ;)
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
SpectreDragon
Tux's lil' helper
Tux's lil' helper


Joined: 22 Aug 2008
Posts: 92
Location: Germany

PostPosted: Wed Jan 06, 2010 11:11 pm    Post subject: Reply with quote

cheater1034 wrote:
That patch is now applied in zen-stable, 2.6.31 and 2.6.32 ;)

thanks :)
(problem did not appear again)
Back to top
View user's profile Send private message
Non_E
Apprentice
Apprentice


Joined: 17 Jan 2006
Posts: 160
Location: Czech Republic

PostPosted: Sat Jan 09, 2010 12:17 am    Post subject: Possible bug Reply with quote

I have encountered possible brtfs bug when I started firefox (right after the boot). The kernel is current as of 2010-01-08 (last commit is 806d50b0e902dbf9c5dce78b6aa9472e8710f056).
Code:
------------[ cut here ]------------
kernel BUG at fs/btrfs/inode.c:5595!
invalid opcode: 0000 [#1] PREEMPT SMP
last sysfs file: /sys/devices/pci0000:00/0000:00:1b.0/sound/card0/controlC0/uevent
CPU 2
Modules linked in: coretemp sco rfcomm snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss xfs exportfs aes_x86_64 aes_generic xts gf128mul dm_crypt hidp bnep l2cap vboxnetflt vboxdrv i2c_dev bridge stp llc nvidia(P) snd_hda_codec_realtek btusb snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_timer snd bluetooth snd_page_alloc asus_atk0110 hwmon atl1e i2c_i801 i2c_core
Pid: 3861, comm: firefox Tainted: P           2.6.32-zen5 #1 P5Q
RIP: 0010:[<ffffffff811ee438>]  [<ffffffff811ee438>] btrfs_rename+0x4c8/0x590
RSP: 0018:ffff880110261c88  EFLAGS: 00010282
RAX: 00000000ffffffef RBX: 0000000004d5e784 RCX: 0000000000000002
RDX: 0000000000000400 RSI: ffff88012f0be200 RDI: ffff88012f0ae600
RBP: ffff880110261d48 R08: 0000000000000000 R09: 0000000000000000
R10: ffff88012bd64800 R11: 0000000000000000 R12: 000000004b47c5ee
R13: ffff8800cf4f5220 R14: 0000000000000000 R15: ffff8800cf5b46c0
FS:  00007f345a2f1710(0000) GS:ffff880028300000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 00007f344e9ff000 CR3: 0000000101d49000 CR4: 00000000000006e0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Process firefox (pid: 3861, threadinfo ffff880110260000, task ffff880101d84b00)
Stack:
 00000000000028d0 ffff880110261e08 ffff880101d84b00 0000000000000000
<0> 01ff8800cf4f5220 ffff8800cf724000 ffff8800cf5b6590 ffff88012bd64800
<0> ffff88012bd64800 ffff8800cf71d9c0 ffff8800cf700b40 ffff8800cf4f5220
Call Trace:
 [<ffffffff810cb420>] vfs_rename+0x350/0x3b0
 [<ffffffff810cd42e>] sys_renameat+0x23e/0x270
 [<ffffffff81465632>] ? _spin_unlock_irqrestore+0x12/0x40
 [<ffffffff8108947a>] ? rcu_start_gp+0x4a/0x180
 [<ffffffff814651a6>] ? _spin_lock+0x16/0x40
 [<ffffffff81253505>] ? _atomic_dec_and_lock+0x55/0x80
 [<ffffffff810c2172>] ? __fput+0x162/0x1e0
 [<ffffffff810c220d>] ? fput+0x1d/0x30
 [<ffffffff810beab8>] ? filp_close+0x58/0x90
 [<ffffffff810cd476>] sys_rename+0x16/0x20
 [<ffffffff8100b3eb>] system_call_fastpath+0x16/0x1b
Code: 00 00 48 81 c7 a8 1a 00 00 e8 f5 41 e6 ff e9 56 fd ff ff 49 8b 77 10 48 8b bd 68 ff ff ff e8 80 fa ff ff 85 c0 0f 84 03 ff ff ff <0f> 0b eb fe 48 8b 75 80 48 8b bd 68 ff ff ff e8 64 16 01 00 e9
RIP  [<ffffffff811ee438>] btrfs_rename+0x4c8/0x590
 RSP <ffff880110261c88>
---[ end trace 53d69859d7bd41c4 ]---

_________________
Only Sith deals in absolutes.
Back to top
View user's profile Send private message
seqizz
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jan 2008
Posts: 103

PostPosted: Sat Jan 09, 2010 11:56 am    Post subject: Reply with quote

Did anyone see a kernel panic because of heavy I/O on ext4?
I can't compile even GCC! :? I'll start to play with my fstab (like this for now):
Code:

/dev/sda1      /      ext4      noatime      0 1
/dev/sda2      /usr/portage   reiser4      noatime,nodiratime,tree.cbk_cache.nr_slots=48   0 0

I can't try gentoo-sources to verify this is something about zen, because of reiser4 partition. Or can i?
_________________
what about an answer here?
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat Jan 09, 2010 12:20 pm    Post subject: Reply with quote

seqizz wrote:
Did anyone see a kernel panic because of heavy I/O on ext4?
I can't compile even GCC! :? I'll start to play with my fstab (like this for now):
Code:

/dev/sda1      /      ext4      noatime      0 1
/dev/sda2      /usr/portage   reiser4      noatime,nodiratime,tree.cbk_cache.nr_slots=48   0 0

I can't try gentoo-sources to verify this is something about zen, because of reiser4 partition. Or can i?


nope - everything works fine so far


just create a tarball of your portage-partition, format it to ext4 and you'll see if you get a kernel-panic when you extract the tarball back to the partition (now in ext4) and doing rsync
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
aTan
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jan 2007
Posts: 134
Location: Czech Republic (Ukraine)

PostPosted: Sat Jan 09, 2010 1:16 pm    Post subject: Reply with quote

seqizz wrote:
Did anyone see a kernel panic because of heavy I/O on ext4?
I can't compile even GCC! :?


Same problem with current git-stable (started maybe with 32-zen2). System hangs when compiling something big like boost or wesnoth. I haven't tried gcc.

also git-stable fails on make modules with lzma support in squashfs enabled.
Back to top
View user's profile Send private message
seqizz
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jan 2008
Posts: 103

PostPosted: Sat Jan 09, 2010 3:44 pm    Post subject: Reply with quote

I *guess* its not something related filesystems or kernel anymore.. Probably my damn new external hdd causes the panic if i directly download to it.. But i'm still taking an error after every emerge:

portage: COUNTER for dev-python/twisted-web-9.0.0 was corrupted; resetting to value of 0
portage: COUNTER for dev-python/twisted-web-9.0.0 was corrupted; resetting to value of 0
_________________
what about an answer here?
Back to top
View user's profile Send private message
aTan
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jan 2007
Posts: 134
Location: Czech Republic (Ukraine)

PostPosted: Sat Jan 09, 2010 4:31 pm    Post subject: Reply with quote

seqizz wrote:
I *guess* its not something related filesystems or kernel anymore.. Probably my damn new external hdd causes the panic if i directly download to it.. But i'm still taking an error after every emerge:

portage: COUNTER for dev-python/twisted-web-9.0.0 was corrupted; resetting to value of 0
portage: COUNTER for dev-python/twisted-web-9.0.0 was corrupted; resetting to value of 0


I don't have any external hdd and system hangs with 2.6.32 zen sources. I have to use now 2.6.31 last zen sources. I also had similar error

>>> Auto-cleaning packages...
portage: COUNTER for app-portage/gentoolkit-0.3.0_rc8 was corrupted; resetting to value of 0
portage: COUNTER for app-portage/gentoolkit-0.3.0_rc8 was corrupted; resetting to value of 0

reemerging gentoolkit fixed it.
Back to top
View user's profile Send private message
seqizz
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jan 2008
Posts: 103

PostPosted: Sat Jan 09, 2010 5:45 pm    Post subject: Reply with quote

aTan wrote:

I don't have any external hdd and system hangs with 2.6.32 zen sources. I have to use now 2.6.31 last zen sources. I also had similar error

>>> Auto-cleaning packages...
portage: COUNTER for app-portage/gentoolkit-0.3.0_rc8 was corrupted; resetting to value of 0
portage: COUNTER for app-portage/gentoolkit-0.3.0_rc8 was corrupted; resetting to value of 0

reemerging gentoolkit fixed it.


Thanks for advice, now fixed for this error. And you were right. System hangs with heavy I/O anyways. Ext4 with latest 9999 (stable branch). I couldn't emerge 2 packages in same time after unplugging external. Changed CFS to BFS (even more risky but), 10000Hz to 1000Hz.. Still hangs. Maybe something about nvidia-drivers or SLQB.. :?
_________________
what about an answer here?
Back to top
View user's profile Send private message
Rion
Guru
Guru


Joined: 12 Oct 2006
Posts: 377
Location: Ekaterinburg, Russia

PostPosted: Sat Jan 09, 2010 8:07 pm    Post subject: Reply with quote

ebrsc wrote:
for the screen flickering, you can try:
Code:
git revert 181a5336d6cc83

and rebuild your kernel.
that works, thx =)

is anyone know maybe there are already updated and fixed intel video stuff in some repo which may be merged into zen ?
_________________
~amd64
rion-overlay
Back to top
View user's profile Send private message
SpectreDragon
Tux's lil' helper
Tux's lil' helper


Joined: 22 Aug 2008
Posts: 92
Location: Germany

PostPosted: Sat Jan 09, 2010 9:00 pm    Post subject: Re: Possible bug Reply with quote

Non_E wrote:
I have encountered possible brtfs bug when I started firefox (right after the boot). The kernel is current as of 2010-01-08 (last commit is 806d50b0e902dbf9c5dce78b6aa9472e8710f056).
...

similar problem here. After updating btrfs crashes as soon as I log in (starting gdm works but after that it crashes). Don't know if it is somehow related to xorg, as I was able to compile things without problems as long as I do not start xorg..

crash occurs somewhere in inode.c as well but at a different position (and may be something completely different). unfortunately I am currently not able to post the log here.

// edit
Code:
[  124.856220] ------------[ cut here ]------------
[  124.857005] kernel BUG at fs/btrfs/inode.c:3318!
[  124.857005] invalid opcode: 0000 [#1] PREEMPT SMP
[  124.857005] last sysfs file: /sys/devices/virtual/block/dm-3/uevent
[  124.857005] CPU 0
[  124.857005] Modules linked in: vboxnetadp vboxnetflt vboxdrv nvidia(P)
[  124.857005] Pid: 2607, comm: gconfd-2 Tainted: P           2.6.32-zen5-sp1 #2 Inspiron 1520                   
[  124.857005] RIP: 0010:[<ffffffff811fb53d>]  [<ffffffff811fb53d>] btrfs_setattr+0xe0/0x21d
[  124.857005] RSP: 0018:ffff88011118bca8  EFLAGS: 00010282
[  124.857005] RAX: 00000000ffffffef RBX: ffff88003794dd70 RCX: 0000000000000000
[  124.857005] RDX: 0000000000000400 RSI: ffff88011e5db600 RDI: ffff88011e5bdd80
[  124.916260] RBP: ffff88011118bd68 R08: 0000000000000001 R09: ffff88011118bd68
[  124.916260] R10: ffff88011118bc78 R11: 0000000000000019 R12: ffff88011e72c800
[  124.916260] R13: ffff8800378af000 R14: 0000000000000000 R15: ffff880116593cc0
[  124.916260] FS:  00007f92f265e700(0000) GS:ffff880028200000(0000) knlGS:0000000000000000
[  124.916260] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[  124.916260] CR2: 0000000002152000 CR3: 00000001110ca000 CR4: 00000000000006f0
[  124.916260] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[  124.916260] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
[  124.916260] Process gconfd-2 (pid: 2607, threadinfo ffff88011118a000, task ffff88011d5cf180)
[  124.916260] Stack:
[  124.916260]  0000000000000000 ffffffff81506971 0000000000000000 ffff88011118bd68
[  124.916260] <0> ffff8800378ae480 ffff88003794dd70 0000000000008068 0000000000000008
[  124.916260] <0> ffff880116593cc0 ffffffff810c803d 0000000000000000 ffff88003794dd70
[  124.916260] Call Trace:
[  124.916260]  [<ffffffff81506971>] ? __down_write_nested+0x34/0xa5
[  124.916260]  [<ffffffff810c803d>] ? notify_change+0x18d/0x2dd
[  124.916260]  [<ffffffff810b50a2>] ? do_truncate+0x68/0x86
[  124.916260]  [<ffffffff810bf4a3>] ? may_open+0x199/0x19b
[  124.916260]  [<ffffffff810bfb1c>] ? do_filp_open+0x4a7/0x91d
[  124.916260]  [<ffffffff81506e0c>] ? _spin_unlock+0x1e/0x2c
[  124.916260]  [<ffffffff810c8a51>] ? alloc_fd+0x110/0x122
[  124.916260]  [<ffffffff810b4445>] ? do_sys_open+0x56/0xf9
[  124.916260]  [<ffffffff8100ba2b>] ? system_call_fastpath+0x16/0x1b
[  124.916260] Code: 4e 01 00 00 be 01 00 00 00 4c 89 e7 e8 c3 92 ff ff 48 89 de 49 89 c5 48 8b 43 e0 4c 89 ef 49 89 45 20 e8 73 f3 ff ff 85 c0 74 04 <0f> 0b eb fe 4d 8b 7d 10 4c 89 e6 4c 89 ef e8 31 85 ff ff be 01
[  124.916260] RIP  [<ffffffff811fb53d>] btrfs_setattr+0xe0/0x21d
[  124.916260]  RSP <ffff88011118bca8>
[  124.925024] ---[ end trace 7a2e8af192c176c7 ]---


// edit^2
downgraded zen and it's still there :?
currently out of ideas what the reason for this crash could be

// edit^3
hm and it is always gconfd-2 which is causing this
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5876

PostPosted: Sun Jan 10, 2010 12:40 am    Post subject: Reply with quote

Well this is annoying... I got a new laptop, but it has a RT2860 wifi chip. The rt2860 driver in current git was "working" for a week (only barely) but for the past few days it's been refusing to connect at all saying the password is invalid (it isn't).

I guess I'm screwed here until the replacement driver in 2.6.33 gets done?

This laptop has built-in bluetooth which in theory could be used for networking, but TBH I've had better experience trying to get winmodems to work under 2.4.x than I've ever managed with bt... :x
Back to top
View user's profile Send private message
pietrek
n00b
n00b


Joined: 09 Oct 2007
Posts: 14

PostPosted: Sun Jan 10, 2010 1:21 pm    Post subject: Reply with quote

Hello!

Could you please consider adding this patch http://lwn.net/Articles/274113/ patch to zen-sources?
Back to top
View user's profile Send private message
Rion
Guru
Guru


Joined: 12 Oct 2006
Posts: 377
Location: Ekaterinburg, Russia

PostPosted: Sun Jan 10, 2010 8:14 pm    Post subject: Reply with quote

just got one yet hard(?) lock with zen-stable (2.6.32-zen5), but on different hardware. in this case no nvidia cards.
other conditions are mostly the same.
rebooted with alt+sysreq+b
_________________
~amd64
rion-overlay
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Tue Jan 12, 2010 7:02 am    Post subject: Reply with quote

CC lib/decompress_unlzo.o
lib/decompress_unlzo.c:53: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'parse_header'
lib/decompress_unlzo.c:90: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'unlzo'
make[1]: *** [lib/decompress_unlzo.o] Error 1
make: *** [lib] Error 2


errors latest git pull zen-unstable.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
SpectreDragon
Tux's lil' helper
Tux's lil' helper


Joined: 22 Aug 2008
Posts: 92
Location: Germany

PostPosted: Tue Jan 12, 2010 9:08 am    Post subject: Reply with quote

regarding my btrfs crash issue:
procedure as usual: backup, format, restore and apparently the problem is gone.

seems that I somehow managed to break my filesystem.. :?
I hope that this does not happen on a regular basis

//
interesting is that every recent change, even those I did directly after booting and before the crash occurs, is lost.
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 7, 8, 9 ... 12, 13, 14  Next
Page 8 of 14

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum