Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Zen Kernel Discussion/Support Thread - Part 2
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 8, 9, 10 ... 12, 13, 14  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
dodo1122
Guru
Guru


Joined: 02 Sep 2006
Posts: 347
Location: York, England

PostPosted: Tue Jan 12, 2010 11:02 am    Post subject: Reply with quote

tranquilcool wrote:
CC lib/decompress_unlzo.o
lib/decompress_unlzo.c:53: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'parse_header'
lib/decompress_unlzo.c:90: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'unlzo'
make[1]: *** [lib/decompress_unlzo.o] Error 1
make: *** [lib] Error 2


errors latest git pull zen-unstable.


I'll look into it when i get home.
_________________
#zen-sources on irc.rizon.net
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Tue Jan 12, 2010 8:39 pm    Post subject: Reply with quote

SpectreDragon wrote:
regarding my btrfs crash issue:
procedure as usual: backup, format, restore and apparently the problem is gone.

seems that I somehow managed to break my filesystem.. :?
I hope that this does not happen on a regular basis

//
interesting is that every recent change, even those I did directly after booting and before the crash occurs, is lost.


That's a risk of running an experimental filesystem i guess :wink: (although i'm running btrfs myself)

------

It seems like there are a lot of bugs in 2.6.32 yet, so please test there and see if you have the problems as well - especially stuff like btrfs, that's all upstream from btrfs-unstable.git tree (which is aka 2.6.33 btrfs) - and a lot of the stuff we don't even touch is most likely upstream as well (so you'd try 2.6.32.3, etc)
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
seqizz
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jan 2008
Posts: 103

PostPosted: Wed Jan 13, 2010 5:29 pm    Post subject: :\ Reply with quote

Here is sweet reiser4 (or ext4) kernel panic. Happens while heavy I/O (or shutdown sometimes).
I've tried to play with bfs/cfs, slub/slqb.. Mounted with "defaults" parameter, it was "noatime". Latest stable-9999 zen. Still i see panics..

>>Image<<

It's reiser4 right? I just want to make sure before destroying one of my filesystems. :)
_________________
what about an answer here?
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Jan 13, 2010 5:39 pm    Post subject: Re: :\ Reply with quote

seqizz wrote:
Here is sweet reiser4 (or ext4) kernel panic. Happens while heavy I/O (or shutdown sometimes).
I've tried to play with bfs/cfs, slub/slqb.. Mounted with "defaults" parameter, it was "noatime". Latest stable-9999 zen. Still i see panics..

>>Image<<

It's reiser4 right? I just want to make sure before destroying one of my filesystems. :)


jbd2_journal_start ?

ext4_da_writepages ?

looks more like ext4 to me
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Wed Jan 13, 2010 6:11 pm    Post subject: Re: :\ Reply with quote

seqizz wrote:
Here is sweet reiser4 (or ext4) kernel panic. Happens while heavy I/O (or shutdown sometimes).
I've tried to play with bfs/cfs, slub/slqb.. Mounted with "defaults" parameter, it was "noatime". Latest stable-9999 zen. Still i see panics..

>>Image<<

It's reiser4 right? I just want to make sure before destroying one of my filesystems. :)


Reiser4 on 2.6.32+ should carry the BROKEN dependency
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
seqizz
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jan 2008
Posts: 103

PostPosted: Wed Jan 13, 2010 7:13 pm    Post subject: Reply with quote

I've tried to remove fstab entry about reiser4 partition (/usr/portage) and opened dozen of apps & copied files & tried to build gcc same time, to create something heavy.. Ext4 worked like a charm, without 1 sec stuck.. So now i'll format my portage partition as ext4 too.. I hope this is true, otherwise i'll have to move entire system and apologize from reiser4..

thanks
_________________
what about an answer here?
Back to top
View user's profile Send private message
aTan
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jan 2007
Posts: 134
Location: Czech Republic (Ukraine)

PostPosted: Wed Jan 13, 2010 7:22 pm    Post subject: Reply with quote

I don't use Reiser4 and it hangs with high I/O. :(
Back to top
View user's profile Send private message
seqizz
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jan 2008
Posts: 103

PostPosted: Wed Jan 13, 2010 7:35 pm    Post subject: Reply with quote

aTan wrote:
I don't use Reiser4 and it hangs with high I/O. :(

i just hope it's not the same problem, otherwise i'm **** up.. :mrgreen:
_________________
what about an answer here?
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Wed Jan 13, 2010 8:35 pm    Post subject: Reply with quote

If you get some kind of trace I suggest you make sure it's useful and report it :wink:
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
aTan
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jan 2007
Posts: 134
Location: Czech Republic (Ukraine)

PostPosted: Wed Jan 13, 2010 8:52 pm    Post subject: Reply with quote

I don't. It just totally hangs. The only thing I can do is a cold reboot. Logs are silent.
Back to top
View user's profile Send private message
Dont Panic
Guru
Guru


Joined: 20 Jun 2007
Posts: 322
Location: SouthEast U.S.A.

PostPosted: Wed Jan 13, 2010 9:42 pm    Post subject: Reply with quote

If you need Reiser4 support, you should probably drop back to a 2.6.31 kernel until the issues with Reiser4 in the .32 kernel are resolved.
Back to top
View user's profile Send private message
aTan
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jan 2007
Posts: 134
Location: Czech Republic (Ukraine)

PostPosted: Wed Jan 13, 2010 10:04 pm    Post subject: Reply with quote

ohh, shame on me. I'm using reiser4 on ccache loop device.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Jan 13, 2010 11:40 pm    Post subject: Reply with quote

aTan wrote:
ohh, shame on me. I'm using reiser4 on ccache loop device.


note that reiser4 is incompatible with loop device or at least has problems with it :idea:
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
dusanc
Apprentice
Apprentice


Joined: 19 Sep 2005
Posts: 248
Location: Serbia

PostPosted: Thu Jan 14, 2010 11:31 am    Post subject: Reply with quote

kernelOfTruth wrote:
aTan wrote:
ohh, shame on me. I'm using reiser4 on ccache loop device.


note that reiser4 is incompatible with loop device or at least has problems with it :idea:


AFAIK that should say:
"note that reiser4 is NO MORE incompatible with loop device or at least HAD problems with it"

:D
_________________
Reiser4 Gentoo FAQ [25Dec2016]
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Thu Jan 14, 2010 12:10 pm    Post subject: Reply with quote

dusanc wrote:
kernelOfTruth wrote:
aTan wrote:
ohh, shame on me. I'm using reiser4 on ccache loop device.


note that reiser4 is incompatible with loop device or at least has problems with it :idea:


AFAIK that should say:
"note that reiser4 is NO MORE incompatible with loop device or at least HAD problems with it"

:D


haha - nice ! :D

I don't wanted to spread FUD (didn't know it works perfectly now), so therefore this heads up :oops:
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Thu Jan 14, 2010 4:02 pm    Post subject: Reply with quote

dodo1122 wrote:
tranquilcool wrote:
CC lib/decompress_unlzo.o
lib/decompress_unlzo.c:53: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'parse_header'
lib/decompress_unlzo.c:90: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'unlzo'
make[1]: *** [lib/decompress_unlzo.o] Error 1
make: *** [lib] Error 2


errors latest git pull zen-unstable.


I'll look into it when i get home.


upstream issue.
just remove 'config RD_LZO' from Kconfig if you have this problem and you are set to go.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
aTan
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jan 2007
Posts: 134
Location: Czech Republic (Ukraine)

PostPosted: Thu Jan 14, 2010 6:51 pm    Post subject: Reply with quote

kernelOfTruth wrote:
aTan wrote:
ohh, shame on me. I'm using reiser4 on ccache loop device.


note that reiser4 is incompatible with loop device or at least has problems with it :idea:


Since when? I've using it since 29 or 30 zen-sources. It hangs with 32 for me and works fine with 31 right now.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat Jan 16, 2010 3:10 pm    Post subject: Reply with quote

aTan wrote:
kernelOfTruth wrote:
aTan wrote:
ohh, shame on me. I'm using reiser4 on ccache loop device.


note that reiser4 is incompatible with loop device or at least has problems with it :idea:


Since when? I've using it since 29 or 30 zen-sources. It hangs with 32 for me and works fine with 31 right now.


since from the beginning :P

like dusanc pointed out it should however work since several releases now (2.6.32 is broken and Edward also said so)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat Jan 16, 2010 11:25 pm    Post subject: Reply with quote

any experience with 2.6.33-rc4 and BFS ?

or would be CFS the better (less hardlocks) option right now ?

many thanks for your insight in advance
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
dodo1122
Guru
Guru


Joined: 02 Sep 2006
Posts: 347
Location: York, England

PostPosted: Sun Jan 17, 2010 4:51 pm    Post subject: Reply with quote

kernelOfTruth wrote:
any experience with 2.6.33-rc4 and BFS ?

or would be CFS the better (less hardlocks) option right now ?

many thanks for your insight in advance


Well, BFS works fine on 2.6.33 zen. There might be some problems with BFS + KMS, but i got reports from people that it works now. Everything should be working as expected now, especially with 2.6.33-rc4-zen1 and zen.git.
_________________
#zen-sources on irc.rizon.net
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sun Jan 17, 2010 5:42 pm    Post subject: Reply with quote

thanks dodo ! :D

recommendations against 2.6.33-rc* and using hibernate to ram ? e.g. data corruption, etc. ?

if there's none there's no "blocker" for me anymore to not migrate to 2.6.33 8)

thanks again, guys, for doing an excellent job with zen ! :D
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Mon Jan 18, 2010 8:07 pm    Post subject: Reply with quote

hibernate to ram seems to be safe, too

badly we have an unfortunate situation going on here:


sound goes faster and slower - remembers me of windows 95 and faulty first generation drivers

ah - the good old times :twisted:

this is with BFS - anyone else encountering timing problems with sound ?

kernel is 2.6.33-rc4-zen1
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Hwoarang
Retired Dev
Retired Dev


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Mon Jan 18, 2010 8:25 pm    Post subject: Reply with quote

I do have some compilation issues with nvidia-drivers and virtualbox-modules using the latest rc of zen-sources? Anyone else having similar issues?
Back to top
View user's profile Send private message
SpectreDragon
Tux's lil' helper
Tux's lil' helper


Joined: 22 Aug 2008
Posts: 92
Location: Germany

PostPosted: Mon Jan 18, 2010 8:43 pm    Post subject: Reply with quote

Hwoarang wrote:
I do have some compilation issues with nvidia-drivers and virtualbox-modules using the latest rc of zen-sources? Anyone else having similar issues?

same here.

this patch worked to compile nvidia-drivers.
did not try any for virtualbox-modules but it seems that they are aware of this problem.
Back to top
View user's profile Send private message
Hwoarang
Retired Dev
Retired Dev


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Mon Jan 18, 2010 8:48 pm    Post subject: Reply with quote

I see. thank you
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 8, 9, 10 ... 12, 13, 14  Next
Page 9 of 14

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum