Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Zen Kernel Discussion/Support Thread - Part 2
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5 ... 12, 13, 14  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ebrsc
n00b
n00b


Joined: 24 Jun 2008
Posts: 31

PostPosted: Fri Dec 11, 2009 9:12 am    Post subject: Reply with quote

tranquilcool wrote:
cheater1034 wrote:
2.6.32-ck1 is now in zen-stable master ;)

Here's what it features (series)
Code:
# 2.6.32-sched-bfs-311.patch (bfs is found in zen-sched)
sched-add-above-background-load-function.patch (adapted for cfs too)
cfq-iso_ionice.patch
mm-make_swappiness_really_mean_it.patch
mm-kswapd_inherit_prio.patch
mm-background_scan.patch
mm-idleprio_prio.patch (bfs only)
mm-lru_cache_add_lru_tail.patch
kconfig-expose_vmsplit_option.patch
hz-default_1000.patch
hz-no_default_250.patch
hz-raise_max.patch
preempt-desktop-tune.patch
#ck-version.patch


I think most will be very happy ;)

Also updated 2.6.31, and will soon make the final 2.6.30 release* - may add the ck patches to master-2.6.31 as well.


how do i checkout v2.6.32-ck1?
i though i could manage the git commands but it's obviously not so.

git remote add zenstable git://zen-kernel.org/kernel/zen-stable.git
git fetch zenstable
git checkout -b ck zenstable/ck

edit: forgot "checkout" :oops:

inspired from http://zen-kernel.org/tutorials/switching-between-zen-stable-and-zen.git
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Dec 11, 2009 1:04 pm    Post subject: Reply with quote

you don't need to checkout anything new - so no need for this git "stunt"

just
Code:
git pull
on the zen-stable repo and you should get latest 2.6.32-zen1 with ck-patches and configuration options added

have fun ! :)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
ebrsc
n00b
n00b


Joined: 24 Jun 2008
Posts: 31

PostPosted: Fri Dec 11, 2009 1:31 pm    Post subject: Reply with quote

kernelOfTruth wrote:
you don't need to checkout anything new - so no need for this git "stunt"

well, it's needed if you don't want to use zen but only the ck branch. that's what I thought tranquilcool wanted to do but I may be wrong :P
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Fri Dec 11, 2009 2:01 pm    Post subject: Reply with quote

kernelOfTruth wrote:
you don't need to checkout anything new - so no need for this git "stunt"

just
Code:
git pull
on the zen-stable repo and you should get latest 2.6.32-zen1 with ck-patches and configuration options added

have fun ! :)


fact is i don't see no ck config options.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Dec 11, 2009 2:16 pm    Post subject: Reply with quote

tranquilcool wrote:
kernelOfTruth wrote:
you don't need to checkout anything new - so no need for this git "stunt"

just
Code:
git pull
on the zen-stable repo and you should get latest 2.6.32-zen1 with ck-patches and configuration options added

have fun ! :)


fact is i don't see no ck config options.


'cause they're active all the time :roll:

please take a look at the code at gitweb


I - of course - could be wrong, so please correct if that's the case

thanks
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
seqizz
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jan 2008
Posts: 103

PostPosted: Fri Dec 11, 2009 7:52 pm    Post subject: :\ Reply with quote

Ok i should report this, especially after trying with zen-sources-9999 (with "-stable" flag).
I can't power off my laptop without pressing the button. When i give "init 0", everything goes good, even the system shuts down the hard drive as i can hear. But screen stays and there is a ["Power Down"] text at the bottom.
Afaik, this is happening with latest zen kernel (git) and 2.6.31-p9 and p8. But there is no problem with 2.6.31-zen1 kernel.
I've played with some ACPI options in kernel, but none of them solved this.

Laptop? Asus f3sc : http://dpaste.com/132146/
Kernel config? Here: http://pastebin.com/m65fb4281

Here is the same problem (i think) http://bbs.archlinux.org/viewtopic.php?id=58418 on arch.
_________________
what about an answer here?
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Fri Dec 11, 2009 8:59 pm    Post subject: Re: :\ Reply with quote

seqizz wrote:
Ok i should report this, especially after trying with zen-sources-9999 (with "-stable" flag).
I can't power off my laptop without pressing the button. When i give "init 0", everything goes good, even the system shuts down the hard drive as i can hear. But screen stays and there is a ["Power Down"] text at the bottom.
Afaik, this is happening with latest zen kernel (git) and 2.6.31-p9 and p8. But there is no problem with 2.6.31-zen1 kernel.
I've played with some ACPI options in kernel, but none of them solved this.

Laptop? Asus f3sc : http://dpaste.com/132146/
Kernel config? Here: http://pastebin.com/m65fb4281

Here is the same problem (i think) http://bbs.archlinux.org/viewtopic.php?id=58418 on arch.


The best thing to do would be to test 2.6.32 upstream (stable version), if it works for that - then try 2.6.32-zen1 (zen-stable.git, release soon) - if it fails on 2.6.32-zen1 only - throw it in the bug tracker on zen-kernel.org - if it fails on 2.6.32 upstream then we may be looking at hardware related, something missing, or an actual upstream bug. Although doubtful, if 2.6.32-zen1 is the only one that fails then try without bfs (choose cfs)

I think bfs doesn't work well with parallel rc scripts - that may or may not be true still, but if you have parallel init setup maybe disable it and see if that works?

Thanks
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Fri Dec 11, 2009 9:03 pm    Post subject: Reply with quote

tranquilcool wrote:
how do i checkout v2.6.32-ck1?
i though i could manage the git commands but it's obviously not so.


I pushed a v2.6.32-ck1 tag (if you wanted ck only or wanted to diff off of the ck kernel for some reason)

If that's not what you meant, there are no options for any of the ck patches - it edits some defaults like HZ and preempt, but nothing new is added.

Zen adds the bfs/cfs option too, so that isn't found in the ck kernel. (ck kernel is bfs only)
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Fri Dec 11, 2009 9:37 pm    Post subject: Reply with quote

there is going to be conflicts in zen-stable master
so bear with me for a bit ;)
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
seqizz
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jan 2008
Posts: 103

PostPosted: Sat Dec 12, 2009 12:51 am    Post subject: Re: :\ Reply with quote

cheater1034 wrote:

The best thing to do would be to test 2.6.32 upstream (stable version), if it works for that - then try 2.6.32-zen1 (zen-stable.git, release soon) - if it fails on 2.6.32-zen1 only - throw it in the bug tracker on zen-kernel.org - if it fails on 2.6.32 upstream then we may be looking at hardware related, something missing, or an actual upstream bug. Although doubtful, if 2.6.32-zen1 is the only one that fails then try without bfs (choose cfs)

I think bfs doesn't work well with parallel rc scripts - that may or may not be true still, but if you have parallel init setup maybe disable it and see if that works?

Thanks


Very good guess :) I've disabled parallel init and tried with bfs, also tried parallel init with cfs, both worked.. I'm not good with GIT, so as long as i don't switch to stable version manually in /usr/src/linux, i can't try it with emerging again. I mean it's pita, everything goes under distfiles, then copies to src directory, then uninstall the old one.. I've switched 9999 just because of this. "git pull" :mrgreen:

Anyway, thanks cheater1034.

// Edit: BFS is still sometimes problematic w/o parallel init. Going back to CFS after long time.
_________________
what about an answer here?
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5876

PostPosted: Sun Dec 13, 2009 2:09 am    Post subject: Reply with quote

Yay, the 10000Hz thing is back!

What was the original reason for that setting anyway? I remember seeing a 100,000Hz(!) option in one patchset a long time ago, but I'm pretty sure it was just added for a laugh.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sun Dec 13, 2009 12:25 pm    Post subject: Reply with quote

does reiser4 work correctly now again ?

thanks cheater for pushing fixes (?)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
VinzC
Watchman
Watchman


Joined: 17 Apr 2004
Posts: 5021
Location: Dark side of the mood

PostPosted: Sun Dec 13, 2009 5:32 pm    Post subject: Boot splash issue: starts late Reply with quote

Hi guys.

I've tried zen-sources 2.6.31_p9 to first see if it solved an issue I had with Unreal Tournament 2004. I'm also facing a smaller issue with boot splash. It works but starts a little late. The first thing I've noticed is that the screen resolution doesn't switch immediately to the one I selected (1680x1050) but instead the kernel loads in standard VGA mode, prints a couple of log lines and *poof* switches to 1680x1050 and the splash screen appears right at that moment.

Before I included as suggested /usr/share/v86d/initramfs in the kernel bootsplash didn't even appear (I had an error message about v86d being not found) so it's better than nothing. Does anybody have an idea on what I can do to have bootsplash start earlier or as expected?

With my regular Gentoo kernel, the bootsplash screen appears early as expected. Note I did start from a fresh kernel config instead of importing my older one, which I usually do when I upgrade kernels.

Here are my kernel boot line:
cat /proc/cmdline:
dolvm root=/dev/ram0 real_root=/dev/gentoo/root video=uvesafb:1680x1050-32@60,ywrap splash=silent,theme:danger CONSOLE=/dev/tty1

Thanks in advance.

EDIT: The issue is solved! I forgot to append :mtrr:3 to the video= parameter, like this:
Quote:
dolvm root=/dev/ram0 real_root=/dev/gentoo/root video=uvesafb:1680x1050-32@60,ywrap:mtrr:3 splash=silent,theme:danger CONSOLE=/dev/tty1

_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Sun Dec 13, 2009 7:16 pm    Post subject: Reply with quote

kernelOfTruth wrote:
does reiser4 work correctly now again ?

thanks cheater for pushing fixes (?)


reiser4 is upstream (From mmotm) now in zen-stable.git, not so sure if it is problem free or not (if it is i need to tell upstream)

It is broken in zen.git
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sun Dec 13, 2009 7:31 pm    Post subject: Reply with quote

cheater1034 wrote:
kernelOfTruth wrote:
does reiser4 work correctly now again ?

thanks cheater for pushing fixes (?)


reiser4 is upstream (From mmotm) now in zen-stable.git, not so sure if it is problem free or not (if it is i need to tell upstream)

It is broken in zen.git


Edward seems to be aware that there are problems with reiser4 & zen / 2.6.32 - I'm wondering when he'll be releasing a patch for 2.6.32 ...
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
AaronPPC
Guru
Guru


Joined: 29 May 2005
Posts: 522
Location: Tucson, AZ

PostPosted: Sun Dec 13, 2009 9:35 pm    Post subject: Reply with quote

I apologize for the argument I'm about to cause...
Ant_P wrote:
Yay, the 10000Hz thing is back!

What are the drawbacks to using a timer frequency that insane?
_________________
--Aaron
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Mon Dec 14, 2009 12:47 am    Post subject: Reply with quote

AaronPPC wrote:
I apologize for the argument I'm about to cause...
Ant_P wrote:
Yay, the 10000Hz thing is back!

What are the drawbacks to using a timer frequency that insane?


anything over 1000 may break drivers, 10000 hz is extremely likely to break drivers ;)
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Mon Dec 14, 2009 1:41 am    Post subject: Reply with quote

kernelOfTruth wrote:
cheater1034 wrote:
kernelOfTruth wrote:
does reiser4 work correctly now again ?

thanks cheater for pushing fixes (?)


reiser4 is upstream (From mmotm) now in zen-stable.git, not so sure if it is problem free or not (if it is i need to tell upstream)

It is broken in zen.git


Edward seems to be aware that there are problems with reiser4 & zen / 2.6.32 - I'm wondering when he'll be releasing a patch for 2.6.32 ...



I haven't tested normal reiser4 (without cryptcompress and compression) since latest changes

but reiser4 with cryptcompress and gzip-compression seems to work ok

thanks ! :)


NOTE: :idea:
before the changes: there was an odd behavior that it wasn't syncing files to disk while issueing the command

"sync"

it only was syncing files when the partition was unmounted



if it's still happening now - something definitely would be broken (as I already wrote I didn't have time to test it yet)

perhaps someone else could test it ?
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
huckabuck
Tux's lil' helper
Tux's lil' helper


Joined: 14 Apr 2007
Posts: 110
Location: Bronx, NY

PostPosted: Tue Dec 15, 2009 4:12 am    Post subject: Reply with quote

Blisstified !

Code:
Linux gentoo 2.6.32-zen1 #1 ZEN SMP Mon Dec 14 22:49:29 EST 2009 i686 Intel(R) Celeron(R) CPU 2.40GHz GenuineIntel GNU/Linux
Back to top
View user's profile Send private message
Colt45
Tux's lil' helper
Tux's lil' helper


Joined: 05 Sep 2007
Posts: 102
Location: Central Washington

PostPosted: Tue Dec 15, 2009 8:53 am    Post subject: Reply with quote

For some reason with 2.6.32-zen1 on my EeePC it cannot remount the root drive RW (ext4). No obvious reason. I went back to .31-zen9, works fine, again.
_________________
"Hopps" - AMD Athlon X2 4450B, 4GB, 128GB Samsung SSD, (Gentoo Hardened amd64; gcc-4.9.3; 4.4.8-hardened-r1)
"Dash" - 2x Intel Xeon 5148, 12GB FB-DIMM, 3x Samsung 1TB (mdadm RAID 5), AMD HD6950, (Gentoo amd64-multilib; gcc-5.3.0; 4.4.0-pf4)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7104
Location: Austria

PostPosted: Tue Dec 15, 2009 9:11 am    Post subject: Reply with quote

There have been lots of fixes for ext4 in 2.6.32.1, try out 2.6.32-zen2.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue Dec 15, 2009 11:47 am    Post subject: Reply with quote

genstorm wrote:
There have been lots of fixes for ext4 in 2.6.32.1, try out 2.6.32-zen2.


it's not included in the initial 2.6.32-zen2 so you might need to "git pull" again :idea:

thanks for the heads-up genstorm !
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Spaulding
Apprentice
Apprentice


Joined: 16 Apr 2006
Posts: 159
Location: /dev/vagina

PostPosted: Wed Dec 16, 2009 1:24 pm    Post subject: Reply with quote

Code:

*         >> Compiling 2.6.32-zen1 bzImage...
* ERROR: Failed to compile the "bzImage" target...

* -- Grepping log... --

Data Center Bridging support (DCB) [N/y/?] n
*
* Serial ATA (prod) and Parallel ATA (experimental) drivers
*
Serial ATA (prod) and Parallel ATA (experimental) drivers (ATA) [Y/n/m/?] y
  Verbose ATA error reporting (ATA_VERBOSE_ERROR) [Y/n/?] (NEW)   ATA ACPI Support (ATA_ACPI) [Y/n/?] y
--
  SYMLINK include/asm -> include/asm-x86
  HOSTCC  scripts/kallsyms
  CC      scripts/mod/empty.o
  HOSTCC  scripts/mod/mk_elfconfig
scripts/kallsyms.c: In function ‘read_symbol’:
scripts/kallsyms.c:112: warning: ignoring return value of ‘fgets’, declared with attribute warn_unused_result
--
  HOSTCC  scripts/conmakehash
  HOSTCC  scripts/bin2c
  HOSTCC  scripts/mod/modpost.o
  HOSTCC  scripts/mod/sumversion.o
scripts/mod/modpost.c: In function ‘get_markers’:
scripts/mod/modpost.c:1562: warning: ignoring return value of ‘asprintf’, declared with attribute warn_unused_result
scripts/mod/modpost.c: In function ‘add_marker’:
scripts/mod/modpost.c:1982: warning: ignoring return value of ‘asprintf’, declared with attribute warn_unused_result
  HOSTLD  scripts/mod/modpost
  CALL    scripts/checksyscalls.sh
  CC      init/main.o
  HOSTCC  usr/gen_init_cpio
usr/gen_init_cpio.c: In function ‘cpio_mkfile’:
usr/gen_init_cpio.c:357: warning: ignoring return value of ‘fwrite’, declared with attribute warn_unused_result
--
  CC      drivers/acpi/event.o
  CC      fs/ext4/hash.o
  CC      drivers/acpi/debug.o
  CC      fs/ext4/resize.o
drivers/acpi/debug.c: In function ‘acpi_debug_init’:
drivers/acpi/debug.c:300: error: ‘ACPI_SYSTEM_FILE_DEBUG_LAYER’ undeclared (first use in this function)
drivers/acpi/debug.c:300: error: (Each undeclared identifier is reported only once
drivers/acpi/debug.c:300: error: for each function it appears in.)
drivers/acpi/debug.c:302: error: ‘acpi_system_debug_proc_fops’ undeclared (first use in this function)
drivers/acpi/debug.c:308: error: ‘ACPI_SYSTEM_FILE_DEBUG_LEVEL’ undeclared (first use in this function)
--
  LD      fs/notify/inotify/built-in.o
  LD      fs/notify/built-in.o
  LD      fs/quota/built-in.o
  CC      fs/ramfs/inode.o
  CC      fs/proc/task_mmu.o
fs/ramfs/inode.c:284: warning: ‘ramfs_kill_sb’ defined but not used
--
  CC      fs/dcookies.o
  LD      fs/built-in.o
* Gentoo Linux Genkernel; Version 3.4.10.906
* Running with options: --no-clean --menuconfig all

* ERROR: Failed to compile the "bzImage" target...

* -- End log... --

#####################

/usr/src/linux-2.6.32-zen1 # make -j2 bzImage
  CHK     include/linux/version.h
  CHK     include/linux/utsrelease.h
  SYMLINK include/asm -> include/asm-x86
  CALL    scripts/checksyscalls.sh
  CHK     include/linux/compile.h
  CC      drivers/acpi/debug.o
drivers/acpi/debug.c: In function ‘acpi_debug_init’:
drivers/acpi/debug.c:300: error: ‘ACPI_SYSTEM_FILE_DEBUG_LAYER’ undeclared (first use in this function)
drivers/acpi/debug.c:300: error: (Each undeclared identifier is reported only once
drivers/acpi/debug.c:300: error: for each function it appears in.)
drivers/acpi/debug.c:302: error: ‘acpi_system_debug_proc_fops’ undeclared (first use in this function)
drivers/acpi/debug.c:308: error: ‘ACPI_SYSTEM_FILE_DEBUG_LEVEL’ undeclared (first use in this function)
make[2]: *** [drivers/acpi/debug.o] Błąd 1
make[1]: *** [drivers/acpi] Błąd 2
make: *** [drivers] Błąd 2
make: *** Oczekiwanie na niezakończone zadania....




EDIT: when i turned off ACPI Debug(or something similar) kernel compiled fine.
Back to top
View user's profile Send private message
Rion
Guru
Guru


Joined: 12 Oct 2006
Posts: 377
Location: Ekaterinburg, Russia

PostPosted: Wed Dec 16, 2009 5:34 pm    Post subject: Reply with quote

hm with 2.6.32-zen2 my rtl8187 doesn't work (dmesg shows something like "switch is off"). graphics(intel+kms) starts flicker after X start (even in console)
_________________
~amd64
rion-overlay
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Thu Dec 17, 2009 12:30 am    Post subject: Reply with quote

Rion wrote:
hm with 2.6.32-zen2 my rtl8187 doesn't work (dmesg shows something like "switch is off"). graphics(intel+kms) starts flicker after X start (even in console)

try now
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4, 5 ... 12, 13, 14  Next
Page 4 of 14

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum