Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved]Can't emerge amarok-2.2.1-r2 (x86)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1400
Location: Adelaide/Australia

PostPosted: Thu Dec 03, 2009 11:33 am    Post subject: [Solved]Can't emerge amarok-2.2.1-r2 (x86) Reply with quote

Incompatible use flag requirements for media-libs/taglib-1.6.1 between amarok and amarok-utils.
Anyone else experiencing this?

Problems went away - still, I think Amarok 1 series was better than 2.
_________________
...Lyall


Last edited by lyallp on Wed Jan 20, 2010 11:12 am; edited 1 time in total
Back to top
View user's profile Send private message
causality
Apprentice
Apprentice


Joined: 03 Jun 2006
Posts: 228

PostPosted: Sun Dec 06, 2009 2:19 am    Post subject: Reply with quote

I had a similar issue with Taglib. Please see my post here: https://forums.gentoo.org/viewtopic-t-803546-highlight-.html. I resolved it by emerging the unstable version 1.6.1. That didn't help me with Amarok, however. After dealing with Taglib, amarok-2.2.1-r2 would try to compile, and the compile would fail at the configure stage, stating that it could not find qtscriptgenerator. This is despite the fact that I do indeed have x11-libs/qtscriptgenerator installed. Please see my post on the subject at https://forums.gentoo.org/viewtopic-t-804424-highlight-.html. If you resolve the taglib issue, you should expect to encounter that problem immediately afterwards. I never could find a solution to this one.

I note that amarok-2.2.1-r2 is marked as ~unstable. I could not find the answer to this problem and I ultimately decided to be satisfied with the stable version, which is 2.2.0. So I removed both amarok and amarok-utils from my /etc/portage/package.keywords file and re-emerged both. Since then, Amarok has been working well and has given me no problems.

Note, I don't think it makes a difference here, but in the interests of full disclosure I should add that I am using Gentoo Hardened. It's possible that items marked as stable for you would be marked unstable for me because of that. However, in this particular case, I strongly doubt it matters at all. Just thought I'd mention it in the unlikely event that amarok-2.2.1-r2 is marked stable for you.

Sorry that this doesn't help you to install amarok-2.2.1-r2. I tried to get that to work, could not do so, and eventually decided that there is no difference between 2.2.0 and 2.2.1-r2 that is worth this much effort (at least not for my personal needs). I imagine that folks who are far more knowledgable than I will work these things out as later versions of Amarok become stable in the Portage tree.
Back to top
View user's profile Send private message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1400
Location: Adelaide/Australia

PostPosted: Sun Dec 06, 2009 9:56 am    Post subject: Reply with quote

Thanks for taking the time to reply.

I think I may take your suggestion as to going back to stable. I am only on unstable because, at the time, Amarok 2 was unstable. That appears to have changed now.
_________________
...Lyall
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum