Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
blocking problem [solved]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
michael_w
Guru
Guru


Joined: 22 Feb 2006
Posts: 424
Location: 09xxx

PostPosted: Fri Dec 04, 2009 4:10 pm    Post subject: blocking problem [solved] Reply with quote

Hi,

bei einem "emerge -avuDN world" bekomme ich folgendes nicht gelöst:
Code:

[blocks B     ] <sys-fs/e2fsprogs-1.41.8 ("<sys-fs/e2fsprogs-1.41.8" is blocking sys-apps/util-linux-2.16.2)
[blocks B     ] <sys-libs/e2fsprogs-libs-1.41.8 ("<sys-libs/e2fsprogs-libs-1.41.8" is blocking sys-apps/util-linux-2.16.2)

...

  ('installed', '/', 'sys-apps/util-linux-2.16.2', 'nomerge') pulled in by
    sys-apps/util-linux required by world
    >=sys-apps/util-linux-2.13 required by ('installed', '/', 'sys-power/pm-util
s-1.2.5', 'nomerge')
    >=sys-apps/util-linux-2.16 required by ('ebuild', '/', 'sys-fs/lvm2-2.02.56-
r1', 'merge')
    (and 3 more)

  ('ebuild', '/', 'sys-fs/e2fsprogs-1.41.3-r1', 'merge') pulled in by
    sys-fs/e2fsprogs required by ('installed', '/', 'app-misc/mc-4.7.0_pre3', 'n
omerge')
    sys-fs/e2fsprogs required by world

  ('ebuild', '/', 'sys-libs/e2fsprogs-libs-1.41.3-r1', 'merge') pulled in by
    >=sys-libs/e2fsprogs-libs-1.41 required by ('ebuild', '/', 'sys-fs/cryptsetu
p-1.0.7-r1', 'merge')
    ~sys-libs/e2fsprogs-libs-1.41.3 required by ('ebuild', '/', 'sys-fs/e2fsprog
s-1.41.3-r1', 'merge')


vorher steht aber weiter oben:
Code:

[ebuild  N    ] sys-libs/e2fsprogs-libs-1.41.3-r1  USE="nls" 0 kB
[ebuild  N    ] sys-fs/e2fsprogs-1.41.3-r1  USE="nls" 0 kB


ich hab im ersten Ansatz (nicht nörgeln) e2fsprogs deinstalliert und danach util-linux installiert und gedacht ich könnte es damit hinbekommen. aber nix wars.
hat einer einen tipp für mich?
_________________
Linux ryzen 4.19.52-gentoo #2 SMP Mon Jun 24 18:31:32 CEST 2019 x86_64 AMD Ryzen 7 1800X Eight-Core Processor AuthenticAMD GNU/Linux


Last edited by michael_w on Sat Dec 05, 2009 11:13 am; edited 1 time in total
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Fri Dec 04, 2009 7:31 pm    Post subject: Reply with quote

Bei mir hat emerge -C e2fsprogs e2fspogs-libs geholfen. Du musst beide Pakete löschen. Und danach nichts manuell installieren sondern einfach emerge -uDN world.
Back to top
View user's profile Send private message
michael_w
Guru
Guru


Joined: 22 Feb 2006
Posts: 424
Location: 09xxx

PostPosted: Fri Dec 04, 2009 10:05 pm    Post subject: Reply with quote

Tja,

ich hatte je beide Pakete händisch gelöscht, trotzdem kommt die Fehlermeldung.
_________________
Linux ryzen 4.19.52-gentoo #2 SMP Mon Jun 24 18:31:32 CEST 2019 x86_64 AMD Ryzen 7 1800X Eight-Core Processor AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
michael_w
Guru
Guru


Joined: 22 Feb 2006
Posts: 424
Location: 09xxx

PostPosted: Sat Dec 05, 2009 8:16 am    Post subject: Reply with quote

Jetzt hab ichs halbwegs, aber scheitere an dem hier:
Code:

make[2]: Leaving directory `/var/tmp/portage/sys-libs/e2fsprogs-libs-1.41.3-r1/w
ork/e2fsprogs-libs-1.41.3/intl'
make[1]: Leaving directory `/var/tmp/portage/sys-libs/e2fsprogs-libs-1.41.3-r1/w
ork/e2fsprogs-libs-1.41.3'
>>> Completed installing e2fsprogs-libs-1.41.3-r1 into /var/tmp/portage/sys-libs
/e2fsprogs-libs-1.41.3-r1/image/

--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE "/var/log/sandbox/sandbox-29684.log"

VERSION 1.0
FORMAT: F - Function called
FORMAT: S - Access Status
FORMAT: P - Path as passed to function
FORMAT: A - Absolute Path (not canonical)
FORMAT: R - Canonical Path
FORMAT: C - Command Line

F: mkdir
S: deny
P: ././var/cache/fonts/tfm
A: /var/cache/fonts/tfm
R: /var/cache/fonts/tfm
C: mkdir ././var/cache/fonts/tfm
--------------------------------------------------------------------------------

>>> Failed to emerge sys-libs/e2fsprogs-libs-1.41.3-r1, Log file:

>>>  '/var/tmp/portage/sys-libs/e2fsprogs-libs-1.41.3-r1/temp/build.log'


was nu?
_________________
Linux ryzen 4.19.52-gentoo #2 SMP Mon Jun 24 18:31:32 CEST 2019 x86_64 AMD Ryzen 7 1800X Eight-Core Processor AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Sat Dec 05, 2009 8:24 am    Post subject: Reply with quote

Die beiden erwähnten Logfiles bitte.
/var/log/sandbox/sandbox-29684.log
/var/tmp/portage/sys-libs/e2fsprogs-libs-1.41.3-r1/temp/build.log
Am besten auf http://pastebin.com/ oder so.
(Dass das ebulild oder Buildscript in /var/cache/fonts rumpfuscht kann ich mir nicht vorstellen..)
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Sat Dec 05, 2009 8:26 am    Post subject: Reply with quote

Das hat jetzt aber nichts mehr mit den geblockten Paketen zu tun sondern ist eine Access Violation deiner Sandbox.
Back to top
View user's profile Send private message
michael_w
Guru
Guru


Joined: 22 Feb 2006
Posts: 424
Location: 09xxx

PostPosted: Sat Dec 05, 2009 8:46 am    Post subject: Reply with quote

http://pastebin.com/m43e0f583

und

http://pastebin.com/m42317790

die beiden logs
_________________
Linux ryzen 4.19.52-gentoo #2 SMP Mon Jun 24 18:31:32 CEST 2019 x86_64 AMD Ryzen 7 1800X Eight-Core Processor AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Sat Dec 05, 2009 9:18 am    Post subject: Reply with quote

Aus den Logs werd ich nicht schlau...
Es wird nirgends versucht, /var/cache/fonts/tfm zu erstellen (ich konnte jedenfalls nichts finden).
Dann diese Meldung:
sandbox:main signal SIGQUIT already had a handler ...

Welche Sandbox-Version ist bei dir installiert?
sandbox gesucht im bugzilla liefert z.B. das hier:
https://bugs.gentoo.org/show_bug.cgi?id=223077
Sollte aber auf dich nicht zutrefen...

Ansonsten mach einfach nochmal ein emerge --sync, dein letztes ist wohl schon etwas her ;)
-> aus dem ChangeLog:
Quote:

01 Dec 2009; Mike Frysinger <vapier@gentoo.org>
e2fsprogs-libs-1.41.3-r1.ebuild, e2fsprogs-libs-1.41.6.ebuild,
e2fsprogs-libs-1.41.7.ebuild, e2fsprogs-libs-1.41.8.ebuild,
e2fsprogs-libs-1.41.9.ebuild:
Switch to new tc-has-tls function rather than USE=elibc_uclibc.

29 Nov 2009; Joseph Jezak <josejx@gentoo.org>
e2fsprogs-libs-1.41.9.ebuild:
Marked ppc stable for bug #284745.

28 Nov 2009; Ra<C3><BA>l Porcel <armin76@gentoo.org>
e2fsprogs-libs-1.41.9.ebuild:
ia64/sparc stable wrt #284745

23 Nov 2009; Markus Meier <maekke@gentoo.org>
e2fsprogs-libs-1.41.9.ebuild:
arm stable, bug #284745

09 Nov 2009; Christian Faulhammer <fauli@gentoo.org>
e2fsprogs-libs-1.41.9.ebuild:
stable x86, bug 284745

31 Oct 2009; Brent Baude <ranger@gentoo.org> e2fsprogs-libs-1.41.9.ebuild:
Marking e2fsprogs-libs-1.41.9 ppc64 for bug 284745

21 Oct 2009; Jeroen Roovers <jer@gentoo.org> e2fsprogs-libs-1.41.9.ebuild:
Stable for HPPA (bug #284745).

03 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
e2fsprogs-libs-1.41.9.ebuild:
Stable on alpha, bug #284745

1.41.9 also schon seit einiger Zeit stable ;)
Vllt. behebt ja das dein Problem.
Back to top
View user's profile Send private message
michael_w
Guru
Guru


Joined: 22 Feb 2006
Posts: 424
Location: 09xxx

PostPosted: Sat Dec 05, 2009 9:35 am    Post subject: Reply with quote

Letzter sync heute morgen ;)

so siehts aus bei mir:
Code:

gauss ~ # eix e2fsprogs
* sys-fs/e2fsprogs
     Available versions:  1.40.9 1.41.3-r1 ~1.41.6 ~1.41.6-r1 ~1.41.7 ~1.41.7-r1 ~1.41.8 ~1.41.9 {elibc_FreeBSD nls static}
     Homepage:            http://e2fsprogs.sourceforge.net/
     Description:         Standard EXT2/EXT3/EXT4 filesystem utilities

* sys-libs/e2fsprogs-libs
     Available versions:  1.41.3-r1 ~1.41.6 ~1.41.7 ~1.41.8 ~1.41.9 {nls}
     Homepage:            http://e2fsprogs.sourceforge.net/
     Description:         e2fsprogs libraries (common error and subsystem)

2 Treffer.


und
Code:

gauss ~ # eix sandbox
[I] sys-apps/sandbox
     Available versions:  1.2.18.1-r2 ~1.2.18.1-r3 ~1.2.20_alpha2-r1 1.6-r2 ~2.1 ~2.2 {multilib}
     Installed versions:  1.6-r2(13:07:37 16.04.2009)
     Homepage:            http://www.gentoo.org/
     Description:         sandbox'd LD_PRELOAD hack


Quote:
1.41.9 also schon seit einiger Zeit stable ;)

bei mir nicht. s.o.
_________________
Linux ryzen 4.19.52-gentoo #2 SMP Mon Jun 24 18:31:32 CEST 2019 x86_64 AMD Ryzen 7 1800X Eight-Core Processor AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Sat Dec 05, 2009 9:54 am    Post subject: Reply with quote

Das nächste mal aber gleich sagen, welche Architektur man fährt.
Ein emerge --info ist da immer gleich im ersten Post nicht schlecht ;)
Das wäre auch jetzt noch interessant.
Back to top
View user's profile Send private message
michael_w
Guru
Guru


Joined: 22 Feb 2006
Posts: 424
Location: 09xxx

PostPosted: Sat Dec 05, 2009 11:12 am    Post subject: Reply with quote

Sorry, hier ist alles amd64. Ich habs aber jetzt hinbekommen. Ich hab e2fsprogs und die libs bei keywords eingetragen und damit gehts dann.
Thx an alle.
_________________
Linux ryzen 4.19.52-gentoo #2 SMP Mon Jun 24 18:31:32 CEST 2019 x86_64 AMD Ryzen 7 1800X Eight-Core Processor AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum