Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Virtualbox-bin 3.1.0 - modules fail to load
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
butchie
n00b
n00b


Joined: 13 Oct 2004
Posts: 48

PostPosted: Sat Dec 05, 2009 10:53 pm    Post subject: [Solved] Virtualbox-bin 3.1.0 - modules fail to load Reply with quote

After an upgrade of virtualbox-bin and related packages from 3.0.12 to 3.1.0, virtualbox does'nt launch guests anymore.
On boot, I have error messages on some modules not loading.
/etc/init.d/modules restart produces :
Code:
* WARNING: you are stopping a boot service
* Caching service dependencies...                                                                          [ ok ]
* Loading module vboxdrv...                                                                                [ ok ]
* Loading module vboxnetflt...
FATAL: Error inserting vboxnetflt (/lib/modules/2.6.31-gentoo-r4/misc/vboxnetflt.ko): Invalid module format
* Failed to load vboxnetflt                                                                                [ !! ]
* Loading module vboxnetadp...
FATAL: Error inserting vboxnetadp (/lib/modules/2.6.31-gentoo-r4/misc/vboxnetadp.ko): Invalid module format
* Failed to load vboxnetadp


lsmod shows :
Code:
Module                  Size  Used by
radeon                331504  2
drm                   123644  3 radeon
vboxdrv               112872  0
iwl3945                54224  0
intel_agp              23300  0
agpgart                26044  2 drm,intel_agp



At the end of dmesg, I get :
Code:
[ 1630.037719] vboxadd: exports duplicate symbol AssertMsg2 (owned by vboxdrv)
[ 1630.067908] vboxadd: exports duplicate symbol AssertMsg2 (owned by vboxdrv)


I am using gentoo-sources.2.6.31-r4

Have anyone succeeded using virtualbox 3.1.0 ?


Last edited by butchie on Sun Dec 06, 2009 10:23 am; edited 1 time in total
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3256

PostPosted: Sat Dec 05, 2009 11:26 pm    Post subject: Reply with quote

Code:
rmmod vboxdrv
modprobe vboxdrv
:?:
Or maybe your virtualbox-modules didn't compile properly?

It is runnign fine here. Though I am using zen-sources-2.6.31_p6
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde5 | e is unstable :-/
Back to top
View user's profile Send private message
psutokth
Tux's lil' helper
Tux's lil' helper


Joined: 03 Apr 2005
Posts: 121
Location: Lake Champlain

PostPosted: Sat Dec 05, 2009 11:33 pm    Post subject: Reply with quote

I got a similar problem because I upgraded the kernel at the same time, so the modules were built against the new kernel that I wasn't running yet or something like that. Make sure the modules are built against the symlinked kernel and that's the one you're using when loading them.
Back to top
View user's profile Send private message
butchie
n00b
n00b


Joined: 13 Oct 2004
Posts: 48

PostPosted: Sat Dec 05, 2009 11:36 pm    Post subject: Reply with quote

Thanks but no, rmmod then modprobe vboxdrv then the others didn't work.

I just emerged again virtualbox-modules without errors but the modules still don't load

The kernel being used is the current symlinked one.
Back to top
View user's profile Send private message
butchie
n00b
n00b


Joined: 13 Oct 2004
Posts: 48

PostPosted: Sun Dec 06, 2009 10:21 am    Post subject: Reply with quote

OK, I updated my kernel to gentoo-sources-2.6.32, re emerged the modules and it is now working.
Back to top
View user's profile Send private message
psutokth
Tux's lil' helper
Tux's lil' helper


Joined: 03 Apr 2005
Posts: 121
Location: Lake Champlain

PostPosted: Sun Dec 06, 2009 1:26 pm    Post subject: Reply with quote

Hmm, I wonder what the problem was. It is working for me with gentoo sources 2.6.31-r6.
Back to top
View user's profile Send private message
butchie
n00b
n00b


Joined: 13 Oct 2004
Posts: 48

PostPosted: Mon Dec 07, 2009 10:44 pm    Post subject: Reply with quote

Yes, I should have recompiled my kernel without upgrading, but too late...
Maybe I have upgraded some libs or gcc during one emerge -uD world but didn't noticed any problems until then.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum