Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Portage] Je me perds dans les dépendances multiples
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
gbetous
l33t
l33t


Joined: 15 Jan 2004
Posts: 679
Location: Toulouse

PostPosted: Wed Dec 16, 2009 5:09 pm    Post subject: [Portage] Je me perds dans les dépendances multiples Reply with quote

Arglll... help !

Depuis une belle mise à jour (style plusieurs mois que j'avais meme pas fait un sync), je n'arrive plus à stabiliser portage.

Voici ce que j'ai (entre autre) :

Code:

x11-proto/xf86vidmodeproto:0

  ('ebuild', '/', 'x11-proto/xf86vidmodeproto-2.2.2', 'merge') pulled in by
    x11-proto/xf86vidmodeproto required by ('ebuild', '/', 'kde-base/kfile-4.3.3', 'merge')
    x11-proto/xf86vidmodeproto required by ('ebuild', '/', 'kde-base/libtaskmanager-4.3.3', 'merge')
    x11-proto/xf86vidmodeproto required by ('ebuild', '/', 'kde-base/kdialog-4.3.3', 'merge')       
    (and 74 more)                                                                                   

  ('installed', '/', 'x11-proto/xf86vidmodeproto-2.3', 'nomerge') pulled in by
    >=x11-proto/xf86vidmodeproto-2.3 required by ('installed', '/', 'x11-libs/libXxf86vm-1.1.0', 'nomerge')


Si je regarde l'ebuild de kfile par exemple, je ne vois pas pourquoi il refuserait de passer avec un xf86vidmodeproto-2.3.

Une idée ?

Merci !
_________________
Core2Quad Q6600
ASUS P5B-V (i965 video intégrée)
~amd64 / KDE
Back to top
View user's profile Send private message
gbetous
l33t
l33t


Joined: 15 Jan 2004
Posts: 679
Location: Toulouse

PostPosted: Sat Dec 19, 2009 9:25 am    Post subject: Reply with quote

Personne ? :cry:
_________________
Core2Quad Q6600
ASUS P5B-V (i965 video intégrée)
~amd64 / KDE
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Sat Dec 19, 2009 9:52 am    Post subject: Reply with quote

Le problème c'est pas kfile par exemple.
C'est x11-libs/libXxf86vm qui exige au moins x11-proto/xf86vidmodeproto-2.3, alors que x11-proto/xf86vidmodeproto-2.2.2est installé.


Essaye de supprimer x11-proto/xf86vidmodeproto-2.2.2, puis de relancer la mise à jour. Les dépendances de la mise à jour devraient réinstaller x11-proto/xf86vidmodeproto-2.3 cette fois
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
gbetous
l33t
l33t


Joined: 15 Jan 2004
Posts: 679
Location: Toulouse

PostPosted: Sat Dec 19, 2009 6:14 pm    Post subject: Reply with quote

Bin non, je ne pense pas que ce soit ça le problème.

Code:

coyote ~ # emerge -Cp x11-proto/xf86vidmodeproto

>>> These are the packages that would be unmerged:

 x11-proto/xf86vidmodeproto
    selected: 2.3
   protected: none
     omitted: none

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.


xf86vidmodeproto-2.2.2 n'est pas installé.

D'après ce que je comprends du message d'erreur, c'est kfile qui appelle la version 2.2.2 ("pulled in by")...
_________________
Core2Quad Q6600
ASUS P5B-V (i965 video intégrée)
~amd64 / KDE
Back to top
View user's profile Send private message
Kazuya
Apprentice
Apprentice


Joined: 09 Jul 2006
Posts: 256

PostPosted: Sat Dec 19, 2009 6:31 pm    Post subject: Reply with quote

Hello,
bah ça serait étonnant que kfile demande une version spécifique de xf86vidmodproto:
qdepends kfile wrote:

kde-base/kfile-4.3.4: >=dev-util/cmake-2.6.2-r1 >=sys-apps/findutils-4.4.0 dev-util/pkgconfig >=x11-libs/libXtst-1.1.0 <x11-proto/xextproto-7.1.0 x11-proto/xf86vidmodeproto dev-lang/perl >=x11-libs/qt-core-4.5.1:4[qt3support,ssl] >=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] >=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] >=x11-libs/qt-script-4.5.1:4 >=x11-libs/qt-sql-4.5.1:4[qt3support] >=x11-libs/qt-svg-4.5.1:4 >=x11-libs/qt-test-4.5.1:4 x11-libs/libXext x11-libs/libXt x11-libs/libXxf86vm >=kde-base/kdelibs-4.3.4[-kdeprefix] >=kde-base/libknotificationitem-4.3.4[-kdeprefix] >=kde-base/qimageblitz-0.0.4

Tu remarqueras que xf86vidmodproto figure parmi les dépendances, mais il n'y a pas de numéro de version précisé (et pas de "<=" qui le précède notamment)

Non je pense plutôt que le problème, si tu es bien en gentoo STABLE, et bien tu as des ebuilds qui réclame la version 2.3 et portage qui veut garder la version stable 2.2.2 pour les autres ebuilds ayant xf86vidmodeproto en dépendance... bref je ne sais pas trop si je suis claire (ben non moi c'est Kazuy' :)) en gros essais de masquer les versions inférieurs à la 2.3 et tu ne devrais plus avoir de soucis ^^
Quote:

echo "<x11-proto/xf86vidmodeproto-2.3" >> /etc/portage/package.mask

_________________
Hacker vaillant, rien d'impossible !!!
"Quand une vache boit de l'eau, cette eau devient du lait. Quand un serpent boit de l'eau, cette eau devient du poison."


Last edited by Kazuya on Sun Dec 20, 2009 10:55 am; edited 1 time in total
Back to top
View user's profile Send private message
gbetous
l33t
l33t


Joined: 15 Jan 2004
Posts: 679
Location: Toulouse

PostPosted: Sun Dec 20, 2009 8:00 am    Post subject: Reply with quote

Ok, je vois ce que tu veux dire.

Mais c'est de ma faute, je me suis un peu perdu dans les ~x86. En effet je veux garder une Gentoo stable, mais parfois je prends despaquages en ~x86, je mets les dependances à l'arrache (c'est à dire sans mettre la version explicitement), et du coup je me trimballe un fichier packages.keywords pourri.

Je craque, je vire tout, je tente de reprendre la main sur mon système.

Au menu :
- suppression (avec backup, je rassure) des fichiers mask et keywords
- emerge -auDN system
- emerge -auDN world
- revdep-rebuild
_________________
Core2Quad Q6600
ASUS P5B-V (i965 video intégrée)
~amd64 / KDE
Back to top
View user's profile Send private message
Kazuya
Apprentice
Apprentice


Joined: 09 Jul 2006
Posts: 256

PostPosted: Sun Dec 20, 2009 11:05 am    Post subject: Reply with quote

Hello,
arf, ben non, pas pour si peu :\
En fait le seul truc c'est que tu masques la version inférieur à la 2.3 de xf86vidmodproto et voilà, problème réglé...
En fait il n'y a pas beaucoup d'ebuilds qui réclament une version supérieur ou égale à la 2.3 de xf86vidmodeproto, tu peux le constater avec
Quote:

#equery d xf86vidmodeproto


Personnellement je trouve:
Quote:

x11-base/xorg-server-1.7.3.901-r1 (>=x11-proto/xf86vidmodeproto-2.2.99.1)
x11-libs/libXxf86vm-1.1.0 (>=x11-proto/xf86vidmodeproto-2.3)

Mais après je suis en full ~
_________________
Hacker vaillant, rien d'impossible !!!
"Quand une vache boit de l'eau, cette eau devient du lait. Quand un serpent boit de l'eau, cette eau devient du poison."
Back to top
View user's profile Send private message
gbetous
l33t
l33t


Joined: 15 Jan 2004
Posts: 679
Location: Toulouse

PostPosted: Mon Dec 21, 2009 8:54 pm    Post subject: Reply with quote

Trop tard !

Je suis assez fier de mon nettoyage... ça faisait bcp trop longtemps que j'avais rien fait (bien 2 ans mon installation), et l'entropie devenait trop grande. 8)

Je repars sur des bases plus seines :wink:
_________________
Core2Quad Q6600
ASUS P5B-V (i965 video intégrée)
~amd64 / KDE
Back to top
View user's profile Send private message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1552
Location: Madinina

PostPosted: Thu Dec 24, 2009 1:45 am    Post subject: Reply with quote

Salut

J'ai tjrs eu une gentoo en testing depuis le début et je dois dire que j'ai rarement des problèmes, je pense que tous ceux qui sont en ~ confirmeront ...
_________________
Get Up and Go !
Back to top
View user's profile Send private message
Kazuya
Apprentice
Apprentice


Joined: 09 Jul 2006
Posts: 256

PostPosted: Thu Dec 24, 2009 12:40 pm    Post subject: Reply with quote

Hello,
Je confirme :) .
_________________
Hacker vaillant, rien d'impossible !!!
"Quand une vache boit de l'eau, cette eau devient du lait. Quand un serpent boit de l'eau, cette eau devient du poison."
Back to top
View user's profile Send private message
nemo13
Veteran
Veteran


Joined: 08 Oct 2004
Posts: 1016
Location: France/Istres

PostPosted: Thu Dec 24, 2009 1:14 pm    Post subject: Reply with quote

moi itou :P

et je pousse même le vice à le faire sur un HP Z600 tout neuf pour le TAF.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7937
Location: ~Brussels - Belgique

PostPosted: Thu Dec 24, 2009 2:04 pm    Post subject: Reply with quote

Idem.

Les seules instabilités que j'ai eues étaient à cause de CFLAGS ou LDFLAGS un peu trop agressifs (récemment, avec "--as-needed"). Retour à la normale, tout est parfait :)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Tom_
Guru
Guru


Joined: 20 May 2004
Posts: 384
Location: France

PostPosted: Thu Dec 24, 2009 3:35 pm    Post subject: Reply with quote

Avoir "--as-needed" en LDFLAGS ne pose pas de problème avec la majorité des applications. Ca fait un moment que je n'ai plus eu de problème avec ce flag!

C'est sûr que si tu as "--as-needing" forcé direct dans GCC (cf le blog du dev Flameeyes), c'est autre chose! :lol:
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7937
Location: ~Brussels - Belgique

PostPosted: Fri Dec 25, 2009 10:19 pm    Post subject: Reply with quote

Aucune idée. Je viens de tout recompiler sans --as-needed, et tout est hyper stable : avant, ça segfaultait après hibernation, crash du wifi, ...
Maintenant, tout est stable.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum