Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Titanium powerbook display issues
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
therealjrd
Tux's lil' helper
Tux's lil' helper


Joined: 18 May 2006
Posts: 103

PostPosted: Thu Dec 17, 2009 10:51 pm    Post subject: Titanium powerbook display issues Reply with quote

I have a Tibook with an ATI Mobility L6 LY display controller. Until a couple of months ago I was running gentoo on it just fine. The disk died, I replaced it, and have gotten around to trying to get gentoo running again.

In the intervening time it looks like stuff has changed. It's now emerging what appears to be newer combinations of drivers and X. Perhaps due to that, or something else, I can't get X to start at all. My initial forays had it dying right off the bat failing to open the fb. I've now found a combination of kernel build options and stuff which doesn't die right away, but it's still not right, when I startx, the screen flashes white, then does this sort of bloom from the center out to the edges, looking like it's overloaded. I'm told that's a sign that something's badly amiss, and I can fry the hardware if it does that, so I don't let it run when it does that, kill it.

Anybody got a working config for a system like this?

Modern portage tree (up to about a week ago)
kernel 2.6.31-gentoo-r6
profile default/linux/powerpc/ppc32/10.0
xorg-server-1.6.3.901-r2
xorg-drivers-1.6
xf86-video-ati-6.12.4

Thanks in advance...
Back to top
View user's profile Send private message
therealjrd
Tux's lil' helper
Tux's lil' helper


Joined: 18 May 2006
Posts: 103

PostPosted: Tue Dec 22, 2009 10:39 pm    Post subject: Reply with quote

It turns out that this due to a bug in the ati driver. For some reason on this platform it guesses wrong about the screen size, and everything falls over from there.

I have a patch from upstream. It's not clear that this addresses the whole problem, but there are other issues with this system (mouse/trackpad currently not working, no idea why) so it's hard to tell. I'll post back here again when I get it sorted out.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum