Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KVM Umstellung im Portage
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Fri Dec 18, 2009 2:11 pm    Post subject: KVM Umstellung im Portage Reply with quote

Hallo,

nachdem heute mein KVM von der Version 88.1 auf 11.1 upgedated wurde fehlt mir natürlich das /usr/bin/kvm.

Nachdem ich neue virtuelle Maschinenkonfigurationen mit dem Virt-manager erstellt habe. Starten die meisten VM auch wieder. Allerdings nicht alle. Außerdem schnarchlangsam.
Vermutlich wird das kvm-intel Modul nicht benutzt. Wie kann man das checken?

Ist diese 11.1 Version älter als die 88.1 Version? Wer kann helfen?

G. R.
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4459

PostPosted: Fri Dec 18, 2009 2:57 pm    Post subject: Reply with quote

die 88.1 version ist eine devel version sprich neuer. Scheinbar sind die ebuilds für die devel version von den kvm userland tools aus portage rausgeflogen.
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Fri Dec 18, 2009 7:04 pm    Post subject: Reply with quote

firefly wrote:
die 88.1 version ist eine devel version sprich neuer. Scheinbar sind die ebuilds für die devel version von den kvm userland tools aus portage rausgeflogen.


Da die angelegten virtuellen Maschinen mit qemu-system nicht laufen und spätestens nach dem 2. Neustart nicht mehr starten, habe ich nun das alte ebuild ins locale Overlay gepackt, die Geschichte mit den Kernelmodulen herausgelöscht, im virt-manager neu eingeichtet. Jetzt läuft es wieder in gewohnter Schnelligkeit.
Sorry keine Zeit im Moment ;-).

G. R.
Back to top
View user's profile Send private message
schmutzfinger
Veteran
Veteran


Joined: 26 Oct 2003
Posts: 1287
Location: Dresden/Germany

PostPosted: Fri Dec 18, 2009 8:09 pm    Post subject: Reply with quote

0.11.1 ist die Versionsnummer von qemu, der jetzt anscheinend kvm direkt unterstützt. Früher kam kvm mit einem leicht veränderten qemu. Die Änderungen sind jetzt zurückgeflossen. Das binary ist jetzt /usr/bin/qemu. Das kvm-Modul ist schon lange im Linux-Kern und kann auch dort angeschaltet werden. Soweit ich das sehe gibts aber "app-emulation/kvm-kmod" auch noch, ist aber maskiert.
Also eigentlich musst du nur im Kern das Modul mitbauen und statt "kvm" "qemu" starten. Und das im virt-manager umstellen. Wenn eine VM kein kvm benutzt, dann sagt qemu das beim start. Wenn die Kiste schon läuft kann man im qemu-monitor nachfragen. Im SDL-Fenster wäre das "strg-alt-2" und dann "info kvm".
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Sun Dec 20, 2009 10:01 am    Post subject: Reply with quote

schmutzfinger wrote:
0.11.1 ist die Versionsnummer von qemu, der jetzt anscheinend kvm direkt unterstützt. Früher kam kvm mit einem leicht veränderten qemu. Die Änderungen sind jetzt zurückgeflossen. Das binary ist jetzt /usr/bin/qemu. Das kvm-Modul ist schon lange im Linux-Kern und kann auch dort angeschaltet werden. Soweit ich das sehe gibts aber "app-emulation/kvm-kmod" auch noch, ist aber maskiert.
Also eigentlich musst du nur im Kern das Modul mitbauen und statt "kvm" "qemu" starten. Und das im virt-manager umstellen. Wenn eine VM kein kvm benutzt, dann sagt qemu das beim start. Wenn die Kiste schon läuft kann man im qemu-monitor nachfragen. Im SDL-Fenster wäre das "strg-alt-2" und dann "info kvm".


Hallo,

danke für Deine Antwort.
Leider funktioniert es so leider nicht. Im englischen Teil des Forums gibt es dazu ein paar Threads.

1. Also diese Qemu Version kann mit den KVM Images nichts anfangen.
2. Beim Virt-manager ist die Virtuelle Konsole nicht zu erreichen.
3. das kvm-kmod muß per USE "ausgeschaltet" werden, da das im Kernel "beiliegende" problemloser funktioniert.
4. das Kernelmodul wird leider von dieser qemu Version (die hier installiert wird) nicht benutzt...deshalb sind die VM schnarchlangsam ;-)

Deshalb bleibe ich zunächst beim letzten KVM ebuild.
Nur leider will Portage jedesmal das KVM_qemu ebuild installieren...

G. R.
Back to top
View user's profile Send private message
Evildad
Guru
Guru


Joined: 15 Apr 2004
Posts: 475

PostPosted: Sun Dec 20, 2009 10:16 am    Post subject: Reply with quote

Hi,

ich hab die quick and dirty Variant gemacht.
Einfch einen symbolischen Link erstellt und schon hats wieder getan :-)

Grüsse
Back to top
View user's profile Send private message
js08
n00b
n00b


Joined: 04 Mar 2008
Posts: 45

PostPosted: Mon Dec 21, 2009 11:02 am    Post subject: Reply with quote

Tinitus wrote:


danke für Deine Antwort.
Leider funktioniert es so leider nicht. Im englischen Teil des Forums gibt es dazu ein paar Threads.

1. Also diese Qemu Version kann mit den KVM Images nichts anfangen.
2. Beim Virt-manager ist die Virtuelle Konsole nicht zu erreichen.
3. das kvm-kmod muß per USE "ausgeschaltet" werden, da das im Kernel "beiliegende" problemloser funktioniert.
4. das Kernelmodul wird leider von dieser qemu Version (die hier installiert wird) nicht benutzt...deshalb sind die VM schnarchlangsam ;-)

Deshalb bleibe ich zunächst beim letzten KVM ebuild.
Nur leider will Portage jedesmal das KVM_qemu ebuild installieren...

G. R.


also ich hatte die probleme nicht, ich musste lediglich bei meinen start-skripten kvm durch qemu ersetzen.
am anfang hatte ich die grössten bedenken, dass meine mittels vde gerouteten virtuellen maschinen nimmer laufen, aber s'war alles problemlos (RAW-images und eigentlich schon immer das aktuellste kernel-module)
_________________
Train Hard Or Don't Train At All
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum