Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Probleme bei "emerge portage"
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Heavensdoor
n00b
n00b


Joined: 15 Dec 2003
Posts: 17

PostPosted: Sun Dec 27, 2009 1:30 am    Post subject: Probleme bei "emerge portage" Reply with quote

Hallo zusammen,

ich habe mich heute etwas mit Gentoo und meinem NAS beschäftigt. Das NAS selbst hat ein eigenes Linux, welches jedoch in seiner Leistung recht geschnitten ist. Daher habe ich mir eine fertige chroot, welche ca. 1 Jahr alt ist, für das NAS runtergeladen und geupdatet, bzw. ich wollte es.

emerge --sync lief ohne Probleme durch, jedoch gab es mir am Ende die Warnung aus, dass portage selbst doch ein Update gebrauchen könnte.

Quote:

* An update to portage is available. It is _highly_ recommended
* that you update portage now, before any other packages are updated.

* To update portage, run 'emerge portage' now.


Dies hatte ich dann auch gleich mal gestartet und nach Stunden des Wartens gab es bei Update 5 von 6 einen Fehler, welchen ich mir mit einem Halbwissen nicht ganz erklären kann.

Geht dabei wohl um python-2.5.4-r3 und wurde mit folgendem Fehler abgewürgt:

Quote:

creating build/scripts-2.5
copying and adjusting /var/tmp/portage/dev-lang/python-2.5.4-r3/work/Python-2.5.4/Tools/scripts/pydoc -> build/scripts-2.5
copying and adjusting /var/tmp/portage/dev-lang/python-2.5.4-r3/work/Python-2.5.4/Tools/scripts/idle -> build/scripts-2.5
copying and adjusting /var/tmp/portage/dev-lang/python-2.5.4-r3/work/Python-2.5.4/Lib/smtpd.py -> build/scripts-2.5
changing mode of build/scripts-2.5/pydoc from 644 to 755
changing mode of build/scripts-2.5/idle from 644 to 755
changing mode of build/scripts-2.5/smtpd.py from 644 to 755
make: *** [sharedmods] Error 1
*
* ERROR: dev-lang/python-2.5.4-r3 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 4361: Called die
* The specific snippet of code:
* emake || die "emake failed"
* The die message:
* emake failed
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/dev-lang/python-2.5.4-r3/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-lang/python-2.5.4-r3/temp/environment'.
*


Den kompletten Log könnt ihr hier finden:
http://www.lostspecies.com/gentoo/build.log
http://www.lostspecies.com/gentoo/environment.log

Wäre die Frage, ob mir jemand sagen könnte, wo ich das Problem suchen kann. Komme mit der Fehlermeldung überhaupt nicht weiter :(
Back to top
View user's profile Send private message
r3tep
Tux's lil' helper
Tux's lil' helper


Joined: 10 Sep 2005
Posts: 108

PostPosted: Sun Dec 27, 2009 12:48 pm    Post subject: Reply with quote

Deinem Log entnehme ich, dass Du ARM als Architektur einsetzt.

Evtl. findest Du im Forum für andere Architekturen eher Hilfe: https://forums.gentoo.org/viewforum-f-32.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum