Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kernel-Konfiguration von genkernel "anschauen"
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
LED
n00b
n00b


Joined: 27 Dec 2009
Posts: 2

PostPosted: Sun Dec 27, 2009 7:23 pm    Post subject: Kernel-Konfiguration von genkernel "anschauen" Reply with quote

Hallo zusammen,

Ich habe bei mir Gentoo erfolgreich installiert, indem ich genkernel benutzt habe.
Nun wollte ich aber meinen Kernel selber konfigurieren. Mein selber konfigurierter Kernel fährt aber nicht hoch, sondern stoppt mit der Fehlermeldung:

"VFS: Cannot open root device "hda3" or unknown-block(0,0)"
"Please append a correct "root=" boot option here are the available partitions:"
"Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)"

Da Gentoo mit genkernel funktioniert (mit der gleichen fstab) gehe ich davon aus, dass den richtigen IDE-Treiber nicht reinkompiliert habe. Richtig oder Blödsinn?
Wie kann ich bei meinem laufenden Gentoo rauskriegen, welche Treiber gerade benutzt werden?

Schönen Abend,
Martin
Back to top
View user's profile Send private message
andi_s
Apprentice
Apprentice


Joined: 10 Feb 2005
Posts: 226
Location: Germany

PostPosted: Sun Dec 27, 2009 9:23 pm    Post subject: Re: Kernel-Konfiguration von genkernel "anschauen" Reply with quote

LED wrote:

1. "VFS: Cannot open root device "hda3" or unknown-block(0,0)"
"Please append a correct "root=" boot option here are the available partitions:"
"Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)"

2. Wie kann ich bei meinem laufenden Gentoo rauskriegen, welche Treiber gerade benutzt werden?


hallo,

zu 1.: kommt mir bekannt vor: https://forums.gentoo.org/viewtopic-t-791168-highlight-.html

zu 2.: mit
Code:
lsmod
kannst du dir anzeigen lassen, welche module geladen wurden, allerdings wuerde ich dir auch mal
Code:
lspci
empfehlen. damit kannst du dir anschauen, welche hardware dein system hat und danach solltest du dann die entsprechenden treiber (sofern vorhanden) ins kernel aufnehmen.

ich hoffe ich konnte helfen.
Back to top
View user's profile Send private message
LED
n00b
n00b


Joined: 27 Dec 2009
Posts: 2

PostPosted: Mon Dec 28, 2009 1:58 pm    Post subject: Reply with quote

Dankeschööön!!!

lsmod hat mich weitergebracht. Dadurch habe ich gefunden, dass in der SCSI-Abteilung ganze vier Sterne /Haken fehlen. Gentoo fährt jetzt hoch. Jetzt darf ich Schritt für Schritt die vorsorglich gesetzten Sterne wieder rausnehmen...

Problem gelöst, Danke!
Back to top
View user's profile Send private message
andi_s
Apprentice
Apprentice


Joined: 10 Feb 2005
Posts: 226
Location: Germany

PostPosted: Mon Dec 28, 2009 2:47 pm    Post subject: Reply with quote

kp - haeng bitte immer noch ein [solved] oder (geloest) an den titel, wenn ein thema erledigt ist - danke.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum