Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
app-emulation/emul-linux-x86-gtklibs-20081109 ohne libpixman
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
XMath
Guru
Guru


Joined: 14 Aug 2004
Posts: 435
Location: Germany, Gaimersheim

PostPosted: Sun Dec 27, 2009 7:55 pm    Post subject: app-emulation/emul-linux-x86-gtklibs-20081109 ohne libpixman Reply with quote

Hallo,
habe soeben einige Zeit damit zugebracht meinen nspluginwrapper wieder ans Laufen zu bringen:

Code:
/usr/lib64/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: libpixman-1.so.0: cannot open shared object file: No such file or directory


Das Ganze führt bei einem
Code:
revdep-rebuild

zu folgendem Paket
Code:
app-emulation/emul-linux-x86-gtklibs-20081109


Allerdings
Code:
ldd /usr/lib32/libcairo.so.2
        linux-gate.so.1 =>  (0xf7fc9000) 
        libfreetype.so.6 => /usr/lib32/libfreetype.so.6 (0xf7ec2000)
        libz.so.1 => /lib32/libz.so.1 (0xf7eae000)                 
        libfontconfig.so.1 => /usr/lib32/libfontconfig.so.1 (0xf7e82000)
        libpng12.so.0 => /usr/lib32/libpng12.so.0 (0xf7e5e000)         
        libXrender.so.1 => /usr/lib32/libXrender.so.1 (0xf7e53000)     
        libX11.so.6 => /usr/lib32/libX11.so.6 (0xf7d39000)             
        libpixman-1.so.0 => not found                                   
        libm.so.6 => /lib32/libm.so.6 (0xf7d13000)                     
        libc.so.6 => /lib32/libc.so.6 (0xf7bd0000)                     
        libexpat.so.1 => /usr/lib32/libexpat.so.1 (0xf7ba9000)         
        libxcb.so.1 => /usr/lib32/libxcb.so.1 (0xf7b90000)             
        libXau.so.6 => /usr/lib32/libXau.so.6 (0xf7b8c000)             
        libXdmcp.so.6 => /usr/lib32/libXdmcp.so.6 (0xf7b86000)         
        libdl.so.2 => /lib32/libdl.so.2 (0xf7b82000)                   
        /lib/ld-linux.so.2 (0xf7fca000)


Was mir nun geholfen hat war ein älteres emul-linux-x86-gtklibs zu installieren.

Nur frage ich mich, ob da dann nicht die 32bit-Version von libpixman fehlt?
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4459

PostPosted: Sun Dec 27, 2009 8:06 pm    Post subject: Reply with quote

also bei mir ist die libpixman-1.so in dem paket app-emulation/emul-linux-x86-xlibs enthalten. welches auch von nspluginwrapper als abhängigkeit angegeben ist.
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
XMath
Guru
Guru


Joined: 14 Aug 2004
Posts: 435
Location: Germany, Gaimersheim

PostPosted: Sun Dec 27, 2009 8:36 pm    Post subject: Reply with quote

Hi,
danke für den super Hinweis.

app-emulation/emul-linux-x86-xlibs-20081109 scheint libpixman zu enthalten.

Mit app-emulation/emul-linux-x86-xlibs-20091226 fehlt libpixman-1.so.0.

Welche Version hast du installiert?
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4459

PostPosted: Sun Dec 27, 2009 10:19 pm    Post subject: Reply with quote

die stabil im portage vorhandene version
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum