Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Übles Schriftbild beim Drucken
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
oscarwild
l33t
l33t


Joined: 15 Jul 2003
Posts: 857
Location: Memmingen, Germany, Old Europe, Earth

PostPosted: Tue Dec 29, 2009 12:50 pm    Post subject: Übles Schriftbild beim Drucken Reply with quote

Hallo,


seit einer Weile weisen Textdokumente, die ich mit bestimmten Applikationen ausdrucke, ein ziemlich übles Schriftbild auf, die Abstände zwischen den einzelnen Zeichen sind z.T. viel zu breit oder zu eng. Das Wort "auseinandersetzen" sieht ähnlich aus wie "a us e ina nd e rs e tz e n", wobei die Buchstaben "rs" ineinander fließen.

Davon betroffene Applikationen sind z.B. Firefox und Konqueror, nicht jedoch OpenOffice. Das Drucksystem (CUPS) und den Druckertreiber schließe ich eigentlich aus, denn das gleiche Problem tritt auch auf, wenn ich in eine Postscript- oder PDF-Datei drucke.

Da ich in letzter Zeit nicht viel zuhause drucke, kann ich leider nicht sagen, wann oder wodurch der Effekt ausgelöst wurde. Die letzte größere Aktion auf meinem System war vor wenigen Wochen die Umstellung von KDE3 auf KDE4.

Kennt jemand das Problem (und vielleicht auch noch die passende Lösung dazu)?


Gruß + Danke im Voraus
OscarWild
_________________
http://blog.selbsthilfenetzwerk-cannabis-medizin.de
Back to top
View user's profile Send private message
Hollowman
Guru
Guru


Joined: 19 Apr 2007
Posts: 584

PostPosted: Tue Dec 29, 2009 3:56 pm    Post subject: Reply with quote

Hi

Da sind die Schriftarten scheiße eingestellt oder es fehlen ein paar. Bau doch ma die Anwendungen neu bei denen es so ist.

Sebastian
Back to top
View user's profile Send private message
boris64
Veteran
Veteran


Joined: 04 Oct 2003
Posts: 1770
Location: vechelde / peine

PostPosted: Tue Dec 29, 2009 4:25 pm    Post subject: Reply with quote

Ich habe ein ähnliches (oder gar das gleiche) Problem.
Das Ganze tritt nachvollziehbar auf, wenn ich PDF-Dateien mit den
KDE-Programmen ausdrucke, wobei der Ausdruck dann eigentlich
nicht zu gebrauchen ist.
Bisherige Abhilfe war es dann, einfach den "Acrobat Reader" zu benutzen.
Sieht zwar potthässlich aus, druckt aber einwandfrei.

Wenn jemand da eine _echte_ Lösung parat hat, so möge er sprechen ;)
_________________
boris64.net 200x / visit my desktop / try these tiny kernel patches ;)
Back to top
View user's profile Send private message
oscarwild
l33t
l33t


Joined: 15 Jul 2003
Posts: 857
Location: Memmingen, Germany, Old Europe, Earth

PostPosted: Sat Jan 02, 2010 12:18 pm    Post subject: Reply with quote

Also neu bauen hilft leider nicht.
An den Schriftarten sollte es eigentlich auch nicht liegen - am Bildschirm wird ja alles korrekt dargestellt, nur auf dem Drucker, bzw. in einem PDF-Dokument nicht.
Auch hilft es bei mir nicht, ein erzeugtes PDF mit dem Acrobat Reader zu drucken, das Druckergebnis ist das gleiche.
_________________
http://blog.selbsthilfenetzwerk-cannabis-medizin.de
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2042
Location: My own world! I and Gentoo!

PostPosted: Sat Jan 02, 2010 12:21 pm    Post subject: Reply with quote

Dann muss es eigentlich an cups liegen...
Das der die Druckaufträge bekommt und falsch weiterverarbeitet.
Oder das etwas am Druckerkabel nicht in Ordnung ist... Obwohl, Parallel-Port war gestern, bei USB würde dann einfach garnichtsmehr gehn.
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
Hollowman
Guru
Guru


Joined: 19 Apr 2007
Posts: 584

PostPosted: Sat Jan 02, 2010 1:46 pm    Post subject: Reply with quote

Könnt ihr ma bitte gucken mit wie viel DBI ihr druckt? Nicht das da was verstellt ist.

Sebastian
Back to top
View user's profile Send private message
oscarwild
l33t
l33t


Joined: 15 Jul 2003
Posts: 857
Location: Memmingen, Germany, Old Europe, Earth

PostPosted: Sat Jan 02, 2010 6:38 pm    Post subject: Reply with quote

Cups hatte ich als erstes im Verdacht, aber wenn ich cupsd anhalte, kann ich immer noch direkt in eine Datei drucken (Postscript oder PDF). Und auch die hat das selbe Problem. Als Beispiel ein auf diese Weise erstelltes PDF auf diesem Link.
Die DPI-Einstellung passt, ein Fehler daran würde sich aber einer erkennbaren Rasterung, nicht aber an falschen Zeichenabständen widerspiegeln.

Ich vermute, dass beim Drucken die Schriftarten ersetzt werden, und dabei ein Problem auftritt. Welches Subsystem ist dafür verantwortlich?
_________________
http://blog.selbsthilfenetzwerk-cannabis-medizin.de
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum