Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2010! Ein neues Jahr - Eine neue Distribution
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Borki
n00b
n00b


Joined: 01 Jan 2010
Posts: 6

PostPosted: Fri Jan 01, 2010 8:51 am    Post subject: 2010! Ein neues Jahr - Eine neue Distribution Reply with quote

Einen wunderschönen guten Morgen und ein frohes neues Jahr! ;-)

Bevor ich meine Frage formuliere hier erstmal einige Grundkenntnisse die ich besitze :) - Angefangen habe ich mit Ubuntu Linux (Einsteigerdistribution Nummer #1). Nachdem ich mir das System durch zu viele Fremdquellen (Man sollte die Warnungen im Wiki nicht überlesen) zusammengeschossen habe, entschließ ich mich mein Glück mit Archlinux zu versuchen. Dank des gut geführten Wiki war es auch kein Problem, und so baute ich mir von Tag zu Tag mehr Kenntnisse bezüglich Linux auf. Aber ich habe Lust auf etwas Neues, noch aufregenderes und nach langer Recherche stich mir Gentoo ins Auge.

Nun zu meiner Frage.
Das Gentoo Wiki ist einfach nur Top. Alles schön dokumentiert und ich habe mir die 117 Seiten Installationsanleitung ausgedruckt und bin nun bereit für die Installation.

Doch was muss ich alles beachten, ich wünsche mir ein reines Gnome System und würde gerne den Unstable Zweig verwenden, da ich auch fleißig Bugs melde/berichte, und somit hoffe, bei der Entwicklung etwas beizutragen.

Ich habe nur leider das mit den USEFlags noch nicht ganz verstanden. Für jede Hilfe und Anlaufstelle (Wikiseite, Blog,...) wäre ich euch sehr dankbar.

Hoffentlich ist dieser Beitrag nicht zu lange :-) Vielen Dank schonmal im Voraus! =)

Mit freundlichen Neujahrsgrüßen,

Borki :)

P.S.
Ich würde Gentoo gerne auf einem Intel Atom N270 (Samsung NC10) und einem Intel Quad Core aufsetzen, und hoffe, dass dies ohne Problem verlaufen wird!
Back to top
View user's profile Send private message
STiGMaTa_ch
Veteran
Veteran


Joined: 28 Dec 2004
Posts: 1686
Location: Rüti ZH / Schweiz

PostPosted: Fri Jan 01, 2010 10:14 am    Post subject: Re: 2010! Ein neues Jahr - Eine neue Distribution Reply with quote

Auch dir ein gutes neues Jahr Borki

Borki wrote:
Ich habe nur leider das mit den USEFlags noch nicht ganz verstanden. Für jede Hilfe und Anlaufstelle (Wikiseite, Blog,...) wäre ich euch sehr dankbar.

Das mit den USE Flags funktioniert so.

Wenn du ein Paket aus den Sourcen kompilierst, hast du normalerweise diverse Optionen welche du einkompilieren kannst oder eben nicht. So gibt es z.B. Programme die du für die Nutzung unter der Shell sowie unter X verwenden kannst. Willst du das Programm nur in der Shell verwenden, würdest du den Support für X nun deaktivieren (z.B. ./configure --disable-X). Die USE Flags bilden nun genau diese Möglichkeit ab, lösen aber auch benötigte Abhängigkeiten für dich auf. Solltest du z.B. ein Programm mit SSL Unterstützung kompilieren wollen müsstest du von Hand erst die richtigen Libraries herunterladen, kompilieren und installieren.

Bei Portage reicht es aus, wenn du die USE Flag ssl setzt. Dadurch wird dein Programm mit ssl Unterstützung kompiliert (analog zu ./configure --enable-ssl) und falls die ssl Libraries noch nicht vorhanden sind werden diese zuerst heruntergeladen und kompiliert.

Borki wrote:
Ich würde Gentoo gerne auf einem Intel Atom N270 (Samsung NC10) und einem Intel Quad Core aufsetzen, und hoffe, dass dies ohne Problem verlaufen wird!

Ach, Probleme wirst du sicher haben... Aber dafür gibt es ja das Forum. Da fragst du dann einfach nach.

Lieber Gruss
STiGMaTa
_________________
Ich bin Schuldknappe. Das bedeutet ich bin immer an allem Schuld. Und das nicht zu knapp! | Der alltägliche Familienwahnsinn auf meinem BLOG
Back to top
View user's profile Send private message
Borki
n00b
n00b


Joined: 01 Jan 2010
Posts: 6

PostPosted: Fri Jan 01, 2010 10:48 am    Post subject: Re: 2010! Ein neues Jahr - Eine neue Distribution Reply with quote

Erstmal vielen Dank für die Aufklärung :) Das heißt, jedes Gentoo System wird durch die USE Flags-Variablen individuell? (genau wie bei Arch :) )
Nun gut, ich habe mir jetzt erstmal die minimal install cd heruntergeladen und werde gleich mit der Installation anfangen (Das Abenteuer Gentoo kann beginnen :lol: )

Dürfte ich dir noch eine Frage stellen? :oops:

Gibt es schon vordefinierte USE Flags, die ich bei einer reinen Gnome Installation (Automount, ntfs und alle File-Systeme support) verwenden kann, oder muss ich sie mir einzeln zusammensuchen und eintragen?) - Beziehungsweise welche Desktopumgebung kannst du mir empfehlen?

Liebe Grüße,

Borki
Back to top
View user's profile Send private message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1105
Location: Schwabenländle

PostPosted: Fri Jan 01, 2010 11:36 am    Post subject: Re: 2010! Ein neues Jahr - Eine neue Distribution Reply with quote

Borki wrote:
[...] Gibt es schon vordefinierte USE Flags ...


Hier gibt es eine Übesicht über alle USE Flags:

http://gentoo-portage.com/USE

Wenn Du weist, was Du verwenden willst dann kannst Du die global in der /etc/make.conf setzen.

Siehe auch:

http://www.gentoo.de/doc/de/handbook/handbook-x86.xml?part=2&chap=2

http://en.gentoo-wiki.com/wiki/USE_Flags
Back to top
View user's profile Send private message
Borki
n00b
n00b


Joined: 01 Jan 2010
Posts: 6

PostPosted: Fri Jan 01, 2010 2:03 pm    Post subject: Re: 2010! Ein neues Jahr - Eine neue Distribution Reply with quote

Sodala :) Nach einer langen Installationsprozedur bekomme ich schon die erste Fehlermeldung :-/. Grub ist soweit eingerichtet und funktioniert, jedoch erhalte ich während dem Startprozess folgende Fehlermeldung:

>> Mounting root. . .
mount: mounting /dev/sda3 on /newroot failed: Invalid argument
! ! Could not mount specified ROOT, try again
! ! Could not find the root block device in .
Please specify another value or: press Enter for the same, type "shell" for a shell or "q" to skip. . .
root block device() : : _ (Blinkend ^^)

Bei dem System handelt es sich um das Intel Quad Modell :)

Bitte um Rat!

Danke! :)

Liebe Grüße,

Borki
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2042
Location: My own world! I and Gentoo!

PostPosted: Fri Jan 01, 2010 4:05 pm    Post subject: Reply with quote

Hast du genkernel verwendet?
Dann muss in die grub.conf:
Code:
[...]
kernel [...] root=/dev/mem0 real_root=/dev/sda3 [...]
[...]


Falls du den kernel selbstgebaut hast musst du darauf achten den richtigen Treiber für deine IDE/SATA-Controller einzubaun. Was ich sowieso fest einbaun würde wäre der AHCI-Treiber und dann noch für deine IDE/SATA Controller.
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Sat Jan 02, 2010 9:29 am    Post subject: Re: 2010! Ein neues Jahr - Eine neue Distribution Reply with quote

3PO wrote:
Borki wrote:
[...] Gibt es schon vordefinierte USE Flags ...


Hier gibt es eine Übesicht über alle USE Flags:

http://gentoo-portage.com/USE

Wenn Du weist, was Du verwenden willst dann kannst Du die global in der /etc/make.conf setzen.

Erm, er wollte wohl hören "Setz das Desktop-Profil, wie in der Doku beschrieben".
Dass es ein reines Gnome-System wird, geht auch easy:
USE="-kde -qt3 -qt4 gnome gtk" in die make.conf.
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1169
Location: Buchholz/GER

PostPosted: Sun Jan 03, 2010 10:32 am    Post subject: Reply with quote

Hallo borki,
wie ist der Stand der Dinge? Schon weitergekommen?
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
Borki
n00b
n00b


Joined: 01 Jan 2010
Posts: 6

PostPosted: Thu Mar 18, 2010 8:24 pm    Post subject: Reply with quote

Sorry, dass ich erst so spät ein Lebenszeichen von mir gebe. Also, der momentane Stand der Dinge ist einfach weltklasse. Ich habe auf 6 Systemen Gentoo aufgesetzt, und alles funktioniert soweit einwandfrei (sogar dist-cc :) ). Vielen Dank für die Links und die Erklärung, wenn ich zurück denke an das Wissen mit dem ich angefangen habe, und mit dem wo ich heute stehe ist es einfach nur unbeschreiblich "geil" :).

Vielen Dank für eure Hilfe ;-) (and last but not least #gentoo-anfaenger :D)

Liebe Grüße,

Borki

P.S. Ein einziges Problem gibt es noch, aber da bin ich (Gott sei Dank?) nicht der Einzige. CHromium und der lizenzierte h.264 Codec (youtube/html5 / vimeo). Wenn das gelöst ist funktioniert soweit alles einwandfrei (und auch auf opensource ;-) Dann kann ich mich endlich vom Flashplugin verabschieden :) )
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum