Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
x11 overlay questions, and konqueror screen corruption issue
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Sat Jan 02, 2010 3:31 pm    Post subject: x11 overlay questions, and konqueror screen corruption issue Reply with quote

In a final desperate effort to solve some nagging screen corruption problems in konqueror and dolphin (example here: http://img262.imageshack.us/i/snapshot1we.png/ ), I finally tried the x11 overlay with all the 9999 packages about a month ago. This did not fix it, but at times seemed to marginally make it better, but then after a few minutes of use it creeps in again. Dragging the cursor from right to left over the corrupted areas will sometimes remove portions of it, especially over toolbars.

Another example: http://img35.imageshack.us/img35/471/snapshot3l.png

This is on an ~x86 system, with my current qt version being from portage, kde-4.3.4, and 2.6.32 kernels (most recent, but this has been going on for about 2 months now.

Anyway, everything I tried has failed to work. This only happens in Gentoo- Arch, Mandriva, Ubuntu, Pclos, etc. do not have this problem. My questions are:

1. Is there anything to try that I've somehow missed? I've already done many kernels, drivers, xorg-server versions, qt versions, rebuilds of system, world, you name it- I've likely tried it.

2. What's the best way to revert back to the ~x86 portage x11 from the x11 overlay 9999's?

I thought just removing the x11 overlay, and running an emerge -uD @world, or maybe generate a "x11-9999" set, and run emerge -C @x11-9999, with this command, but now I'm not so sure:
Code:
wrc@gentoo ~ $ qlist -sIvC | grep 9999 | xargs -n1 -i echo ={}
=app-text/scrollkeeper-9999-r1                               
=media-fonts/font-util-9999                                   
=media-libs/mesa-9999                                         
=www-client/rekonq-9999                                       
=x11-apps/mesa-progs-9999                                     
=x11-apps/mkfontdir-9999                                     
=x11-apps/mkfontscale-9999                                   
=x11-apps/smproxy-9999                                       
=x11-apps/x11perf-9999                                       
=x11-apps/xcursorgen-9999                                     
=x11-apps/xdriinfo-9999                                       
=x11-apps/xev-9999                                           
=x11-apps/xinit-9999                                         
=x11-apps/xinput-9999                                         
=x11-apps/xkbevd-9999                                         
=x11-apps/xkbutils-9999                                       
=x11-apps/xman-9999                                           
=x11-apps/xrandr-9999                                         
=x11-apps/xvinfo-9999                                         
=x11-apps/xwininfo-9999                                       
=x11-base/xorg-drivers-9999                                   
=x11-base/xorg-server-9999                                   
=x11-drivers/xf86-input-evdev-9999                           
=x11-drivers/xf86-input-keyboard-9999                         
=x11-drivers/xf86-input-mouse-9999                           
=x11-drivers/xf86-input-synaptics-9999                       
=x11-drivers/xf86-video-ati-9999                             
=x11-drivers/xf86-video-intel-9999                           
=x11-libs/cairo-9999                                         
=x11-libs/libFS-9999                                         
=x11-libs/libICE-9999                                         
=x11-libs/libSM-9999                                         
=x11-libs/libX11-9999                                         
=x11-libs/libXScrnSaver-9999                                 
=x11-libs/libXTrap-9999                                       
=x11-libs/libXamine-9999                                     
=x11-libs/libXau-9999                                         
=x11-libs/libXaw-9999                                         
=x11-libs/libXcursor-9999                                     
=x11-libs/libXdamage-9999                                     
=x11-libs/libXdmcp-9999                                       
=x11-libs/libXevie-9999                                       
=x11-libs/libXext-9999                                       
=x11-libs/libXfixes-9999                                     
=x11-libs/libXfont-9999                                       
=x11-libs/libXfontcache-9999                                 
=x11-libs/libXft-9999                                         
=x11-libs/libXi-9999                                         
=x11-libs/libXinerama-9999                                   
=x11-libs/libXmu-9999                                         
=x11-libs/libXp-9999                                         
=x11-libs/libXpm-9999                                         
=x11-libs/libXrandr-9999                                     
=x11-libs/libXrender-9999                                     
=x11-libs/libXres-9999                                       
=x11-libs/libXt-9999                                         
=x11-libs/libXtst-9999                                       
=x11-libs/libXv-9999                                         
=x11-libs/libXvMC-9999                                       
=x11-libs/libXxf86dga-9999                                   
=x11-libs/libXxf86misc-9999                                   
=x11-libs/libXxf86vm-9999                                     
=x11-libs/libdmx-9999                                         
=x11-libs/libdrm-9999                                         
=x11-libs/libfontenc-9999                                     
=x11-libs/libpciaccess-9999                                   
=x11-libs/libxcb-9999                                         
=x11-libs/libxkbfile-9999                                     
=x11-libs/libxkbui-9999                                       
=x11-libs/pixman-9999                                         
=x11-libs/xcb-util-9999                                       
=x11-libs/xpyb-9999                                           
=x11-libs/xtrans-9999                                         
=x11-misc/util-macros-9999                                   
=x11-misc/xcb-demo-9999                                       
=x11-misc/xkeyboard-config-9999                               
=x11-proto/bigreqsproto-9999                                 
=x11-proto/calibrateproto-9999                               
=x11-proto/compositeproto-9999                               
=x11-proto/damageproto-9999
=x11-proto/dmxproto-9999
=x11-proto/dri2proto-9999
=x11-proto/evieext-9999
=x11-proto/fixesproto-9999
=x11-proto/fontcacheproto-9999
=x11-proto/fontsproto-9999
=x11-proto/glproto-9999
=x11-proto/inputproto-9999
=x11-proto/kbproto-9999
=x11-proto/lg3dproto-9999
=x11-proto/printproto-9999
=x11-proto/randrproto-9999
=x11-proto/recordproto-9999
=x11-proto/renderproto-9999
=x11-proto/resourceproto-9999
=x11-proto/scrnsaverproto-9999
=x11-proto/trapproto-9999
=x11-proto/videoproto-9999
=x11-proto/xcb-proto-9999
=x11-proto/xcmiscproto-9999
=x11-proto/xextproto-9999
=x11-proto/xf86bigfontproto-9999
=x11-proto/xf86dgaproto-9999
=x11-proto/xf86driproto-9999
=x11-proto/xf86miscproto-9999
=x11-proto/xf86rushproto-9999
=x11-proto/xf86vidmodeproto-9999
=x11-proto/xineramaproto-9999
=x11-proto/xproto-9999


On the other hand, removing the x11 overlay, and then emerge -upD @world gives me this:
Code:
gentoo wrc # emerge -upD @world     

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     UD] x11-misc/util-macros-1.4.1 [9999]
[ebuild     UD] x11-proto/xproto-7.0.16 [9999]   
[ebuild     UD] x11-proto/kbproto-1.0.4 [9999]   
[ebuild     UD] x11-libs/xtrans-1.2.5 [9999]     
[ebuild     UD] media-fonts/font-util-1.1.1 [9999]
[ebuild     UD] x11-proto/inputproto-2.0 [9999]   
[ebuild     UD] x11-proto/xextproto-7.1.1 [9999] 
[ebuild     UD] x11-proto/randrproto-1.3.1 [9999]
[ebuild     UD] x11-proto/renderproto-0.11 [9999]
[ebuild     UD] x11-libs/libdrm-2.4.17 [9999]     
[ebuild     UD] x11-proto/fontsproto-2.1.0 [9999]
[ebuild     UD] x11-proto/xf86vidmodeproto-2.3 [9999]
[ebuild     UD] x11-proto/videoproto-2.3.0 [9999]   
[ebuild     UD] x11-proto/xf86driproto-2.1.0 [9999] 
[ebuild     UD] x11-proto/xf86dgaproto-2.1 [9999]   
[ebuild     UD] x11-proto/recordproto-1.14 [9999]   
[ebuild     UD] x11-proto/compositeproto-0.4.1 [9999]
[ebuild     UD] x11-proto/resourceproto-1.1.0 [9999]
[ebuild     UD] x11-proto/damageproto-1.2.0 [9999]   
[ebuild     UD] x11-proto/xineramaproto-1.2 [9999]   
[ebuild     UD] x11-proto/xf86miscproto-0.9.3 [9999]
[ebuild     UD] x11-libs/pixman-0.17.2 [9999]       
[ebuild     UD] x11-proto/trapproto-3.4.3 [9999]     
[ebuild     UD] x11-proto/dri2proto-2.1 [9999]       
[ebuild     UD] x11-proto/scrnsaverproto-1.2.0 [9999]
[ebuild     UD] x11-proto/xf86bigfontproto-1.2.0 [9999]
[ebuild     UD] x11-proto/fontcacheproto-0.1.3 [9999] 
[ebuild     UD] x11-proto/printproto-1.0.4 [9999]     
[ebuild     UD] x11-proto/bigreqsproto-1.1.0 [9999]   
[ebuild     UD] x11-libs/libpciaccess-0.11.0 [9999] USE="zlib%*"
[ebuild     UD] x11-proto/xf86rushproto-1.1.2 [9999]             
[ebuild     UD] x11-proto/xcmiscproto-1.2.0 [9999]               
[ebuild     UD] x11-libs/libXau-1.0.5 [9999]                     
[ebuild     UD] x11-libs/libICE-1.0.6 [9999]                     
[ebuild     UD] x11-libs/libXdmcp-1.0.3 [9999]                   
[ebuild     UD] x11-proto/fixesproto-4.1.1 [9999]               
[ebuild     UD] x11-libs/libfontenc-1.0.5 [9999]                 
[ebuild     UD] x11-libs/libSM-1.1.1 [9999] USE="uuid%*"         
[ebuild     UD] x11-base/xorg-drivers-1.7 [9999]                 
[ebuild     UD] x11-proto/xcb-proto-1.6 [9999]                   
[ebuild     UD] x11-libs/libxcb-1.5 [9999] USE="-doc% (-selinux)"
[ebuild     UD] x11-proto/glproto-1.4.10 [9999]                   
[ebuild     UD] x11-libs/libX11-1.3.2 [9999] USE="-doc%"         
[ebuild     UD] x11-libs/xcb-util-0.3.6 [9999]                   
[ebuild     UD] x11-libs/libXt-1.0.7-r1 [9999]                   
[ebuild     UD] x11-libs/libXext-1.1.1 [9999]                     
[ebuild     UD] x11-libs/libXrender-0.9.5 [9999]                 
[ebuild     UD] x11-libs/libxkbfile-1.0.6 [9999]                 
[ebuild     UD] x11-libs/libXfixes-4.0.4 [9999]                   
[ebuild     UD] x11-apps/xev-1.0.4 [9999]                         
[ebuild     UD] x11-libs/libXxf86vm-1.1.0 [9999]                 
[ebuild     UD] x11-apps/mkfontscale-1.0.7 [9999]                 
[ebuild     UD] x11-libs/libXmu-1.0.5 [9999]                     
[ebuild     UD] x11-libs/libXi-1.3 [9999]                         
[ebuild     UD] x11-libs/libXcursor-1.1.10 [9999]                 
[ebuild     UD] x11-libs/libXrandr-1.3.0 [9999]                   
[ebuild     UD] x11-libs/libXfont-1.4.1 [9999]                   
[ebuild     UD] x11-libs/libXpm-3.5.8 [9999] USE="nls%*"         
[ebuild     UD] x11-libs/libXv-1.0.5 [9999]                       
[ebuild     UD] x11-libs/libXdamage-1.1.2 [9999]                 
[ebuild     UD] x11-libs/libXres-1.0.4 [9999]                     
[ebuild     UD] x11-libs/libXfontcache-1.0.5 [9999]               
[ebuild     UD] x11-libs/libXp-1.0.0 [9999]                       
[ebuild     UD] x11-libs/libxkbui-1.0.2 [9999]                   
[ebuild     UD] x11-apps/xkbevd-1.1.0 [9999]                     
[ebuild     UD] x11-libs/libXxf86dga-1.1.1 [9999]                 
[ebuild     UD] x11-libs/libXxf86misc-1.0.2 [9999]               
[ebuild     UD] x11-libs/libXScrnSaver-1.2.0 [9999]               
[ebuild     UD] x11-libs/libXTrap-1.0.0 [9999]                   
[ebuild     UD] media-fonts/font-alias-1.0.1 [1.0.2]             
[ebuild     UD] x11-apps/mkfontdir-1.0.5 [9999]                   
[ebuild     UD] x11-libs/libXtst-1.1.0 [9999]                     
[ebuild     UD] x11-libs/libXaw-1.0.7 [9999]                     
[ebuild     UD] x11-misc/xkeyboard-config-1.7 [9999]             
[ebuild     UD] x11-apps/xrandr-1.3.2 [9999]                     
[ebuild     UD] x11-apps/smproxy-1.0.3 [9999]                     
[ebuild     UD] x11-apps/xinput-1.5.0 [9999]                     
[ebuild     UD] x11-apps/xwininfo-1.0.5 [9999]                   
[ebuild     UD] x11-apps/xvinfo-1.1.0 [9999]                     
[ebuild     UD] x11-apps/xcursorgen-1.0.3 [9999]                 
[ebuild     UD] media-libs/mesa-7.7-r1 [9999] USE="gallium* (-selinux)" VIDEO_CARDS="-svga%"
[ebuild     UD] x11-apps/xinit-1.2.0-r3 [9999]                                               
[ebuild     UD] x11-apps/xkbutils-1.0.2 [9999]                                               
[ebuild     UD] x11-apps/xdriinfo-1.0.3 [9999]                                               
[ebuild     UD] x11-libs/libXft-2.1.14 [9999]                                               
[ebuild     UD] media-fonts/font-xfree86-type1-1.0.1 [1.0.2]                                 
[ebuild     UD] media-fonts/font-adobe-utopia-100dpi-1.0.1 [1.0.2]                           
[ebuild     UD] media-fonts/font-ibm-type1-1.0.0 [1.0.1] USE="nls%*"                         
[ebuild     UD] media-fonts/font-adobe-75dpi-1.0.0 [1.0.1]                                   
[ebuild     UD] media-fonts/font-bh-type1-1.0.0 [1.0.1]                                     
[ebuild     UD] media-fonts/font-micro-misc-1.0.0 [1.0.1]                                   
[ebuild     UD] media-fonts/font-bh-ttf-1.0.0 [1.0.1]                                       
[ebuild     UD] media-fonts/font-adobe-utopia-75dpi-1.0.1 [1.0.2]                           
[ebuild     UD] media-fonts/font-misc-ethiopic-1.0.0-r1 [1.0.1]                             
[ebuild     UD] media-fonts/font-sony-misc-1.0.0 [1.0.1]                                     
[ebuild     UD] media-fonts/font-screen-cyrillic-1.0.1 [1.0.2]                               
[ebuild     UD] media-fonts/font-jis-misc-1.0.0 [1.0.1]                                     
[ebuild     UD] media-fonts/font-bh-100dpi-1.0.0 [1.0.1]                                     
[ebuild     UD] media-fonts/font-misc-misc-1.0.0 [1.1.0]                                     
[ebuild     UD] media-fonts/font-cursor-misc-1.0.0 [1.0.1]                                   
[ebuild     UD] media-fonts/font-misc-cyrillic-1.0.0 [1.0.1]                                 
[ebuild     UD] media-fonts/font-arabic-misc-1.0.0 [1.0.1]                                   
[ebuild     UD] media-fonts/font-bitstream-100dpi-1.0.0 [1.0.1]                             
[ebuild     UD] media-fonts/font-misc-meltho-1.0.0 [1.0.1]                                   
[ebuild     UD] media-fonts/font-adobe-100dpi-1.0.0 [1.0.1]                                 
[ebuild     UD] media-fonts/font-bh-75dpi-1.0.0 [1.0.1]                                     
[ebuild     UD] media-fonts/font-cronyx-cyrillic-1.0.0 [1.0.1]                               
[ebuild     UD] media-fonts/font-daewoo-misc-1.0.0 [1.0.1]                                   
[ebuild     UD] media-fonts/font-mutt-misc-1.0.0 [1.0.1]                                     
[ebuild     UD] media-fonts/font-bitstream-speedo-1.0.0 [1.0.1]                             
[ebuild     UD] media-fonts/font-sun-misc-1.0.0 [1.0.1]                                     
[ebuild     UD] media-fonts/font-bitstream-75dpi-1.0.0 [1.0.1]                               
[ebuild     UD] media-fonts/font-adobe-utopia-type1-1.0.1 [1.0.2]                           
[ebuild     UD] media-fonts/font-bh-lucidatypewriter-100dpi-1.0.0 [1.0.1]                   
[ebuild     UD] media-fonts/font-winitzki-cyrillic-1.0.0 [1.0.1]                             
[ebuild     UD] media-fonts/font-dec-misc-1.0.0 [1.0.1]                                     
[ebuild     UD] media-fonts/font-schumacher-misc-1.0.0 [1.1.0]                               
[ebuild     UD] media-fonts/font-isas-misc-1.0.0 [1.0.1]                                     
[ebuild     UD] media-fonts/font-bitstream-type1-1.0.0 [1.0.1]                               
[ebuild     UD] media-fonts/font-bh-lucidatypewriter-75dpi-1.0.0 [1.0.1]                     
[ebuild     UD] x11-libs/cairo-1.8.8 [9999] USE="(-aqua)"                                   
[ebuild     UD] x11-apps/x11perf-1.5.1 [9999]                                               
[ebuild     UD] x11-base/xorg-server-1.7.3.902 [9999]                                       
[ebuild     UD] x11-drivers/xf86-input-keyboard-1.4.0 [9999]                                 
[ebuild     UD] x11-drivers/xf86-input-evdev-2.3.2 [9999]
[ebuild     UD] x11-drivers/xf86-input-mouse-1.5.0 [9999]
[ebuild     UD] x11-drivers/xf86-video-ati-6.12.4 [9999]



Are either of these methods sufficient, or is there a better way to revert to insure nothing goes haywire with X?

EDIT: Just tried a new 2.6.33-rc2 vanilla kernel. Still get same screen corruption in konqueror, about the same or a little worse.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental


Last edited by wrc1944 on Thu Jan 14, 2010 11:23 pm; edited 2 times in total
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Sun Jan 03, 2010 5:13 am    Post subject: Reply with quote

Well, sync'd the x11 overlay and rebuilt everything- same screen corruption.
Then did the revert with removing the x11 0verlay, and doing a emerge -uD @world, which downgraged all the x11 9999 packages to portage versions, with no problems.

After than, radeon and radeonhd driver will not get into kdm or gdm- leaves a very small cursor on a black screen which moves, but no other response is possible, and no terminals will start. This is with or without an xorg.conf. Have to cold reboot and use a live cd to get into my Gentoo xorg.conf for edits.

The only thing that works is an xorg.conf with the vesa driver, which in kde is really bad with blobs of greenish black corruption. Xfce4 is much better, but still has tinges of the green/black stuff.

All things considered, I'm worse off than before. revdep-rebuild is consistent, and I've rebuilt everything x11, twice.

At this point I'm fed up, so I'll wait until kde-4.4-rc1 is released before I make another attempt at this, but what I'm really puzzled about is why the xorg radeon driver now refuses to work at all, even thought I'm now using using all portage qt, kde-4.3.4, and xorg versions.

What a mess this 5-6 year old Gentoo install system has become. Guess after kde-4.4-rc1 comes out, I'll do a complete emerge -e @world when I update kde, and hope that sorts it all out. I've tried so many things for months now I've lost track.

Has anyone else seen this screen corruption, and know what causes it?
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
GD
Tux's lil' helper
Tux's lil' helper


Joined: 11 May 2005
Posts: 134
Location: Greece

PostPosted: Thu Jan 14, 2010 9:16 pm    Post subject: Reply with quote

Are you sure this isn't a radeon thing? Are you using KMS?

I've been using highly unstable stuff for the past few weeks, namely everything live from the x11 overlay, everything live from the kde-testing overlay, the unstable zen-kernel tree and i've never run into screen corruption issues. However I'm using intel graphics with KMS (even tried gallium for a while, but kwin effects didn't work so i reverted back to classic mesa) and my system is a relatively fresh gentoo installation.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Thu Jan 14, 2010 10:44 pm    Post subject: Reply with quote

GD,
Thanks for the feedback! :D I'm not using KMS, and the plain radeon driver won't initialize beyong a moving mouse cursor on a black screen. Have to use radeonhd.

Just tried a new 2.6.33-rc4 kernel that has a bunch of new radeon fixes/updates- same problem persists. Also the same with kde-4.4-rc1 on another partition.

Maybe this is a clue. I raised the video memory by adding 256mb system ram to the 128mb "sideport" this board has, and konqueror now holds out for about 10 minutes instead of 1-3 minutes before the corruption starts and gets worse and worse. Konqueror memory leak???

This seems essentially limited to konqueror, so I'm now thinking this has to be a konqueror and/or qt specific problem (as opposed to driver or kernel), as any gtk apps don't show any of this. Dolphin is also now apparently problem free.

I'm currently looking at mttr settings, and reading everything I can find on radeon and xorg mailing lists. This problem is really becoming insane- I'd be happy if I just could isolate the cause, even if I still couldn't fix it. :roll:

I've tried all the recent and current kde/qt/kernel/radeon/vesa/radeonhd versions, and still no progress- but it only seems to occur with konqueror. However, looking on the bright side I find myself liking Firefox more and more. :lol:

I'll give Arora and Rekonq a thorough shakedown, and see if they too develop the corruption- that's one thing I haven't tried. If they do, wouldn't seem to incriminate qt/webkit, especially if only Arora shows corruption?
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
yther
Apprentice
Apprentice


Joined: 25 Oct 2002
Posts: 151
Location: Charlotte, NC (USA)

PostPosted: Thu Jan 14, 2010 11:43 pm    Post subject: Reply with quote

You said the graphical corruption doesn't happen in other distributions, so possibly it could have something to do with how your system's KDE is compiled compared to theirs. You could check into which compiler version and options were used to build the packages on those other distros, and perhaps some changes to your CFLAGS or other options could help the graphics problem. (For example, here's some (old?) info on Ubuntu. It looks like they don't use anything stronger than -O2, with most packages using -O0.)
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Fri Jan 15, 2010 12:46 am    Post subject: Reply with quote

yther,
Thanks for the post.
I had looked into these aspects you mention in some depth before, but didn't find a likely cause. Maybe it's worth another look. What did appear odd is that Arch and Mandriva could use the xorg xf86-video-ati (radeon) and vesa drivers, but with Gentoo I've recently had to use radeonhd.

I have thought it must be the ongoing updating process currently with xorg stuff and linux kernel, combined with some weird quirk in my Gentoo configuration (or misconfiguration, as the case may be), or I'm missing some xorg/driver option/configuration. Or worse case, the AMD 790gx ATI HD3300 IGP video hardware isn't as good as it's cracked up to be, and I'm beating my head against a wall. I'm now thinking it's konqueror itself.

Maybe someone who has an AMD 790gx board with the HD3300 128mb onboard memory actually set up correctly and NOT having this problem could post a rundown on their settings and driver used? (kernel config, xorg config, if any, and any other thing they did resulting in konqueror working normally.

Probably any of the integrated AMD Radeon HD xxxx graphics in the R700 or even R600 series would be similar.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum