Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Grub install problems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Niklas_E
n00b
n00b


Joined: 01 Oct 2009
Posts: 1

PostPosted: Fri Jan 08, 2010 11:32 am    Post subject: Grub install problems Reply with quote

I have a problem. I had to install windows on /dev/sda1 and have my swap on /dev/sda5, root device is /dev/sda6 and home is sda7.

When I installed XP yesterday, it messed up my boot, so it won't boot windows or gentoo. I tried to boot though the gentoo 9 live-cd but don't seem to be able to install grub again. is there some way to install grub? tried chroot /dev/sda6 ; grub-install /dev/sda but don't work.

I also tried grub-install --root-dictitonary /mnt/gentoo /dev/sda but don't seem to work neither.

Anyone know hot to fix it?

Thanks in advance,
Niklas
Back to top
View user's profile Send private message
ryan221
n00b
n00b


Joined: 07 Jan 2010
Posts: 28

PostPosted: Fri Jan 08, 2010 1:29 pm    Post subject: Reply with quote

live cd should allow you to fix this
it's just like in the handbook during installation

all you should have to do is mount your root partition(you don't mention a boot partition but if you have one mount it too ) on /mnt/gentoo

then do
mount -t proc none /mnt/gentoo/proc
mount -o bind /dev /mnt/gentoo/dev

then just chroot like in the handbook

chroot /mnt/gentoo /bin/bash
env-update && source /etc/profile

once inside you chroot , i would re-emerge grub , the you should be able to install it like normal
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum