Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mysqld denkt, dass es keinen zugriff auf das socket hat.
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
GhostTyper
Tux's lil' helper
Tux's lil' helper


Joined: 03 Apr 2004
Posts: 79
Location: Germany; BW

PostPosted: Sat Jan 09, 2010 4:25 am    Post subject: mysqld denkt, dass es keinen zugriff auf das socket hat. Reply with quote

hallo,

ich habe drei gentoo webserver mit lighttpd und einen gentoo mysql server auf insgesamt 4 physikalischen maschinen aufgesetzt. (also einfach drei webserver und einen datenbankserver.) jetzt wollte ich drann' gehen und einen der webserver als backup mysql server betreiben, den ich dann starten kann, falls die eigentliche mysql maschine ausfällt.

ich habe zuanfang nur einen der webserver installiert und dann die anderen zwei via dd und netcat gespiegelt. das heisst, diese sind sich softwaretechnisch sehr ähnlich!

nach dem emerge mysql und mysql_install_db meldet mir der mysqld allerdings:

Code:
100109  5:06:52 [Warning] No argument was provided to --log-bin, and --log-bin-index was not used; so replication may break when this MySQL server acts as a master and has his hostname changed!! Please use '--log-bin=mysqld-bin' to avoid this problem.
InnoDB: The InnoDB memory heap is disabled
InnoDB: use atomic builtins.
100109  5:06:52  InnoDB: Started; log sequence number 0 43655
100109  5:06:52 [ERROR] Can't start server : Bind on unix socket: Permission denied
100109  5:06:52 [ERROR] Do you already have another mysqld server running on socket: /var/run/mysqld/mysqld.sock ?
100109  5:06:52 [ERROR] Aborting

100109  5:06:52  InnoDB: Starting shutdown...
100109  5:06:53  InnoDB: Shutdown completed; log sequence number 0 43655
100109  5:06:53 [Note] /usr/sbin/mysqld: Shutdown complete


ich habe mehrmals nachgeschaut und kontrolliert: /var/run/mysqld/mysqld.sock existiert nicht! und das wäre auch erkannt worden vom startscript. /etc/init.d/mysql start führe ich als root aus. die my.cnf und /etc/conf.d/mysql dateien sind im auslieferungszustand. alle drei webserver haben diesen fehler, wenn ich versuche mysql zu starten. ich habe schon oft erfolgreich mysql auf gentoo installiert - ich hatte ein solches problem noch nie!

woran kann das liegen? welche weiteren info's braucht ihr um mir tipps geben zu können?
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Sat Jan 09, 2010 10:04 am    Post subject: Reply with quote

Ich hatte das letztens auch gehabt.
Schau mal nach den Berechtigungen:
/var/run/mysqld muss mysql:mysql gehören.

Hoffe, das ist es.

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
GhostTyper
Tux's lil' helper
Tux's lil' helper


Joined: 03 Apr 2004
Posts: 79
Location: Germany; BW

PostPosted: Sat Jan 09, 2010 1:47 pm    Post subject: Reply with quote

danke, das hat geholfen!

komisch, dass sich das geändert hat...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum