Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst]cam-Treiberwahl nicht möglich taucht nicht auf(lsusb
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Schinkencroissant
Guru
Guru


Joined: 09 Oct 2009
Posts: 309

PostPosted: Sat Jan 09, 2010 11:28 pm    Post subject: [gelöst]cam-Treiberwahl nicht möglich taucht nicht auf(lsusb Reply with quote

Hallo,

eigentlich würde ich gerne meine im Rechner eingebaute Webcam einrichten, dazu wollte ich dann wie hier http://en.gentoo-wiki.com/wiki/Webcam beschrieben vorgehen.

Als ich dann aber über lsusb den Chipsatz herausfinden wollte, bekam ich sie gar nicht angezeigt. Wahrscheinlich wieder mal ein Anfängerfehler, wäre aber trotzdem dankbar, wenn mir jemand helfen könnte.

Bei dem Rechner handelt es sich um ein ThinkPad T400 (2767-WSD) mit dem Rahmen, der eben eine LED-Hintergrundbeleuchtung und eine Webcam in sich vereint.

Viele Grüße,

Schinkencroissant
_________________
"Es muss ein Lehrplan her und eine Wertediskussion
und keine Werte unter 120 Phon!"

- J.B.O.


Last edited by Schinkencroissant on Mon Jan 11, 2010 9:26 pm; edited 1 time in total
Back to top
View user's profile Send private message
XMath
Guru
Guru


Joined: 14 Aug 2004
Posts: 435
Location: Germany, Gaimersheim

PostPosted: Sun Jan 10, 2010 1:47 pm    Post subject: Reply with quote

Hi,
kannst du die Kamera vielleicht im BIOS deaktivieren?
Vielleicht taucht sie deshalb nicht auf.
Back to top
View user's profile Send private message
Schinkencroissant
Guru
Guru


Joined: 09 Oct 2009
Posts: 309

PostPosted: Mon Jan 11, 2010 6:35 pm    Post subject: Reply with quote

Daran hatte ich noch gar nicht gedacht, ehrlich gesagt, aber eben habe ich nachgeschaut, im BIOS habe ich nichts gefunden, um die Webcam zu aktivieren, also warum finde ich sie nicht? Jemand eine Idee?

Die Ausgabe von lsusb sieht bei mir so aus:

Code:
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 17ef:1004 Lenovo
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 003: ID 0a5c:2145 Broadcom Corp. Bluetooth with Enhanced Data Rate II
Bus 004 Device 002: ID 08ff:2810 AuthenTec, Inc.
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


Kann das eventuell jemand mit einem T400 oder etwas vergleichbarem bestätigen?

Viele Grüße,

Schinkencroissant
_________________
"Es muss ein Lehrplan her und eine Wertediskussion
und keine Werte unter 120 Phon!"

- J.B.O.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Mon Jan 11, 2010 6:52 pm    Post subject: Reply with quote

Schinkencroissant wrote:
Bus 001 Device 004: ID 17ef:1004 Lenovo


Suchmaschine wrote:
Webcam

The webcam in T61 is some sort of UVC camera: Found UVC 1.00 device Integrated Camera (17ef:1004). The module loads out of the box. I tested the camera using: Luvcview: http://mxhaard.free.fr/spca50x/Investigation/uvc/luvcview-20070512.tar.gz Just compile and run using ./luvcview -f yuv (JPG format doesn't work)

I also tried gqcam and webcam, but both doesn't work (first SEGFAULTs, second prints Invalid argument)

luvcview has a button to take pictures. Place your mouse over the buttons at the bottom of the window, and their function is revealed in the title bar. Unfortunately, the button for avi capture does not seem to work (although it does tell you what the video framerate is, which is helpful).

To capture a video stream, run ./luvcview -f yuv -S To play back the video stream, run mplayer -demuxer rawvideo -rawvideo fps=7:w=320:h=240:yuy2 stream.raw
http://www.thinkwiki.org/wiki/Installing_Ubuntu_7.04_%28Feisty_Fawn%29_on_a_ThinkPad_T61#Webcam

Code:
$ eix Luvcview
* media-video/luvcview
     Available versions:  (~)20070512
     Homepage:            http://linux-uvc.berlios.de
     Description:         USB Video Class grabber


/edit:
Evtl. bekommst du deinen "lsusb" Output auch noch etwas auskunftsfreudigker indem du mal ein
Code:
 # update-usbids
durchführst. Dies aktualisiert die lokale Datenbank-Datei von "lsusb" (aus dem Internet), diese sollte möglichst immer aktueller sein als die verbaute Hardware.

Viel Erfolg
Back to top
View user's profile Send private message
Schinkencroissant
Guru
Guru


Joined: 09 Oct 2009
Posts: 309

PostPosted: Mon Jan 11, 2010 9:23 pm    Post subject: Reply with quote

Hallo,

sorry, aber ich hab da nur den Namen Lenovo gesehen und habe von da aus nicht auf die Kamera geschlossen. Mit der ID, OK, Anfängerfehler...

Jetzt habe ich beim Kernel mal das entsprechende Häkchen gemacht und siehe da, die Webcam tut's. Sie erscheint mir ein wenig langsam, kann das auch der Treiber oder die Konfiguration sein oder ist das grundsätzlich nur die Hardware?

Vielen Dank soweit, wenn jemand noch was zu dem Ruckeln sagen kann, bitte, ansonsten [gelöst]

Grüße,

Schinkencroissant
_________________
"Es muss ein Lehrplan her und eine Wertediskussion
und keine Werte unter 120 Phon!"

- J.B.O.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum