Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
What is the current method of installing nouveau?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
dswann
n00b
n00b


Joined: 12 Jan 2010
Posts: 1

PostPosted: Tue Jan 12, 2010 1:12 am    Post subject: What is the current method of installing nouveau? Reply with quote

Running a late 2004 PowerMac G5 M9455LL/A which my system has a NVIDIA 5200FX. The gentoo base system installed and running fine in a 64 bit UL; working my way towards x.org and KDE.. so I am up to getting the NVIDIA drivers configured/installed. I have no desire/need for 3D support.

So I thought I would try the Nouveau drivers using the Wiki. Added these lines into my portage.keywords (needed because of PPC):

Code:

~x11-libs/libdrm-9999 **
~x11-base/nouveau-drm-99999999 **
~x11-drivers/xf86-video-nouveau-9999 **


And started to emerge using Layman x11 overlay; x11-libs/libdrm-9999 emerged/installed fine. However, when emerging x11-base/nouveau-drm-99999999 (the nouveau firmware was a dependency), it complained that it needed linux kernel 2.6.32 (I was running 2.6.31-r6). So I emerged the 2.6.32-r1 kernel, compiled and configured everything there and start back over and now when I try to emerge nouveau-drm-99999999, it fails at compiling kernel modules giving me an error basically saying that my kernel version was incompatible. Humph

So

A.) Should I make the jump to the 2.6.33 kernel, which has built in nouveau?

Or

B.) Just use the nv driver?

Thanks!
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Tue Jan 12, 2010 2:37 pm    Post subject: Reply with quote

I have no clue what is the best to do in ppc world actually, my pb is ati based.
I´d say, use the latest kernel sources, pull everything from x11 overlay, add nouveau to your VIDEO_CARDS var in make.conf and hopefully it will work.
In case you are using the kernel drm you don´t need nouveau-drm i suppose.

Quote:
Just use the nv driver?


in case the nouveau driver doesn´t work for you, yes. The nv driver is really limited in its funcionality.

cheers
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
bmaass
n00b
n00b


Joined: 15 Mar 2008
Posts: 25

PostPosted: Tue Jan 12, 2010 9:34 pm    Post subject: Re: What is the current method of installing nouveau? Reply with quote

The InstallDRM instructions on nouveau.freedesktop.org work for PPC. If you get build errors with nouveau-drm from portage, your kernel is misconfigured and you won't get different results if you pull the complete nouveau git source and build from there. The InstallDRM page has all informations you need to properly set up your kernel, though. Firmware is NOT needed for nv40 and below (like your card), so the ebuild has it wrong.
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Mon Jan 18, 2010 2:10 pm    Post subject: Reply with quote

I just tested nouveau-drm-99999999 and it compiles fine with 2.6.32. Please post your error here. There is also an older snapshot of nouveau-drm in the sunrise overlay which should be compatible with 2.6.31. Be sure to have your kernel configured correctly, the ebuild will complain if not.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum