Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Son]Deux cartes son ? [résolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Tom_
Guru
Guru


Joined: 20 May 2004
Posts: 385
Location: France

PostPosted: Tue Jan 26, 2010 10:39 am    Post subject: [Son]Deux cartes son ? [résolu] Reply with quote

Bonjour,
Je possède deux cartes sons dans ma machine :
- celle intégrée à la carte mère (géré via le module snd_intel8x0)
- une carte pci : Terratec Aureon 5.1 PCI (module snd_cmipci)

En plus de ca, je possède une carte TV (Hauppauge HVR1100) qui possède un pilote Alsa (cx88_alsa) et une webcam avec un micro (en usb, snd_usb_audio).

J'aimerais utiliser la Terratec comme carte son principale, et celle intégrée pour Skype.

J'ai essayé de configurer ca dans deux fichiers : /etc/modules.d/alsa.conf et /etc/modprobe.d/alsa.conf :
Code:
# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-cmipci
alias snd-card-1 snd-intel8x0

#
# # OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-cmipci
alias sound-slot-1 snd-intel8x0
#
# # OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
#
# # OSS/Free portion - card #1
alias sound-service-1-0 snd-mixer-oss
alias sound-service-1-1 snd-seq-oss
alias sound-service-1-3 snd-pcm-oss
alias sound-service-1-8 snd-seq-oss
alias sound-service-1-12 snd-pcm-oss
#
#
options snd cards_limit=2
options snd-cmipci index=0
options snd-intel8x0 index=1

J'ai mis la même chose dans les fichiers vu que je savais pas trop quoi faire...

Le problème c'est que des fois ca marche, et d'autres fois nen. Hier j'avais du son, mais aujourd'hui j'en ai plus :
Code:
thomas@gentoo ~ % cat /proc/asound/cards
 0 [U0x46d0x8a2    ]: USB-Audio - USB Device 0x46d:0x8a2
                      USB Device 0x46d:0x8a2 at usb-0000:00:02.0-10, full speed
 1 [CK804          ]: NFORCE - NVidia CK804
                      NVidia CK804 with ALC850 at irq 22
 2 [CX8811         ]: CX88x - Conexant CX8811
                      Conexant CX8811 at 0xfb000000

Il manque donc ma Terratec dans la liste alors qu'elle est bien présente dans lspci :
Code:
01:08.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
        Subsystem: TERRATEC Electronic GmbH Aureon 5.1
        Flags: bus master, stepping, medium devsel, latency 32, IRQ 3
        I/O ports at ac00 [size=256]
        Capabilities: [c0] Power Management version 2
        Kernel modules: snd-cmipci


Comment je peux faire pour que ca fonctionne tout le temps?

Merci d'avance.


Last edited by Tom_ on Wed Jan 27, 2010 4:22 pm; edited 1 time in total
Back to top
View user's profile Send private message
Gaby
Apprentice
Apprentice


Joined: 03 Aug 2005
Posts: 251

PostPosted: Tue Jan 26, 2010 11:50 am    Post subject: Reply with quote

Bonjour,

Si j'ai bien compris, tu as 4 cartes sons reconnu et tu ne veux te servir que de 2.
J'avais fait un truc similaire avec 3 cartes sons et en ne me servant que de 2 et j'ai été obligé de déclarer la 3eme dans le fichier /etc/modprobe.d/alsa.conf
Code:
# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-cmipci
alias snd-card-1 snd-intel8x0
alias snd-card-2 cx88_alsa
alias snd-card-3 snd_usb_audio

#
# # OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-cmipci
alias sound-slot-1 snd-intel8x0
#
# # OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
#
# # OSS/Free portion - card #1
alias sound-service-1-0 snd-mixer-oss
alias sound-service-1-1 snd-seq-oss
alias sound-service-1-3 snd-pcm-oss
alias sound-service-1-8 snd-seq-oss
alias sound-service-1-12 snd-pcm-oss
#
#
options snd cards_limit=4
options snd-cmipci index=0
options snd-intel8x0 index=1
options cx88_alsa index=2
options snd_usb_audio index=3

Chez moi ça fonctionne de cette façon.

Gaby
Back to top
View user's profile Send private message
Tom_
Guru
Guru


Joined: 20 May 2004
Posts: 385
Location: France

PostPosted: Tue Jan 26, 2010 12:18 pm    Post subject: Reply with quote

Je me sers un peu des 4 on va dire :
- 2 en sortie : la Terratec et celle intégrée
- 2 en entrée : la carte tv et la webcam que j'utilise comme micro le temps que je me trouve un micro-casque qui fonctionne.

Je vais essayer ce que tu m'as donné. ;)

Ensuite, c'est quoi la différence entre /etc/modules.d/ et /etc/modprobe.d ?

Merci
Back to top
View user's profile Send private message
Tom_
Guru
Guru


Joined: 20 May 2004
Posts: 385
Location: France

PostPosted: Tue Jan 26, 2010 12:27 pm    Post subject: Reply with quote

Je viens de copier-coller ce que tu m'as donné, et ca a marché niquel après un reboot.

J'ai supprimé /etc/modules.d/alsa.conf et gardé seulement /etc/modprobe.d/alsa.conf.

On verra si ca continue de fonctionner demain :lol:

En tout cas, merci Gaby. ;)
Back to top
View user's profile Send private message
Gaby
Apprentice
Apprentice


Joined: 03 Aug 2005
Posts: 251

PostPosted: Tue Jan 26, 2010 11:21 pm    Post subject: Reply with quote

Pour la différence entre les 2 fichiers, je ne sais pas te répondre.

Pense à passer en [résolu] ;)

Gaby
Back to top
View user's profile Send private message
Tom_
Guru
Guru


Joined: 20 May 2004
Posts: 385
Location: France

PostPosted: Wed Jan 27, 2010 4:21 pm    Post subject: Reply with quote

/etc/modules.d est obsolète maintenant : https://bugs.gentoo.org/215626

La config de mes cartes sont a l'air de bien fonctionner! Merci :)
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Thu Jan 28, 2010 7:24 am    Post subject: Reply with quote

SAlut, j'ai une question très bête, mais c'est pour ma culture :)

Pourquoi utiliser deux cartes son? j'ai du mal à saisir.
Merci
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Thu Jan 28, 2010 10:53 am    Post subject: Reply with quote

Bah perso j'ai ma carte son intégrée qu'est naze mais fonctionne avec Traverso... pis j'aime Traverso (quand j'ai besoin de m'en servir).
Ma carte pas intégrée qu'a des drivers moisis, ne fonctionne pas avec Traverso mais que le son il est plus mieux ;)
_________________
Full Gentoo powered.
Back to top
View user's profile Send private message
Tom_
Guru
Guru


Joined: 20 May 2004
Posts: 385
Location: France

PostPosted: Thu Jan 28, 2010 12:00 pm    Post subject: Reply with quote

On dit toujours que les cartes son intégrées sont pas géniales! J'avais l'occassion d'avoir une carte PCI pour pas très cher. Alors, j'ai acheté cette carte son et je l'utilise comme carte son principale. J'utilise Skype tous les jours, et je trouve pénible de toujours (dé)brancher mon casque : alors vu que j'ai deux cartes sons, je me suis que je pourrais les utiliser les deux. 8)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum