Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Reprise impossible d'emerge après coupure courant ! [Réglé]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
CaptainBlood
Veteran
Veteran


Joined: 24 Jan 2010
Posts: 1008

PostPosted: Sat Jan 30, 2010 11:16 pm    Post subject: Reprise impossible d'emerge après coupure courant ! [Réglé] Reply with quote

Bonjour,

J'étais en chemin avec un
Code:
emerge vuze
,lorsque le courant a été coupé :cry:.Je relance la machine,
Code:
emerge --resume vuze
me donne
Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] dev-java/ant-core-1.7.1-r4  USE="-doc -source" 0 kB
[ebuild  N    ] virtual/jre-1.6.0  0 kB
[ebuild  N    ] dev-java/json-simple-20080420  USE="-doc -source" 0 kB
[ebuild  N    ] dev-java/log4j-1.2.15-r2  USE="-doc -javamail -jms -jmx -source" 0 kB
[ebuild  N    ] dev-java/bcprov-1.38  USE="-doc -source" 0 kB
[ebuild  N    ] dev-java/commons-cli-1.2  USE="-doc -source -test" 0 kB
[ebuild  N    ] net-libs/xulrunner-1.9.1.6  USE="alsa python -custom-optimization -dbus -debug -gnome -java -sqlite -startup-notification" 0 kB
[ebuild  N    ] dev-java/swt-3.5.1  USE="cairo xulrunner -gnome -opengl" 0 kB
[ebuild  N    ] net-p2p/vuze-4.2.0.8  USE="-source" 0 kB
[ebuild  N    ] net-p2p/vuze-coreplugins-4.2.0.8-r1  0 kB

Total: 10 packages (10 new), Size of downloads: 0 kB

*** Resuming merge...

>>> Verifying ebuild manifests

>>> Starting parallel fetch

>>> Emerging (1 of 10) dev-java/ant-core-1.7.1-r4
 * apache-ant-1.7.1-src.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                   [ ok ]
 * ant-1.7.1-gentoo.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                       [ ok ]
 * checking ebuild checksums ;-) ...                                              [ ok ]
 * checking auxfile checksums ;-) ...                                             [ ok ]
 * checking miscfile checksums ;-) ...                                            [ ok ]
 * Using: icedtea6-bin
>>> Unpacking source...
>>> Unpacking apache-ant-1.7.1-src.tar.bz2 to /var/tmp/portage/dev-java/ant-core-1.7.1-r4/work
>>> Unpacking ant-1.7.1-gentoo.tar.bz2 to /var/tmp/portage/dev-java/ant-core-1.7.1-r4/work
>>> Source unpacked in /var/tmp/portage/dev-java/ant-core-1.7.1-r4/work
>>> Preparing source in /var/tmp/portage/dev-java/ant-core-1.7.1-r4/work/apache-ant-1.7.1 ...
removed `lib/xercesImpl.jar'
removed `lib/xml-apis.jar'
 * Applying 1.7.1-pkg-info.patch ...                                               [ ok ]
 * Applying 1.7.1-jdk4-javadoc.patch ...                                           [ ok ]
Rewriting attributes
Rewriting build.xml
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-java/ant-core-1.7.1-r4/work/apache-ant-1.7.1 ...
Rewriting attributes
Rewriting ./build.xml
>>> Source configured.
>>> Compiling source in /var/tmp/portage/dev-java/ant-core-1.7.1-r4/work/apache-ant-1.7.1 ...
... Bootstrapping Ant Distribution
... Compiling Ant Classes
./bootstrap.sh: line 137: 14167 Illegal instruction     "${JAVAC}" $BOOTJAVAC_OPTS -d ${CLASSDIR} ${TOOLS}/bzip2/*.java ${TOOLS}/tar/*.java ${TOOLS}/zip/*.java ${TOOLS}/ant/util/regexp/RegexpMatcher.java ${TOOLS}/ant/util/regexp/RegexpMatcherFactory.java ${TOOLS}/ant/types/*.java ${TOOLS}/ant/types/resources/*.java ${TOOLS}/ant/*.java ${TOOLS}/ant/taskdefs/*.java ${TOOLS}/ant/taskdefs/compilers/*.java ${TOOLS}/ant/taskdefs/condition/*.java
... Failed compiling Ant classes !
Bootstrap FAILED
 *
 * ERROR: dev-java/ant-core-1.7.1-r4 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 4282:  Called die
 * The specific snippet of code:
 *       CLASSPATH="$(java-config -t)" ./build.sh ${bsyscp} jars-core internal_dist $(use_doc javadocs) || die "build failed"
 *  The die message:
 *   build failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-java/ant-core-1.7.1-r4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-java/ant-core-1.7.1-r4/temp/environment'.
 *
!!! When you file a bug report, please include the following information:
GENTOO_VM=icedtea6-bin  CLASSPATH="" JAVA_HOME="/opt/icedtea6-bin-1.6.2"
JAVACFLAGS="-source 1.4 -target 1.4" COMPILER=""
and of course, the output of emerge --info

>>> Failed to emerge dev-java/ant-core-1.7.1-r4, Log file:

>>>  '/var/tmp/portage/dev-java/ant-core-1.7.1-r4/temp/build.log'

 * Messages for package dev-java/ant-core-1.7.1-r4:

 *
 * ERROR: dev-java/ant-core-1.7.1-r4 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 4282:  Called die
 * The specific snippet of code:
 *       CLASSPATH="$(java-config -t)" ./build.sh ${bsyscp} jars-core internal_dist $(use_doc javadocs) || die "build failed"
 *  The die message:
 *   build failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-java/ant-core-1.7.1-r4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-java/ant-core-1.7.1-r4/temp/environment'.


Je ne sais pas faire reprendre la compilation de vuze.
Quel conseil pour diagnostiquer et réparer cette panne ?

N.B. Je n'était pas en face de la machine lors de la coupure, je suis donc incapable de garantir le status de la compilation à cet instant ( en cours ?, déjà interrompue ?).
Ptêt que je suis simplement en face d'un problème de ant-core sans conjoncture avec la coupure de courant.

Merci de votre attention.


Last edited by CaptainBlood on Fri Mar 05, 2010 1:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
CaptainBlood
Veteran
Veteran


Joined: 24 Jan 2010
Posts: 1008

PostPosted: Sun Jan 31, 2010 11:48 pm    Post subject: Reply with quote

Le problème est en fait lié au java-jdk déployé par le portage vuze en cas de défaut de java-sdk au démarrage de l'install.
La coupure de courant n'y était pour rien.

Soluce à https://bugs.gentoo.org/show_bug.cgi?id=302997

Merci de votre attention.
A+
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum