Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge problem [solved]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
andi_s
Apprentice
Apprentice


Joined: 10 Feb 2005
Posts: 226
Location: Germany

PostPosted: Mon Feb 01, 2010 5:01 pm    Post subject: emerge problem [solved] Reply with quote

hallo,

ich habe ein etwas nerviges problem:

Code:
emerge world --deep --update --newuse -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "gnome-base/gvfs[gnome]".
!!! One of the following packages is required to complete your request:
- gnome-base/gvfs-1.2.3 (Change USE: +gnome)
(dependency required by "gnome-base/libgnome-2.26.0" [ebuild])
(dependency required by "dev-db/mysql-gui-tools-5.0_p12-r3" [installed])
(dependency required by "world" [argument])


um "world" aktualisieren zu koennen muss ich erstmal
Code:
emerge -C mysql-gui-tools


eingeben - gefolgt von
Code:

emerge world --deep --update --newuse
emerge mysql-gui-tools


die mysql-gui-tools sind '~amd64' (daher kein grund sich zu beschweren), aber dennoch nervt es das ich so vorgehen muss(!?), wenn ich mein system aktuell halten will... zumal ich es auch merkwuerdig finde, das ich mit "world" aufgefordert werde +gnome in die useflags zu nehmen, es aber nach emerge -C und update world auch immer (musste diese prozedur schon mehrmals machen) wunderbar ohne +gnome (was ich nicht will) funktioniert!?

hat da jemand einen tipp (workaround oder mache ich etwas falsch?) oder kann man das als 'bug' bezeichnen, da die mysql-gui-tools sich ja auch ohne das angefordertete use-flag und die angeblichen abhaengigkeiten mergen lassen und auch einwandfrei funktionieren!?

danke


Last edited by andi_s on Tue Feb 02, 2010 2:41 pm; edited 1 time in total
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2225
Location: Germany

PostPosted: Mon Feb 01, 2010 5:27 pm    Post subject: Reply with quote

Hi,

hab da grade mal in den Abhängigkeiten nachgeforscht.

Code:
query-browser?
      ( gnome-extra/gtkhtml:3.14 gnome-base/libgnomeprint:2.2 gnome-base/libgnome )


Demnach will das Useflag query-browser von dem mysql-gui-tools wohl ein +gnome haben. Wenn du dieses Useflag auch nicht brauchst sollte ein

Code:
# echo "mysql-gui-tools -query-browser" >> /etc/portage/package.use
emerge -N mysql-gui-tools


Abhilfe schaffen.

Grüße
Back to top
View user's profile Send private message
Mr. Anderson
l33t
l33t


Joined: 22 Apr 2004
Posts: 761

PostPosted: Mon Feb 01, 2010 7:46 pm    Post subject: Reply with quote

Die Wurzel des Problems ist glaub in der indirekten Abhängigkeit gnome-base/libgnome selbst. Die will nämlich unbedingt das gnome-USE-Flag:

Code:
PDEPEND="gnome-base/gvfs[gnome]"


Dass er die Abhängigkeit beim separaten Emergen nicht bemängelt, liegt vermutlich daran, dass eine andere Version von gvfs bereits installiert ist. 2.26.0 ist nämlich die einzige Version von libgnome, die diese Abhängigkeit mit sich bringt, so weit ich das sehe. Mein Vorschlag wäre daher: gnome-base/libgnome-2.26.0 in package.mask maskieren oder gnome-base/libgnome-2.28.0 in package.keywords demaskieren.
Back to top
View user's profile Send private message
andi_s
Apprentice
Apprentice


Joined: 10 Feb 2005
Posts: 226
Location: Germany

PostPosted: Tue Feb 02, 2010 9:56 am    Post subject: Reply with quote

hallo,

@ChrisJumper
das useflag query-browser benoetige ich leider

@Mr.Anderson

das ist alles, was ich von gnome-base installiert habe (amd64 system):
Code:

[I--] [  ] gnome-base/gnome-common-2.26.0 (3)
[I--] [  ] gnome-base/gnome-desktop-2.24.3-r1 (0)
[I--] [  ] gnome-base/gnome-keyring-2.22.3-r1 (0)
[I--] [  ] gnome-base/gnome-menus-2.24.2 (0)
[I--] [  ] gnome-base/gnome-mime-data-2.18.0 (0)
[I--] [  ] gnome-base/gnome-mount-0.8 (0)
[I--] [  ] gnome-base/gnome-panel-2.24.3-r1 (0)
[I--] [  ] gnome-base/gnome-vfs-2.24.1 (2)
[I--] [  ] gnome-base/libgnome-2.24.1 (0)
[I--] [  ] gnome-base/libgnomecanvas-2.20.1.1 (0)
[I--] [  ] gnome-base/libgnomeprint-2.18.6 (2.2)
[I--] [  ] gnome-base/libgnomeui-2.24.1 (0)


also das mit 2.26.0 kann so nicht ganz stimmen, aber vielleicht erledigt sich das problem ja tatsaechlich irgendwann von selbst, wenn libgnome einen versionssprung macht... werde wohl erstmal damit leben muessen, wenn ich das richtig verstanden habe...

schade - dennoch, danke
Back to top
View user's profile Send private message
aleph-muc
Apprentice
Apprentice


Joined: 23 Jun 2004
Posts: 205
Location: Auf dem Land

PostPosted: Tue Feb 02, 2010 11:08 am    Post subject: Reply with quote

Hi andi_s,

was passiert denn, wenn du vor dem emerge ein
Code:
echo gnome-base/gvfs gnome >> /etc/portage/package.use

machst?

Gruß
aleph
Back to top
View user's profile Send private message
Mr. Anderson
l33t
l33t


Joined: 22 Apr 2004
Posts: 761

PostPosted: Tue Feb 02, 2010 11:29 am    Post subject: Reply with quote

andi_s wrote:
@Mr.Anderson

das ist alles, was ich von gnome-base installiert habe (amd64 system):
Code:

[I--] [  ] gnome-base/gnome-common-2.26.0 (3)
[I--] [  ] gnome-base/gnome-desktop-2.24.3-r1 (0)
[I--] [  ] gnome-base/gnome-keyring-2.22.3-r1 (0)
[I--] [  ] gnome-base/gnome-menus-2.24.2 (0)
[I--] [  ] gnome-base/gnome-mime-data-2.18.0 (0)
[I--] [  ] gnome-base/gnome-mount-0.8 (0)
[I--] [  ] gnome-base/gnome-panel-2.24.3-r1 (0)
[I--] [  ] gnome-base/gnome-vfs-2.24.1 (2)
[I--] [  ] gnome-base/libgnome-2.24.1 (0)
[I--] [  ] gnome-base/libgnomecanvas-2.20.1.1 (0)
[I--] [  ] gnome-base/libgnomeprint-2.18.6 (2.2)
[I--] [  ] gnome-base/libgnomeui-2.24.1 (0)


also das mit 2.26.0 kann so nicht ganz stimmen, aber vielleicht erledigt sich das problem ja tatsaechlich irgendwann von selbst, wenn libgnome einen versionssprung macht... werde wohl erstmal damit leben muessen, wenn ich das richtig verstanden habe...


Um. Da habe ich mich verschrieben. Ich meinte, dass bereits eine Version von libgnome installiert ist.

Wie Du siehst, ist gnome-base/libgnome-2.24.1 ja installiert. Bei einem emerge world --deep --update --newuse soll das auf nome-base/libgnome-2.26.0 aktualisiert werden. Mit 2.26.0 kommt auch die Abhängigkeit gvfs[gnome] rein.

Wenn Du hingegen emerge mysql-gui-tools ausführst, wird dabei libgnome-2.24.1 nicht aktualisiert, sondern so belassen.

Daher mein Vorschlag: gnome-base/libgnome-2.26.0 in der package.mask eintragen.
Back to top
View user's profile Send private message
andi_s
Apprentice
Apprentice


Joined: 10 Feb 2005
Posts: 226
Location: Germany

PostPosted: Tue Feb 02, 2010 2:05 pm    Post subject: Reply with quote

also,

sowohl =gnome-base/libgnome-2.26.0 in der package.mask als auch gnome-base/gvfs gnome in der package.use haben den selben effekt:

Code:

# emerge world --deep --update --newuse -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=net-libs/libsoup-2.25.1[gnome]".
!!! One of the following packages is required to complete your request:
- net-libs/libsoup-2.26.3-r3 (Change USE: +gnome)
(dependency required by "gnome-base/gvfs-1.2.3" [ebuild])
(dependency required by "gnome-base/libgnome-2.24.1" [installed])
(dependency required by "dev-db/mysql-gui-tools-5.0_p12-r3" [installed])
(dependency required by "world" [argument])


hmm...
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4459

PostPosted: Tue Feb 02, 2010 2:08 pm    Post subject: Reply with quote

öhm jetzt haste eine etwas andere Fehlermeldung ;) scheinbar muss auch für libsoup das gnome flag gesetzt sein, bzw. du müsstest die neuere version auch maskieren.
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
andi_s
Apprentice
Apprentice


Joined: 10 Feb 2005
Posts: 226
Location: Germany

PostPosted: Tue Feb 02, 2010 2:40 pm    Post subject: Reply with quote

ja, habe ich gesehen ;)

ich habe nun libsoup und gvfs mit gnome-useflag emerged (...) - nun funktioniert auch das world update...

danke.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum