Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] inkscape & libpoppler.so.?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1167
Location: Eppingen, Germany

PostPosted: Fri Feb 05, 2010 9:11 pm    Post subject: [gelöst] inkscape & libpoppler.so.? Reply with quote

Mein inkscape startet nicht, weil er libpoppler.so.4/5 etc nicht fnden kann.

libpoppler.so.4 gehört zu dev-libs/poppler also habe ich ein emerge dev-libs/poppler verscuht. Danach meckerte inkscape über ein fehlendes libpoppler.so.5.

Ein "Rundum"-Schlag klappt auch nicht:

Code:
HOSTNAME=Tux uhai # emerge -av inkscape

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] app-text/poppler-0.12.3-r3  USE="abiword cairo jpeg jpeg2k lcms png qt4 utils xpdf-headers -cjk -debug -doc -exceptions" 0 kB
[ebuild   R   ] media-gfx/inkscape-0.47  USE="dia gnome inkjar lcms nls postscript spell wmf -debug (-mmx)" 0 kB                             
[blocks B     ] app-text/poppler ("app-text/poppler" is blocking dev-libs/poppler-0.10.7, dev-libs/poppler-qt4-0.10.7)
[blocks B     ] dev-libs/poppler ("dev-libs/poppler" is blocking app-text/poppler-0.12.3-r3)
[blocks B     ] dev-libs/poppler-qt4 ("dev-libs/poppler-qt4" is blocking app-text/poppler-0.12.3-r3)

Total: 2 packages (1 new, 1 reinstall), Size of downloads: 0 kB
Conflict: 3 blocks (3 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('installed', '/', 'dev-libs/poppler-0.10.7', 'nomerge') pulled in by
    dev-libs/poppler required by world

  ('installed', '/', 'dev-libs/poppler-qt4-0.10.7', 'nomerge') pulled in by
    dev-libs/poppler-qt4 required by world

  ('ebuild', '/', 'app-text/poppler-0.12.3-r3', 'merge') pulled in by
    ~app-text/poppler-0.12.3[cairo] required by ('installed', '/', 'virtual/poppler-glib-0.12.3-r2', 'nomerge')


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


Dummerweise muss ich ganz schnell mit inkscape noch eine Grafik fertigmachen. Die Blocks bekomme ich nicht geknackt. Wie kann ich inkscape noch zum laufen bringen?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org


Last edited by uhai on Sat Feb 06, 2010 12:40 pm; edited 1 time in total
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3716
Location: Germany

PostPosted: Fri Feb 05, 2010 11:48 pm    Post subject: Reply with quote

Hi Uhai

Das ist das normale poppler Update welches es vor ein paar Wochen gab, das solltest du erst mal sauber durchbringen,
denn die von inkscape vermisste "libpoppler.so.5" ist im neuen Paket vorhanden
Code:
# equery b libpoppler.so.5
 * Searching for libpoppler.so.5 ...
app-text/poppler-0.12.3-r3 (/usr/lib/libpoppler.so.5 -> libpoppler.so.5.0.0)


Um dieses Update durchzubekommen solltest du erst mal alle installierten poppler Pakete deinstallieren, dann sollte es "normal" problemlos mit dem Update klappen, und keine Blocks mehr geben.
Hier mal ein Befehl der alle installierten poppler Pakete deinstallieren würde
Code:
# emerge -avC $(qlist -I -C poppler)
(hierfür muss portage-utils installiert sein)

Versuche danach dann zb ein
Code:
emerge -avuDNt media-gfx/inkscape
(oder gar world) und danach ein
Code:
# revdep-rebuild -i
fehlerfrei durchzubringen.

Ansonsten schau auch mal hier: https://forums.gentoo.org/viewtopic-t-812718-start-0-postdays-0-postorder-asc-highlight-.html
da wurde auch schon einiges zu diesem Update erwähnt.

Viel Erfolg
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1167
Location: Eppingen, Germany

PostPosted: Sat Feb 06, 2010 12:40 pm    Post subject: Reply with quote

ok, so vollständig habe ich die popplers bisher noch nicht ersetzt. Das funktionier. Den anderen Thread hatte ich nicht gefunden, sorry.

Danke für Deine Hilfe, Grafik ist fertig.

uha
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum