Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
hplip 3.9.12-R1 fails somewhere ? [Solved]
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
magowiz
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1029
Location: Italy/Milan/Bresso

PostPosted: Thu Feb 18, 2010 9:13 pm    Post subject: Reply with quote

aCOSwt wrote:

Happy you managed to sort it out.
That is the common factor to all our problems with hplip... we incidentally manage to make it work... but we cannot tell exactly why... :twisted:


Yes it's true :D anyway I'm pretty sure that doing all these things solves the problem , apart re-emerge ghoscript, all these things can be done in 1 or 2 minutes so it could be an acceptable solution.

I also tried to fully remove the printer (since HP-systray claims about no printers installed) and re-install it using hp-systray and it worked. Perhaps I could solve this to simply remove the printer and reinstall using hplip given procedure .
Back to top
View user's profile Send private message
cybertronix
Tux's lil' helper
Tux's lil' helper


Joined: 25 Aug 2004
Posts: 97
Location: Minnesota

PostPosted: Fri Feb 19, 2010 7:01 am    Post subject: Reply with quote

I ran into the same problem after the upgrade to 3.9.12, and I thought I would just let everyone know that the thing that finally got it working for me was doing a "Modify Printer" in CUPS, and switching the PPD from the foomatic/hpijs one to one without the foomatic/hpijs following the printer model. For my Deskjet 3745 there were actually three in the list - two with foomatic/hpijs and one without. Apparently the one without is the new hpcups driver.
Back to top
View user's profile Send private message
magowiz
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1029
Location: Italy/Milan/Bresso

PostPosted: Fri Feb 19, 2010 7:32 am    Post subject: Reply with quote

cybertronix wrote:
I ran into the same problem after the upgrade to 3.9.12, and I thought I would just let everyone know that the thing that finally got it working for me was doing a "Modify Printer" in CUPS, and switching the PPD from the foomatic/hpijs one to one without the foomatic/hpijs following the printer model. For my Deskjet 3745 there were actually three in the list - two with foomatic/hpijs and one without. Apparently the one without is the new hpcups driver.


That's make sense , perhaps also in my case the "real" solution was to modify the PPD, thank you for reporting.
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Fri Feb 19, 2010 4:03 pm    Post subject: Reply with quote

In fact, I will keep that in mind :P
Back to top
View user's profile Send private message
aCOSwt
Bodhisattva
Bodhisattva


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Fri Feb 19, 2010 5:35 pm    Post subject: Reply with quote

d2_racing wrote:
In fact, I will keep that in mind :P

<trolling>
Hmmm... Could you keep this elsewhere too ?
</trolling>
No disrespect meant of course d2
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum