Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Beamerbild auf Notebookdisplay
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
solos
n00b
n00b


Joined: 26 Feb 2008
Posts: 49

PostPosted: Sat Feb 13, 2010 1:55 pm    Post subject: Beamerbild auf Notebookdisplay Reply with quote

Hallo Forum,

ich habe mal wieder ein Problem und das schon ziemlich lange. Ich habe es bisher noch nie geschafft einen Beamer erfolgreich an mein Notebook anzuschließen.
Wenn ich einen Beamer an den VGA-Ausgang anschließe, erkennt dies Xorg auch und pasts das Bild dementsprechend an, allerdings nur auf meinem Notebookdisplay. Wenn ich die Displays identifizieren lasse erscheint eine 1 auf dem Notebookdisplay was auch das Notebookdisplay sein soll, allerdings erscheint die 2 für das Beamerbild ebenfalls auf dem Notebookdisplay. Er gibt also das Beamerbild ebenfalls nur auf dem Notebookdisplay aus, der Beamer zeigt nichts an.

Da ich wegen einem BIOS-Update Windows installieren musste habe ich das dort auch getestet, leider mit dem selben Ergebnis. Mir scheints fast so als wäre meine Grafikkarte defekt? Kennt jemand das Problem oder kann mir sagen was ich noch versuchen könnte? Ich bin mittlerweile ratlos.

die xorg.conf ist fast leer, die ganzen Displayoptionen macht Hal.

Code:
xrandr
Screen 0: minimum 320 x 200, current 1280 x 800, maximum 2048 x 2048
VGA connected (normal left inverted right x axis y axis)
   1440x900       59.9 +   75.0     59.9 
   1280x1024      75.0     60.0 
   1280x960       60.0 
   1152x864       75.0 
   1024x768       75.0     70.1     60.0 
   832x624        74.6 
   800x600        72.2     75.0     60.3     56.2 
   640x480        75.0     72.8     66.7     59.9 
   720x400        70.1 
LVDS connected 1280x800+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
   1280x800       60.0*+
   1024x768       85.0     75.0     70.1     60.0 
   832x624        74.6 
   800x600        85.1     72.2     75.0     60.3     56.2 
   640x480        85.0     72.8     75.0     59.9 
   720x400        85.0 
   640x400        85.1 
   640x350        85.1 
TV disconnected (normal left inverted right x axis y axis)


Code:
lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)


xorg.log Auszug:
Code:
(II) intel(0): Output configuration:
(II) intel(0):   Pipe A is on
(II) intel(0):   Display plane B is now enabled and connected to pipe A.
(II) intel(0):   Pipe B is on
(II) intel(0):   Display plane A is now enabled and connected to pipe B.
(II) intel(0):   Output VGA is connected to pipe A
(II) intel(0):   Output LVDS is connected to pipe B
(II) intel(0):   Output TV is connected to pipe none
Back to top
View user's profile Send private message
wuesti
Apprentice
Apprentice


Joined: 07 Mar 2009
Posts: 191

PostPosted: Sat Feb 13, 2010 7:40 pm    Post subject: Reply with quote

Hast du das USE-Flag xinerama gesetzt?

Auf meinem xubuntu-laptop klappt es so:
Code:
/usr/bin/xrandr --output LVDS --auto --output VGA --off
/usr/bin/xrandr --output LVDS --auto --output VGA --auto --right-of LVDS

Die erste Zeile setzt den LVDS als Hauptbildschirm. Erst dann kann ich sinnvoll umschalten.
Back to top
View user's profile Send private message
solos
n00b
n00b


Joined: 26 Feb 2008
Posts: 49

PostPosted: Sat Feb 13, 2010 9:55 pm    Post subject: Reply with quote

Hi,

das funktioniert zwar, aber leider nur so wie ichs erwartet hatte. Mein Notebookdisplay schaltet auf 1440x900 um und xrandr zeigt das beide Bildschirma aktiv sind. Leider aber nur wieder auf meinem Notebook. Der Beamer (bzw. bei dem aktuellen Test der externe Monitor) bleibt dunkel.

Code:
xrandr
Screen 0: minimum 320 x 200, current 1440 x 900, maximum 2048 x 2048
VGA connected 1440x900+0+0 (normal left inverted right x axis y axis) 410mm x 257mm
   1440x900       59.9*+   75.0     59.9*
   1280x1024      75.0     60.0 
   1280x960       60.0 
   1152x864       75.0 
   1024x768       75.0     70.1     60.0 
   832x624        74.6 
   800x600        72.2     75.0     60.3     56.2 
   640x480        75.0     72.8     66.7     59.9 
   720x400        70.1 
LVDS connected 1280x800+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
   1280x800       60.0*+
   1024x768       85.0     75.0     70.1     60.0 
   832x624        74.6 
   800x600        85.1     72.2     75.0     60.3     56.2 
   640x480        85.0     72.8     75.0     59.9 
   720x400        85.0 
   640x400        85.1 
   640x350        85.1 
TV disconnected (normal left inverted right x axis y axis)
Back to top
View user's profile Send private message
wuesti
Apprentice
Apprentice


Joined: 07 Mar 2009
Posts: 191

PostPosted: Sun Feb 14, 2010 9:13 am    Post subject: Reply with quote

[quote="solos"]
Code:
xrandr
Screen 0: minimum 320 x 200, current 1440 x 900, maximum 2048 x 2048
VGA connected 1440x900+0+0 (normal left inverted right x axis y axis) 410mm x 257mm
   1440x900       59.9*+   75.0     59.9*
LVDS connected 1280x800+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
   1280x800       60.0*+


Sind das denn die für die Bildschirme richtigen Auflösungen?

Ansonsten mal versuchen:
Code:
xrandr --output VGA --mode 640x480
Back to top
View user's profile Send private message
furanku
l33t
l33t


Joined: 08 May 2003
Posts: 902
Location: Hamburg, Germany

PostPosted: Mon Feb 15, 2010 12:43 pm    Post subject: Reply with quote

Das ist jetzt nur ein "ungezielter Schuß aus Hüfte", aber versuch doch mal vor dem Anschließen des Beamers mit "Strg + Alt + F1" auf eine Konsole umzuschalten, dann den Beamer anschließen und ggf. mit "Fn + F7" auf den Beamer umschalten (ist zumindest bei Thinkpads z.B. die entsprechende Tastenkombination) und wenn das klappt mit "Strg + Alt + F7" wieder auf X zurückzuschalten. So haben wir zumindest bei uns in der Arbeitsgruppe ein paar alte, störrische Notebooks ausgetrickst.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum