Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge portage failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
jurgen69
n00b
n00b


Joined: 26 Sep 2009
Posts: 31
Location: London

PostPosted: Wed Feb 17, 2010 9:21 pm    Post subject: emerge portage failed Reply with quote

Hi,

This is the error that I get when trying to emerge portage.

I'm uncertain of how I should cure this problem, any help would be much appreciated.

Code:

vdr01 ~ # emerge portage
Calculating dependencies... done!
>>> Verifying ebuild Manifests...
>>> starting parallel fetching

>>> Emerging (1 of 2) dev-lang/python-2.5.4-r4 to /
 * Python-2.5.4.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                                                    [ ok ]
 * python-gentoo-patches-2.5.4-r3.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                                  [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                                       [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                                      [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                                     [ ok ]
 * checking Python-2.5.4.tar.bz2 ;-) ...                                                                                                                                   [ ok ]
 * checking python-gentoo-patches-2.5.4-r3.tar.bz2 ;-) ...                                                                                                                 [ ok ]
 * "bsddb" module is out-of-date and no longer maintained inside dev-lang/python. It has
 * been additionally removed in Python 3. You should use external, still maintained "bsddb3"
 * module provided by dev-python/bsddb3 which supports both Python 2 and Python 3.
 * It is highly recommended to additionally install Python 3, but without configuring Python wrapper to use Python 3.
 *
 * ERROR: dev-lang/python-2.5.4-r4 failed.
 * Call stack:
 *                ebuild.sh, line 1717:  Called dyn_setup
 *                ebuild.sh, line  768:  Called qa_call 'pkg_setup'
 *                ebuild.sh, line   44:  Called pkg_setup
 *   python-2.5.4-r4.ebuild, line   68:  Called built_with_use 'sys-devel/gcc' 'libffi'
 *            eutils.eclass, line 1847:  Called die
 * The specific snippet of code:
 *                                      die)   die "$PKG does not actually support the $1 USE flag!";;
 *  The die message:
 *   sys-devel/gcc-4.1.2 does not actually support the libffi USE flag!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/log/portage/dev-lang:python-2.5.4-r4:20100217-214514.log'.


I have included my emerge --info
Code:

Portage 2.1.3.19 (default/linux/x86/10.0, gcc-4.1.2, glibc-2.5-r4, 2.6.23.11-gentoo i686)
=================================================================
System uname: 2.6.23.11-gentoo i686 Intel(R) Pentium(R) 4 CPU 3.20GHz
Timestamp of tree: Wed, 17 Feb 2010 20:00:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r1
sys-devel/gcc:       4.1.2
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.23-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium4 -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=pentium4 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp:///ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://ftp.gentoo.skynet.be/pub/gentoo/ http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/"
LANG="en_US"
LC_ALL="de_DE@euro"
LDFLAGS="-Wl,-O1 -Wl,--enable-new-dtags -Wl,--sort-common -s"
LINGUAS="de"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/gentoo-de /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa apache2 arts automount avahi berkdb bluetooth bzip2 cairo cardbus cddb cdr cli cracklib crypt cups cxx dbus directfb dmx dri dv dvb dvd dvdr dvdread dxr3 encode exif fbcon fbcondecor ffmpeg fftw flac fortran ftp gd gdbm gif glitz glut gpm gs gtk gtk2 hal hddtemp iconv ieee1394 imagemagick imap imlib ipod ipv6 irda ithreads java joystick jpeg kde kdehiddenvisibility latin1 lcms libwww lirc lm_sensors logrotate mad mmx modules motif mp3 mp4 mp4live mpeg mplayer mudflap mysql ncurses network nls nptl nvidia ogg opengl openmp oss pam pcre pda pdf perl php png pppd python qt3 quicktime rdesktop readline reflection samba scanner sdl session slang sndfile spell spl sse ssl svg svga sysfs tcpd tiff transcode truetype unicode usb v4l v4l2 vcd vorbis wifi x264 x86 xcomposite xine xinerama xml xorg xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="joystick keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text cfontzpacket cwlinux eyeboxone graphlcd icpa106 imon iowarrior lcterm md8800 ms6931 mtcs16209x noritakevfd pyramid sed1330 sed1520 serialvfd sli stv5730 svga t6963 tyan xosd" LINGUAS="de" LIRC_DEVICES="all" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev fglrx i810 mga nv nvidia r128 radeon s3 savage sis via v4l vesa vga vmware"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Many thanks
Back to top
View user's profile Send private message
mikegpitt
Advocate
Advocate


Joined: 22 May 2004
Posts: 3221

PostPosted: Wed Feb 17, 2010 9:34 pm    Post subject: Reply with quote

Am I correct in assuming that you are updating a pretty old install? It looks like the source of your problem is related to gcc. Perhaps you should try updating gcc, then move on to python, and then portage.

Also, have you performed an `emerge --sync` and updated to the latest profile? I only ask, because the latest python is 2.6 and your emerge was trying for 2.5.
Back to top
View user's profile Send private message
jurgen69
n00b
n00b


Joined: 26 Sep 2009
Posts: 31
Location: London

PostPosted: Wed Feb 17, 2010 9:50 pm    Post subject: Reply with quote

Hi,

Thanks for you reply.

My system is a pre-compiled binary called Gen2vdr. I am using this profile

I have emerge --sync and the profile I'm using is:

Code:

/usr/portage/profiles/default/linux/x86/10.0


If I try to emerge sys-devel/gcc I get the following error:
Code:

vdr01 ~ # emerge sys-devel/gcc
Calculating dependencies /
!!! All ebuilds that could satisfy ">=sys-libs/glibc-2.8" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-libs/glibc-2.8_p20080602-r1 (masked by: package.mask)
/etc/portage/package.mask:
# glibc > 2.5 will break em84xx

- sys-libs/glibc-2.9_p20081201-r2 (masked by: package.mask)
- sys-libs/glibc-2.9_p20081201-r3 (masked by: package.mask, ~x86 keyword)
- sys-libs/glibc-2.10.1 (masked by: package.mask, ~x86 keyword)
- sys-libs/glibc-2.10.1-r1 (masked by: package.mask)
- sys-libs/glibc-2.11 (masked by: package.mask, ~x86 keyword)
- sys-libs/glibc-2.11-r1 (masked by: package.mask, ~x86 keyword)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "sys-devel/gcc-4.3.4" [ebuild])
Back to top
View user's profile Send private message
mikegpitt
Advocate
Advocate


Joined: 22 May 2004
Posts: 3221

PostPosted: Wed Feb 17, 2010 9:58 pm    Post subject: Reply with quote

I think what's happening is that your portage overlays are out of date and are blocking the updates. Comment out or remove the PORTDIR_OVERLAY line(s) in your /etc/make.conf.

BTW - I'm not sure what your end goal is, but you might have an easier time just starting from scratch with gentoo vs. updating your current install.
Back to top
View user's profile Send private message
jurgen69
n00b
n00b


Joined: 26 Sep 2009
Posts: 31
Location: London

PostPosted: Wed Feb 17, 2010 10:17 pm    Post subject: Reply with quote

Unfortunately commenting out the PORTDIR_OVERLAY line doesn't make any difference

I'm using this system because up until now it worked, all I have to do to have a working VDR system in 30 minutes is put the ISO in the drive.

I would like to build my own Gentoo system and have tried on a couple of occasions, but I have so far compiled 2 or 3 un-bootable kernels, I also ran in to masked package problems with VDR.

Gen2vdr also comes with a lot of built-in scripts to detect new DVB cards and other handy features.

I'm updating my system because I have a new DVB card, and I'm having trouble loading the firmware and drivers.

That aside I'm keen to learn, and I am going to try to load anther system in the future.

Thank you for your help
Back to top
View user's profile Send private message
mikegpitt
Advocate
Advocate


Joined: 22 May 2004
Posts: 3221

PostPosted: Wed Feb 17, 2010 10:25 pm    Post subject: Reply with quote

I didn't read the output above carefully enough before. It also looks like you have some entries in your /etc/portage/package.mask specifically blocking the glibc update. Try commenting those out as well and rerun...
Back to top
View user's profile Send private message
jurgen69
n00b
n00b


Joined: 26 Sep 2009
Posts: 31
Location: London

PostPosted: Wed Feb 17, 2010 10:31 pm    Post subject: Reply with quote

I don't understand what I have to do here, do I just remove the comment form in front of the glibc line?

Code:

>=x11-libs/qt-4
sys-fs/cdfs
=media-tv/linuxtv-dvb-firmware-2007.04.13
# glibc > 2.5 will break em84xx
>=sys-libs/glibc-2.6
#bootsplash don't work with newer version
#>media-gfx/splashutils-1.4.2
>dev-python/kaa-base-0.1.3-r1
>dev-python/kaa-imlib2-0.2.1
>dev-python/kaa-metadata-0.6.1-r1
>media-tv/freevo-1.8.0
=media-sound/esound-0.2.38-r1
#>media-video/mplayer-1.0.20070622-r1
#<media-video/mplayer-1.0.20070622-r1
>media-video/mplayer-1.0_rc2
Back to top
View user's profile Send private message
mikegpitt
Advocate
Advocate


Joined: 22 May 2004
Posts: 3221

PostPosted: Wed Feb 17, 2010 10:51 pm    Post subject: Reply with quote

You should comment out this line:
Code:
>=sys-libs/glibc-2.6

Of course, heed the warning on the commented line above this that says the newer glibc will break em84xx support. I'm not sure if that is still true or not, since glibc-2.5 is quite old at this point. I'm also not sure if you would require such support in your setup.
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9236
Location: beyond the rim

PostPosted: Wed Feb 17, 2010 10:55 pm    Post subject: Reply with quote

The best course of action would be to tell whoever provides that image that it seriously needs to be updated. Portage-2.1.3 is from 2006 or 2007, and updating such a system is going to be a real pain.
Back to top
View user's profile Send private message
jurgen69
n00b
n00b


Joined: 26 Sep 2009
Posts: 31
Location: London

PostPosted: Thu Feb 18, 2010 12:07 am    Post subject: Reply with quote

Thanks Mike, I will try:
Code:

#>=sys-libs/glibc-2.6

But, I think I'll take your advice and start form scratch.

Genone, I think there is a latter version of Gen2vdr due for release, so if I can't build my own then I'll wait for the next release.
Back to top
View user's profile Send private message
timeBandit
Bodhisattva
Bodhisattva


Joined: 31 Dec 2004
Posts: 2674
Location: here, there or in transit

PostPosted: Fri Feb 19, 2010 3:29 pm    Post subject: Reply with quote

Moved from Portage & Programming to Unsupported Software.
Gen2vdr != Gentoo, therefore unsupported.
_________________
Plants are pithy, brooks tend to babble--I'm content to lie between them.
Super-short f.g.o checklist: Search first, strip comments, mark solved, help others.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum