Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nagios/apache2: Unrecognized character \\x7F at /usr/lib/na
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Sheldon
n00b
n00b


Joined: 12 Oct 2007
Posts: 47
Location: Mömbris

PostPosted: Wed Feb 17, 2010 10:48 pm    Post subject: nagios/apache2: Unrecognized character \\x7F at /usr/lib/na Reply with quote

Calling the startpage of nagios acts correct. however accessing a cgi-function leads to the following error in the error_log:

[error] Unrecognized character \\x7F at /usr/lib/nagios/cgi-bin/avail.cgi line 1.\n

The code in avail.cgi seems to be compiled(?). How do I have to tell apache to execute this code in the right way? or
is nagios installed in the wrong way?

Executing a perl-script works in the right manner.
Back to top
View user's profile Send private message
richard.scott
Veteran
Veteran


Joined: 19 May 2003
Posts: 1497
Location: Oxfordshire, UK

PostPosted: Thu Feb 25, 2010 4:11 pm    Post subject: Reply with quote

does this help:

http://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg62427.html
Back to top
View user's profile Send private message
Sheldon
n00b
n00b


Joined: 12 Oct 2007
Posts: 47
Location: Mömbris

PostPosted: Thu Feb 25, 2010 10:28 pm    Post subject: Reply with quote

Oh, thank's for info. But I already found this site and some few others. This problem seems to be seldom.
By now I think, it is a problem of my apache2 installation. But I don't see it. In the meantime I compiled apache with
all possible modules.Php with cgi option. But this didn't help. Anyhow my apache-installation/configuration does not like a ELF-Compilat, what ever this is.
Back to top
View user's profile Send private message
richard.scott
Veteran
Veteran


Joined: 19 May 2003
Posts: 1497
Location: Oxfordshire, UK

PostPosted: Fri Feb 26, 2010 9:48 am    Post subject: Reply with quote

Does your apache build have the "suexec" flag set?
Back to top
View user's profile Send private message
Sheldon
n00b
n00b


Joined: 12 Oct 2007
Posts: 47
Location: Mömbris

PostPosted: Sat Feb 27, 2010 12:30 am    Post subject: Reply with quote

Nop.
Somewhen my subconscious told me, that suexec sounds like it could've to do s.th. with it. The other hand it has to do s.th. with
permissions. And because I can execute perl-scripts from the cgi-bin-directory, I thought ...
I will compile the apche with this flag set and report ...
Back to top
View user's profile Send private message
richard.scott
Veteran
Veteran


Joined: 19 May 2003
Posts: 1497
Location: Oxfordshire, UK

PostPosted: Sat Feb 27, 2010 12:45 pm    Post subject: Reply with quote

AFAIK you need suexec so you can execute progs as the "nagios" user as this is who owns them.
Back to top
View user's profile Send private message
Sheldon
n00b
n00b


Joined: 12 Oct 2007
Posts: 47
Location: Mömbris

PostPosted: Sat Feb 27, 2010 8:14 pm    Post subject: Reply with quote

Oh my goodness! I shoot myself in the foot!!!

Someone suggested, to configure Apache like this:

<Files ~ "\.(pl|cgi)$"> (instead of <Location /cgi-perl/*.pl>)
SetHandler perl-script
....

to get all perl-scripts executed, irregardless the location.
So, everything with .cgi at it's tail was interpreted in that one way or so.

I changed the adjustment and now it works (for the moment by all means).

Thanks for all hints.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum