Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
pulseaudio not seing the audiocard
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
potuz
Guru
Guru


Joined: 30 Jan 2010
Posts: 378

PostPosted: Thu Feb 18, 2010 11:21 pm    Post subject: pulseaudio not seing the audiocard Reply with quote

Hello list, on a fresh install on a powerbook g4. Alsa and gstreamer are working fine as the following
Code:
gst-launch-0.10 filesrc location=1.mp3 ! mad ! audioconvert ! audioresample ! alsasink
produces audio. Changing the default alsa pcm to pulse (alsa-plugins installed) and
Code:
gst-launch-0.10 playbin uri=file:///1.mp3
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: GstPulseSinkClock

No audio. Pavucontrol doesn't find any hardware card, and the only output possible is the Dummy one.

My sound card is driven by snd-powermac which is not found automatically by the init script so I had to
Code:
alias snd-card-0 snd-powermac
on /etc/modprobe.d/alsa.conf

booting up I see a line like this just after loading the module:
Code:
udevd-work[4638]: error opening ATTR{/sys/class/sound/controlC0/../uevent} for writing: No such file or directory
but I am not sure it is related.

Any help would be appreciated. Even good advice as to how to get rid of pulseaudio might work. I built all of gnome with the USE="pulseaudio" flag, so I'm not sure how safe is it to go with emerge --unmerge pulseaudio.
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Fri Feb 19, 2010 11:27 am    Post subject: Reply with quote

don´t know if this is related or not but here it goes :

Quote:
My sound card is driven by snd-powermac


if it works then you are done i suppose, but my powerbook uses the so called "apple onboard audio driver" instead of the the snd-powermac driver.
BTW, alsaconf or alsa´s init script don´t detect the card here either and never did IIRC.

Quote:
Even good advice as to how to get rid of pulseaudio might work. I built all of gnome with the USE="pulseaudio" flag, so I'm not sure how safe is it to go with emerge --unmerge pulseaudio.


sure you can get rid of pulseaudio, it just is another sound daemon after all which isn´t needed in case you just want to play some music or movies.
I think pulseaudio isn´t enabled by default in any profile so removing pulseaudio from your USE´s in your make.conf file ( if that´s the case) and rebuilding all packages that have a pulseaudio flag afterwards should do it. It can be easily done with emerge´s -N switch.

cheers
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
potuz
Guru
Guru


Joined: 30 Jan 2010
Posts: 378

PostPosted: Fri Feb 19, 2010 4:59 pm    Post subject: Reply with quote

Well, I figured that if the initscript didn't detect the card, then hal and udev wont detect it for pulseaudio either. So explicitly asking to load the alsa module in default.pa did the trick and I have a functioning pulseaudio. Which by the way I like cause I don't know any other way of streaming to an airport express. I'm still experiencing overheating and related shutdowns on performance governor though :( but that's part of the other thread.

Thanks,

R.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum