Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Xorg] Clavier non fonctionnel (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
SnowBear
l33t
l33t


Joined: 03 Sep 2005
Posts: 729
Location: Dax [40]

PostPosted: Wed Feb 17, 2010 3:52 pm    Post subject: [Xorg] Clavier non fonctionnel (résolu) Reply with quote

Bonjour à tous,

Installation toute fraiche et je rencontre déjà mes premiers problèmes :D (qui a dit que j'étais rouillé !!! ).

La machine est un portable Acer Aspire One. En console le clavier fonctionne parfaitement.

Mon make.conf :
Quote:
CFLAGS="-O2 -march=core2 -mtune=generic -mssse3 -mfpmath=sse -fomit-frame-pointer -pipe"
CXXFLAGS="${CFLAGS}"
CHOST="i686-pc-linux-gnu"
MAKEOPTS="-j2"

(...)

VIDEO_CARDS="intel"
INPUT_DEVICES="synaptics evdev keyboard"

USE_EXCLUDE="-ipv6"
USE_ADD="X acpi alsa dbus hal laptop theora v4l v4l2 xcb"
USE="${USE_EXCLUDE} ${USE_ADD}"


Le xorg.conf :
Quote:
Section "ServerFlags"
Option "DontZap" "yes"
Option "DontVTSwitch" "yes"
EndSection

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/TTF/"
FontPath "/usr/share/fonts/OTF"
FontPath "/usr/share/fonts/100dpi/"
FontPath "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "glx"
Load "xtrap"
Load "record"
Load "dri"
Load "freetype"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "synaptics"
Option "Protocol" "auto"
Option "Device" "/dev/input/mouse0"
Option "ZAxisMapping" "4 5 6 7"
Option "Corepointer"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
EndSection


Section "Monitor"
DisplaySize 190 110 # mm
Identifier "Monitor0"
VendorName "LGD"
ModelName "17f"
EndSection

Section "Monitor"
Identifier "Monitor1"
EndSection


Section "Device"
Option "NoDDC"
Identifier "Card0"
Driver "intel"
VendorName "Intel Corporation"
BoardName "Unknown Board"
BusID "PCI:0:2:0"
Option "AccelMethod" "exa"
Option "MigrationHeuristic" "greedy"
Option "Clone" "true"
Option "monitor-LVDS" "Monitor0"
Option "monitor-VGA" "Monitor1"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Modes "1024*600"
Depth 24
EndSubSection
EndSection


Mon Xorg.log (réduit :D )
Quote:

(...)
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Keyboard0
(...)
(II) Initializing built-in extension XKEYBOARD


Si quelqu'un à une idée parce que là je n'arrive pas à comprendre pourquoi il ne veut pas du clavier :D .

Merci d'avance.
Back to top
View user's profile Send private message
SnowBear
l33t
l33t


Joined: 03 Sep 2005
Posts: 729
Location: Dax [40]

PostPosted: Wed Feb 17, 2010 5:01 pm    Post subject: Reply with quote

Résolu en démarrant hald... (et accessoirement en simplifiant mon xorg.conf).
Back to top
View user's profile Send private message
engil
Tux's lil' helper
Tux's lil' helper


Joined: 22 Nov 2005
Posts: 117
Location: France

PostPosted: Wed Feb 17, 2010 5:02 pm    Post subject: Reply with quote

Tu as compilé ton système avec le Use "hal", tu ne devrais pas avoir besoin de section INPUT dans xorg.conf, voir pas de xorg.conf du tout.

Edit : arf, grilled :D
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8078
Location: ~Brussels - Belgique

PostPosted: Wed Feb 17, 2010 6:27 pm    Post subject: Reply with quote

Salut,

J'ai un acer aspire one... et un xorg.conf absent.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
SnowBear
l33t
l33t


Joined: 03 Sep 2005
Posts: 729
Location: Dax [40]

PostPosted: Wed Feb 17, 2010 7:05 pm    Post subject: Reply with quote

XavierMiller wrote:
Salut,

J'ai un acer aspire one... et un xorg.conf absent.


ça risque se finir comme ça aussi ;) .
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Thu Feb 18, 2010 3:45 am    Post subject: Reply with quote

Présentement c'est le cas, mais avec Xorg-Server 1.8, on va devoir créer des règles udev pour configurer nos trucs il parraît.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8078
Location: ~Brussels - Belgique

PostPosted: Thu Feb 18, 2010 8:38 am    Post subject: Reply with quote

On ne pourrait pas avoir un jour un système de configuration STABLE ?
Genre : un xorg.conf ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Thu Feb 18, 2010 12:42 pm    Post subject: Reply with quote

Apparement non :P

https://forums.gentoo.org/viewtopic-t-815885-highlight-.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum