Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] [x11-overlay] xorg-server-9999 fails to build
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
GD
Tux's lil' helper
Tux's lil' helper


Joined: 11 May 2005
Posts: 134
Location: Greece

PostPosted: Tue Feb 23, 2010 5:06 pm    Post subject: [SOLVED] [x11-overlay] xorg-server-9999 fails to build Reply with quote

Hello,

xorg-server-9999 has been failing to build a couple (?) of days now. the problem seems to be upstream but a few workarounds had been proposed around the net... the error is:

Code:
glxdri2.c: In function '__glXDRIdrawableSwapBuffers':
glxdri2.c:221: error: '__DRI2flushExtension' has no member named 'flushInvalidate'


You might want to check:

http://bbs.archlinux.org/viewtopic.php?pid=714404
http://www.spinics.net/lists/xorg/msg48798.html (I don't have the mesa issues described there though)

Is there a way to include the proposed solutions into the ebuild? Thanks


Last edited by GD on Wed Feb 24, 2010 5:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5387

PostPosted: Tue Feb 23, 2010 6:19 pm    Post subject: Reply with quote

have you thought of notifying upstream? or wait a couple of days till it will be fixed?
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
GD
Tux's lil' helper
Tux's lil' helper


Joined: 11 May 2005
Posts: 134
Location: Greece

PostPosted: Wed Feb 24, 2010 5:51 pm    Post subject: Reply with quote

Apparently it was fixed upstream a few hours ago, so everything's ok now :-D
Back to top
View user's profile Send private message
chrelad
n00b
n00b


Joined: 03 Sep 2008
Posts: 9

PostPosted: Wed Apr 14, 2010 8:50 pm    Post subject: Not okay... Reply with quote

GD wrote:
Apparently it was fixed upstream a few hours ago, so everything's ok now :-D

Hmmm, I've been trying to get the latest xorg-server from the x11 overlay for about two weeks now with the same error every time:
Code:

glxdri2.c: In function '__glXDRIdrawableSwapBuffers':
glxdri2.c:227: error: '__DRI2flushExtension' has no member named 'flushInvalidate'
make[1]: *** [glxdri2.lo] Error 1

I've tried looking at the API documentation to see what the code *should* be, as well as reverting to old commits. Nothing has worked for me so far.

Any ideas? :?
Back to top
View user's profile Send private message
ConnClark
n00b
n00b


Joined: 15 Aug 2007
Posts: 57

PostPosted: Thu Apr 15, 2010 8:20 pm    Post subject: Reply with quote

chrelad,

I have the exact same problem as you emergeing xor-server-1.8 and can't find anything on fixing it.
_________________
In formal computer science advances are made by standing on the shoulders of giants. Linux has shown that, if there are enough of you, you can advance just as far by stepping on each others toes.
Back to top
View user's profile Send private message
chrelad
n00b
n00b


Joined: 03 Sep 2008
Posts: 9

PostPosted: Fri Apr 16, 2010 4:14 pm    Post subject: Bump! Reply with quote

ConnClark,

Yeah, I tried using the x11 overlay, but still get the same problem. I tried asking for help on freenode in the #xorg but the experience wasn't very pleasant. One of the nicer folks in the #xorg channel (ajax) said that I needed to update mesa. So, I did and still got the same error. Hope someone figures this one out soon :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum